E-mail Εκτύπωση

gm_large  ΓλωσσοΜάθεια - Συντακτικό


 

ΣΤΟΙΧΕΙΟ:

Τίτλος προγράμματος

ΣΥΝΤΑΞΗ:

ΠΡΟΓΡΑΜΜΑ ΟΝΟΜΑ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΑΡΑΔΕΙΓΜΑ:

ΠΡΟΓΡΑΜΜΑ Εύρεση_Μεγίστου

ΣΧΟΛΙΑ:

-


ΣΤΟΙΧΕΙΟ:

Δηλώσεις σταθερών

ΣΥΝΤΑΞΗ:

 

 

 


ΣΤΑΘΕΡΕΣ

    ΟΝΟΜΑ_1=ΤΙΜΗ_1

    ΟΝΟΜΑ_2=ΤΙΜΗ_2

    : :

    ΟΝΟΜΑ_Ν=ΤΙΜΗ_Ν

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 


ΣΤΑΘΕΡΕΣ

  π=3.14

  απόσταση=2500

  λέξη='Καλημέρα'

  βρέθηκε=ΑΛΗΘΗΣ

  τέλος_πίνακα=ΨΕΥΔΗΣ

ΣΧΟΛΙΑ:



Σε περίπτωση που δε θα χρησιμοποιηθούν σταθερές, η παράγραφος αυτή είναι δυνατό να

παραληφθεί.

Στους δεκαδικούς αριθμούς σαν υποδιαστολή πρέπει να χρησιμοποιείται η τελεία "."


ΣΤΟΙΧΕΙΟ:

Δηλώσεις μεταβλητών

ΣΥΝΤΑΞΗ:

 

 

 


ΜΕΤΑΒΛΗΤΕΣ

    ΤΥΠΟΣ_1: ΟΝΟΜΑ_Α1, ΟΝΟΜΑ_Α2, ... , ΟΝΟΜΑ_Αn

    ΤΥΠΟΣ_2: ΟΝΟΜΑ_Β1, ΟΝΟΜΑ_Β2, ... , ΟΝΟΜΑ_Βn

    : : : :

    ΤΥΠΟΣ_Ν: ΟΝΟΜΑ_Ν1, ΟΝΟΜΑ_Ν2, ... , ΟΝΟΜΑ_Νn

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 


ΜΕΤΑΒΛΗΤΕΣ

  ΑΚΕΡΑΙΕΣ: i, άθροισμα, πιν[100], α

  ΠΡΑΓΜΑΤΙΚΕΣ: x, Α[20], μέσος_όρος

  ΧΑΡΑΚΤΗΡΕΣ: ονοματεπώνυμα[5000], διεύθυνση

  ΛΟΓΙΚΕΣ: βρέθηκε, τέλος_πίνακα, είναι_αγόρι[192]

ΣΧΟΛΙΑ:


Σε περίπτωση που δε θα χρησιμοποιηθούν μεταβλητές, η παράγραφος αυτή είναι δυνατό να

παραληφθεί.


ΣΤΟΙΧΕΙΟ:

Έναρξη εντολών προγράμματος

ΣΥΝΤΑΞΗ:

ΑΡΧΗ

ΠΑΡΑΔΕΙΓΜΑ:

ΑΡΧΗ

ΣΧΟΛΙΑ:

-


ΣΤΟΙΧΕΙΟ:

Τελεστής εκχώρησης

ΣΥΝΤΑΞΗ:

 


ΟΝΟΜΑ_ΜΕΤΑΒΛΗΤΗΣ <-- ΤΙΜΗ

ή

ΟΝΟΜΑ_ΜΕΤΑΒΛΗΤΗΣ <-- ΠΑΡΑΣΤΑΣΗ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 

 

 


κ <-- 5

απόσταση <-- 48.2

διεύθυνση <-- 'Π. Κορομηλά 56'

βρέθηκε <-- ΑΛΗΘΗΣ

τέλος_πίνακα <-- ΨΕΥΔΗΣ

πιν[51] <-- 10

x <-- (κ*απόσταση-2)/πιν[51]

α <-- α+1

ΣΧΟΛΙΑ:

 

 

 

 


Σαν σύμβολο εκχώρησης χρησιμοποιείται ο συνδυασμός " <-- " λόγω αδυναμίας των

πληκτρολογίων να εμφανίσουν με άμεσο τρόπο το αριστερό βέλος.

Αν επιχειρήσετε να χρησιμοποιήσετε την εντολή εκχώρησης ανάμεσα σε διαφορετικούς τύπους

δεδομένων θα εμφανιστεί σφάλμα ασυμβατότητας τύπων. Η μοναδική περίπτωση που μπορείτε

να κάνετε κάτι τέτοιο είναι όταν αποθηκεύετε μια ΑΚΕΡΑΙΑ τιμή/μεταβλητή/παράσταση σε μια

ΠΡΑΓΜΑΤΙΚΗ μεταβλητή (το αντίθετο δεν είναι δυνατό να γίνει).


ΣΤΟΙΧΕΙΟ:

Εντολή εισόδου

ΣΥΝΤΑΞΗ:

ΔΙΑΒΑΣΕ ΜΕΤΑΒΛΗΤΗ_1, ΜΕΤΑΒΛΗΤΗ_2, ... , ΜΕΤΑΒΛΗΤΗ_Ν

ΠΑΡΑΔΕΙΓΜΑ:

 


ΔΙΑΒΑΣΕ x

ΔΙΑΒΑΣΕ ονοματεπώνυμο, διεύθυνση, κ

ΔΙΑΒΑΣΕ πιν[1], α

ΣΧΟΛΙΑ:


Αφού εισαγάγετε δεδομένα σε μία ΔΙΑΒΑΣΕ θα πρέπει να πατήσετε το πλήκτρο ENTER για

επικύρωση.


ΣΤΟΙΧΕΙΟ:

Εντολή εξόδου

ΣΥΝΤΑΞΗ:

 

 

 


ΓΡΑΨΕ 'ΜΗΝΥΜΑ'

ή

ΓΡΑΨΕ ΜΕΤΑΒΛΗΤΗ_1, ΜΕΤΑΒΛΗΤΗ_2, ... , ΜΕΤΑΒΛΗΤΗ_Ν

ή

ΓΡΑΨΕ ΠΑΡΑΣΤΑΣΗ_1, ΠΑΡΑΣΤΑΣΗ_2, ... , ΠΑΡΑΣΤΑΣΗ_Ν

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 


ΓΡΑΨΕ 'Δώσε έναν αριθμό'

ΓΡΑΨΕ άθροισμα

ΓΡΑΨΕ 'Μέσος όρος = ', άθροισμα/πλήθος

ΓΡΑΨΕ ονοματεπώνυμο, διεύθυνση

ΓΡΑΨΕ 'Η ', κ, 'ή τιμή του πίνακα Π είναι ίση με:', Π[Κ]

ΣΧΟΛΙΑ:


 

 

 

 

 

 

 

 

 

 

 


Αν χρησιμοποιήσετε τη ΓΡΑΨΕ για να δείτε την τιμή μιας λογικής μεταβλητής/παράστασης, θα

εμφανιστεί η λέξη ΑΛΗΘΗΣ ή η λέξη ΨΕΥΔΗΣ.

Μετά την εκτέλεση μιας ΓΡΑΨΕ η γραφίδα μετακινείται αυτόματα στην αρχή της επόμενης

γραμμής.

Η εντολή ΓΡΑΨΕ χωρίς καθόλου παραμέτρους αφήνει μια κενή γραμμή στην οθόνη (χρήσιμο για

διαχωρισμό στοιχείων).

 

Η ΓλωσσοΜάθεια, για πιο ευανάγνωστα αποτελέσματα, υποστηρίζει εκτός από τη ΓΡΑΨΕ και την

εντολή "ΓΡΑΨΕ_" (δηλ. με μια κάτω-παύλα).

Η εντολή αυτή εμφανίζει τιμές ή μηνύματα στην οθόνη, ΑΛΛΑ ΔΕΝ ΜΕΤΑΚΙΝΕΙ ΤΗ ΓΡΑΦΙΔΑ ΣΤΗΝ

ΕΠΟΜΕΝΗ ΓΡΑΜΜΗ ΤΗΣ ΟΘΟΝΗΣ. Κάτι τέτοιο μπορεί να φανεί ιδιαίτερα χρήσιμο σε περιπτώσεις

που προτιμάται η διατεταγμένη εμφάνιση δεδομένων, όπως π.χ. στους διδιάστατους πίνακες.

Αυτό το πρόσθετο χαρακτηριστικό υλοποιήθηκε για πρακτικούς μόνο σκοπούς

και δεν περιλαμβάνεται στο μάθημα της ΑΕΠΠ


ΣΤΟΙΧΕΙΟ:

Δομή επιλογής "ΑΝ"

ΣΥΝΤΑΞΗ:

 

 


 

 

 

 

 

 

 

 

 

 


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


ΑΝ ΣΥΝΘΗΚΗ_1 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_1]

ΤΕΛΟΣ_ΑΝ

ή

ΑΝ ΣΥΝΘΗΚΗ_1 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_1]

ΑΛΛΙΩΣ

    [ΕΝΤΟΛΕΣ_2]

ΤΕΛΟΣ_ΑΝ

ή

ΑΝ ΣΥΝΘΗΚΗ_1 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_1]

ΑΛΛΙΩΣ_ΑΝ ΣΥΝΘΗΚΗ_2 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_2]

ΑΛΛΙΩΣ_ΑΝ ΣΥΝΘΗΚΗ_3 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_3]

: :

ΑΛΛΙΩΣ_ΑΝ ΣΥΝΘΗΚΗ_Ν ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_Ν]

ΑΛΛΙΩΣ

    [ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΑΝ

ή

ΑΝ ΣΥΝΘΗΚΗ_1 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_1]

ΑΛΛΙΩΣ_ΑΝ ΣΥΝΘΗΚΗ_2 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_2]

ΑΛΛΙΩΣ_ΑΝ ΣΥΝΘΗΚΗ_3 ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_3]

: :

ΑΛΛΙΩΣ_ΑΝ ΣΥΝΘΗΚΗ_Ν ΤΟΤΕ

    [ΕΝΤΟΛΕΣ_Ν]

ΤΕΛΟΣ_ΑΝ

ΠΑΡΑΔΕΙΓΜΑ:

 


 

 

 

 

 

 

 

 


 

 

 

 

 


 

 

 

 

 

 

 

 

 

 


 

 

 

 

 


ΑΝ x>0 ΤΟΤΕ

  ΓΡΑΨΕ 'Θετικός'

ΤΕΛΟΣ_ΑΝ 

 

ΑΝ x>0 ΤΟΤΕ

  ΓΡΑΨΕ 'Θετικός'

ΑΛΛΙΩΣ

  ΓΡΑΨΕ 'Αρνητικός ή μηδέν'

ΤΕΛΟΣ_ΑΝ

 

ΑΝ x>0 ΤΟΤΕ

  ΓΡΑΨΕ 'Θετικός'

ΑΛΛΙΩΣ_ΑΝ x<0 ΤΟΤΕ

  ΓΡΑΨΕ 'Αρνητικός'

ΑΛΛΙΩΣ

  ΓΡΑΨΕ 'Μηδέν'

ΤΕΛΟΣ_ΑΝ

 

ΑΝ x>0 ΤΟΤΕ

  ΓΡΑΨΕ 'Θετικός'

ΑΛΛΙΩΣ_ΑΝ x<0 ΤΟΤΕ

  ΓΡΑΨΕ 'Αρνητικός'

ΤΕΛΟΣ_ΑΝ

 

ΑΝ x>0 Ή x<0 ΤΟΤΕ

  ΓΡΑΨΕ 'Διάφορος του μηδενός'

ΤΕΛΟΣ_ΑΝ

 

ΑΝ ΟΧΙ x<>0 ΤΟΤΕ

  ΓΡΑΨΕ 'Ίσος με μηδέν'

ΤΕΛΟΣ_ΑΝ

 

ΑΝ x>=100 ΚΑΙ x<=999 ΤΟΤΕ

  ΓΡΑΨΕ 'Τριψήφιος'

ΤΕΛΟΣ_ΑΝ

ΣΧΟΛΙΑ:

 


Οι συνδυασμοί ">=", "<=" και "<>" χρησιμοποιούνται για τις έννοιες "μεγαλύτερο-ίσο",

"μικρότερο-ίσο" και "διάφορο", λόγω αδυναμίας των πληκτρολογίων να εμφανίσουν με άμεσο

τρόπο αυτά τα μαθηματικά σύμβολα.


ΣΤΟΙΧΕΙΟ:

Δομή επιλογής "ΕΠΙΛΕΞΕ"

ΣΥΝΤΑΞΗ:

 

 

 

 

 

 

 

 


 

 

 

 

 


 

 

 

 


ΕΠΙΛΕΞΕ ΟΝΟΜΑ_ΜΕΤΑΒΛΗΤΗΣ_Η_ΟΝΟΜΑ_ΠΑΡΑΣΤΑΣΗΣ

    ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Α1, ΤΙΜΗ_Α2, ... , ΤΙΜΗ_Αn

        [ΕΝΤΟΛΕΣ]

    ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Β1, ΤΙΜΗ_Β2, ... , ΤΙΜΗ_Βn

        [ΕΝΤΟΛΕΣ]

    : :

    ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Ν1, ΤΙΜΗ_Ν2, ... , ΤΙΜΗ_Νn

        [ΕΝΤΟΛΕΣ]

    ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ

        [ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ή

ΕΠΙΛΕΞΕ ΟΝΟΜΑ_ΜΕΤΑΒΛΗΤΗΣ_Η_ΟΝΟΜΑ_ΠΑΡΑΣΤΑΣΗΣ

    ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Α1, ΤΙΜΗ_Α2, ... , ΤΙΜΗ_Αn

        [ΕΝΤΟΛΕΣ]

    ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Β1, ΤΙΜΗ_Β2, ... , ΤΙΜΗ_Βn

        [ΕΝΤΟΛΕΣ]

    : :

    ΠΕΡΙΠΤΩΣΗ ΤΙΜΗ_Ν1, ΤΙΜΗ_Ν2, ... , ΤΙΜΗ_Νn

        [ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ΠΑΡΑΔΕΙΓΜΑ:


 

 


 

 

 


 

 

 


 

 

 


ΕΠΙΛΕΞΕ x

  ΠΕΡΙΠΤΩΣΗ 1

    ΓΡΑΨΕ 'Ένα'

  ΠΕΡΙΠΤΩΣΗ 2

    ΓΡΑΨΕ 'Δύο'

  ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ

    ΓΡΑΨΕ 'Ούτε ένα ούτε δύο'

ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ


ΕΠΙΛΕΞΕ 5*α-2

  ΠΕΡΙΠΤΩΣΗ 1..9

    ΓΡΑΨΕ 'Μονοψήφιος'

  ΠΕΡΙΠΤΩΣΗ 10..99

    ΓΡΑΨΕ 'Διψήφιος'

  ΠΕΡΙΠΤΩΣΗ 100..999, 50000

    ΓΡΑΨΕ 'Τριψήφιος ή 50000'

ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ΣΧΟΛΙΑ:

-


ΣΤΟΙΧΕΙΟ:

Δομή επανάληψης "ΓΙΑ"

ΣΥΝΤΑΞΗ:

 

 

 

 

 


ΓΙΑ ΜΕΤΑΒΛΗΤΗ ΑΠΟ ΑΡΧΙΚΗ_ΤΙΜΗ ΜΕΧΡΙ ΤΕΛΙΚΗ_ΤΙΜΗ

    [ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ή

ΓΙΑ ΜΕΤΑΒΛΗΤΗ ΑΠΟ ΑΡΧΙΚΗ_ΤΙΜΗ ΜΕΧΡΙ ΤΕΛΙΚΗ_ΤΙΜΗ ΜΕ ΒΗΜΑ ΤΟ_ΒΗΜΑ

    [ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 


 

 

 

 

 


 

 

 

 


 

 

 

 

 


ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10

  ΔΙΑΒΑΣΕ πιν[κ]

  ΓΡΑΨΕ κ, πιν[κ]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΓΙΑ i ΑΠΟ 7*x ΜΕΧΡΙ α+α/2

  ΓΡΑΨΕ i, x

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΓΙΑ i ΑΠΟ 15 ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1

  ΓΡΑΨΕ 'Το τετράγωνο του i είναι: ', i*i

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΓΙΑ i ΑΠΟ κ ΜΕΧΡΙ α ΜΕ ΒΗΜΑ μ

  ΓΡΑΨΕ 'Το τετράγωνο του i είναι: ', i^2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 0.3

  ΓΡΑΨΕ κ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΓΙΑ i ΑΠΟ 20 ΜΕΧΡΙ 10 ΜΕ ΒΗΜΑ -0.2

  ΓΡΑΨΕ 'i=', i

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΣΧΟΛΙΑ:

 



Αν το ΒΗΜΑ είναι θετικό και η αρχική τιμή είναι μεγαλύτερη από την τελική, οι εσωτερικές εντολές

της ΓΙΑ δε θα εκτελεστούν ούτε μία φορά.

Το ίδιο θα συμβεί και στην περίπτωση που το βήμα είναι αρνητικό και η αρχική τιμή είναι

μικρότερη από την τελική.


ΣΤΟΙΧΕΙΟ:

Δομή επανάληψης "ΟΣΟ"

ΣΥΝΤΑΞΗ:

 


ΟΣΟ ΣΥΝΘΗΚΗ ΕΠΑΝΑΛΑΒΕ

    [ΕΝΤΟΛΕΣ]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 

 


 

 

 

 


μ <-- 1

ΟΣΟ μ<10 ΕΠΑΝΑΛΑΒΕ

  ΓΡΑΨΕ 'Το τετράγωνο του ', μ, ' είναι: ', μ*μ

  μ <-- μ+1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


κ <-- 100

ΟΣΟ κ>50 ΚΑΙ x<>0 ΕΠΑΝΑΛΑΒΕ

  ΔΙΑΒΑΣΕ x

  ΓΡΑΨΕ x*x+5*x-2

  κ <-- κ-3

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΣΧΟΛΙΑ:

-


ΣΤΟΙΧΕΙΟ:

Δομή επανάληψης "ΜΕΧΡΙΣ_ΟΤΟΥ"

ΣΥΝΤΑΞΗ:

 


ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    [ΕΝΤΟΛΕΣ]

ΜΕΧΡΙΣ_ΟΤΟΥ ΣΥΝΘΗΚΗ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 

 

 

 

 


ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε ένα διψήφιο αριθμό:'

  ΔΙΑΒΑΣΕ αριθμ

ΜΕΧΡΙΣ_ΟΤΟΥ αριθμ>=10 ΚΑΙ αριθμ<=99


i <-- 1

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ i*i

  i <-- i+1

ΜΕΧΡΙΣ_ΟΤΟΥ i*i>100

ΣΧΟΛΙΑ:

-


ΣΤΟΙΧΕΙΟ:

Τελεστές "DIV" και "MOD"

ΣΥΝΤΑΞΗ:


ΜΕΤΑΒΛΗΤΗ_Η_ΠΑΡΑΣΤΑΣΗ DIV ΜΕΤΑΒΛΗΤΗ_Η_ΠΑΡΑΣΤΑΣΗ

ΜΕΤΑΒΛΗΤΗ_Η_ΠΑΡΑΣΤΑΣΗ MOD ΜΕΤΑΒΛΗΤΗ_Η_ΠΑΡΑΣΤΑΣΗ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 


λ <-- x DIV 2

y <-- (κ^2-34) MOD (α/2)

ΑΝ x MOD 2=0 ΤΟΤΕ

    ΓΡΑΨΕ 'Ο αριθμός x είναι ΑΡΤΙΟΣ!'

ΤΕΛΟΣ_ΑΝ

ΣΧΟΛΙΑ:


 


DIV: Ακέραιο πηλίκο (π.χ. 5 DIV 2 = 2)

MOD: Ακέραιο υπόλοιπο διαίρεσης (π.χ. 10 MOD 3 = 1)

Οι τελεστές αυτοί εφαρμόζονται μόνο σε ΑΚΕΡΑΙΕΣ τιμές/παραστάσεις/μεταβλητές και

επιστρέφουν αριθμούς τύπου ΑΚΕΡΑΙΟΥ.


ΣΤΟΙΧΕΙΟ:

Ενσωματωμένες μαθηματικές συναρτήσεις

ΣΥΝΤΑΞΗ:

 

 

 

 

 

 

 


ΗΜ(X) :

ΣΥΝ(X) :

ΕΦ(X) :

Τ_Ρ(X) :

ΛΟΓ(X) :

Ε(X) :

Α_Μ(X) :

Α_Τ(X) :

Α^Χ :

Ημίτονο του Χ

Συνημίτονο του Χ

Εφαπτομένη του Χ

Τετραγωνική ρίζα του Χ

Φυσικός λογάριθμος του Χ

eX

Ακέραιο μέρος του Χ

Απόλυτη τιμή του Χ

Ύψωση του Α στη δύναμη Χ

ΠΑΡΑΔΕΙΓΜΑ:


ΔΙΑΒΑΣΕ α, β, γ, δ

ΓΡΑΨΕ ΗΜ(α), Τ_Ρ(β), Α_Τ(γ), δ^3, κ^(-2), x^(4*y-8), 5^3.91

ΣΧΟΛΙΑ:

Η συνάρτηση Α_Μ() επιστρέφει αριθμό τύπου ΑΚΕΡΑΙΟΥ.


ΣΤΟΙΧΕΙΟ:

Τμηματικός Προγραμματισμός - ΔΙΑΔΙΚΑΣΙΕΣ

ΣΥΝΤΑΞΗ:

 

 

 

 


ΔΙΑΔΙΚΑΣΙΑ ΟΝΟΜΑ(ΠΑΡ_1, ΠΑΡ_2, ... ΠΑΡ_Ν)

ΜΕΤΑΒΛΗΤΕΣ

    [δήλωση παραμέτρων και τοπικών μεταβλητών]

ΑΡΧΗ

    [εντολές]

ΤΕΛΟΣ _ΔΙΑΔΙΚΑΣΙΑΣ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 


ΔΙΑΔΙΚΑΣΙΑ Διπλασίασε(αριθμός)

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: αριθμός

ΑΡΧΗ

  αριθμός <-- 2*αριθμός

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΧΟΛΙΑ:

 


 

 


Οι διαδικασίες επιστρέφουν αποτελέσματα μέσω των παραμέτρων τους.

Συνεπώς, αλλαγή στην τιμή μιας παραμέτρου που θα γίνει μέσα σε μια διαδικασία, θα συνεχίσει να

υφίσταται και μετά την επιστροφή στο κύριο πρόγραμμα.

Για το λόγο αυτό μπορείτε να χρησιμοποιείτε σαν παραμέτρους μόνο μεταβλητές και όχι σταθερές

ή αριθμητικές παραστάσεις.

Οι διαδικασίες καλούνται με την εντολή ΚΑΛΕΣΕ, π.χ.: ΚΑΛΕΣΕ ΔΙΠΛΑΣΙΑΣΕ(Χ)


ΣΤΟΙΧΕΙΟ:

Τμηματικός Προγραμματισμός - ΣΥΝΑΡΤΗΣΕΙΣ

ΣΥΝΤΑΞΗ:

 

 

 

 

 


ΣΥΝΑΡΤΗΣΗ ΟΝΟΜΑ(ΠΑΡ_1, ΠΑΡ_2, ... ΠΑΡ_Ν): ΤΥΠΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΜΕΤΑΒΛΗΤΕΣ

    [δήλωση παραμέτρων και τοπικών μεταβλητών]

ΑΡΧΗ

    [εντολές]

    ΟΝΟΜΑ <-- τιμή

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΠΑΡΑΔΕΙΓΜΑ:

 

 

 

 


ΣΥΝΑΡΤΗΣΗ Τρίτη_δύναμη(αριθμός)

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: αριθμός

ΑΡΧΗ

  Τρίτη_δύναμη <-- αριθμός^3

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΧΟΛΙΑ:

 

 

 

 

 


Οι συναρτήσεις επιστρέφουν αποτέλεσμα μέσω του ονόματός τους.

Συνεπώς, αλλαγή στην τιμή μιας παραμέτρου που θα γίνει μέσα σε μια συνάρτηση, παύει να

υφίσταται μετά την επιστροφή στο κύριο πρόγραμμα.

Για το λόγο αυτό μπορείτε να χρησιμοποιείτε σαν παραμέτρους μεταβλητές, σταθερές ή

αριθμητικές παραστάσεις.

Οι συναρτήσεις καλούνται όπως και οι ενσωματωμένες μαθηματικές συναρτήσεις της

ψευδογλώσσας, π.χ.: ΓΡΑΨΕ ΤΡΙΤΗ_ΔΥΝΑΜΗ(34)


ΣΤΟΙΧΕΙΟ:

Δήλωση τερματισμού προγράμματος

ΣΥΝΤΑΞΗ:

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΟΝΟΜΑ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΑΡΑΔΕΙΓΜΑ:

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_μεγίστου

ΣΧΟΛΙΑ:

-

 

  < Προηγούμενο: ΓλωσσοΜάθεια - Γενικά
Επόμενο: ΓλωσσοΜάθεια - Φωτογραφίες >  
 
Κυριακή 27 Σεπτεμβρίου 2020