Τώρα είναι Πέμ 04 Ιουν 2020 01:37 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Σχολικος Διαγωνισμος
ΔημοσίευσηΔημοσιεύτηκε: Τρί 11 Μαρ 2008 05:41 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 11 Μαρ 2008 05:28 pm
Δημοσιεύσεις: 4
Syntax: [ Download ] [ Hide ]
Θα σας ημουν υποχρεος αν θα μπορουσατε να λυσετε το εξης :


Σε ενα σχολικο διαγωνισμο συμμετειχαν 100 μαθητες απο 30 διαφορετικα σχολεια
Να υλοποιησετε αλγοριθμο που:

1.να καταχωριζει σε καταλληλους πινακες το ονοματεπωνυμο , την ταξη, το σχολειο και τον βαθμο
που πετυχε καθε μαθητης,λαμβανοντας υποψη οτι αποδεκτες τιμες για την ταξη ειναι μονο οι
'Α' ή 'Β' ή 'Γ', οι βαθμοι πρεπει να ειναι μεταξυ 1-100,ενώ ως σχολειο καταχωρεται ενας ακεραιος αριθμος
(κωδικος) απο 1 ως το 30.

2.να καταχωρει σε καταλληλο πινακα το ονομα καθε σχολειου

3.να υπολογιζει κ να καταχωρει σε ενα νεο πινακα συχνοτητων F[30] , ποσοι μαθητες απο καθε σχολειο
ελαβαν μερος.

4.να βρισκει το ποσοστο τψν μαθητων της Β ταξης.

5.να βρισκει κ να εμφανιζει τα ονοματα κ τα σχολεια των νικητων του διαγωνισμου για καθε ταξη,βρισκοντας τον μαθητη ή τους μαθητες με την υψηλοτερη βαθμολογια για καθε ταξη.
Να λαβετε υποψη σας οτι υπαρχουν περιπτωσεις ισοβαθμιας.

6.Να ζητα απο το χρηστη ενα ονομα μαθητη κ αν αυτο υπαρχει, να εμφανιζει την ταξη,τον βαθμο κ το σχολειο του, διαφορετικα ενα μηνυμα <Δεν Υπαρχει>.

7.Να ζητα απο το χρηστη ενα ονομα σχολειου κ αν αυτο υπαρχει, να εμφανιζει τα στοιχεια των μαθητων αυτου του σχολειου που ελαβαν μερος στο διαγωνισμο, διαφορετικα μυνημα < δεν υπαρχει >.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Σχολικος Διαγωνισμος
ΔημοσίευσηΔημοσιεύτηκε: Τετ 26 Μαρ 2008 01:30 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  SXOLIKOS_DIAGONISMOS
!****************************************************************
!* PROGRAM MADE BY PERIPTERO                                    *
!* EMAIL periptero at gmail dot com                             *
!* Το παρακάτω πρόγραμμα θεωρώ ότι ξεφεύγει από τους σκοπούς    *
!* του μαθήματος ΑΕΠΠ. Πιστεύω ότι είναι ανωτέρου επιπέδου      *
!****************************************************************
ΣΤΑΘΕΡΕΣ
  N=100
  M=30
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I,J,BATHMOS[N],SXOLEIO[N], KOD, SUM1, MAX1, MAX2, MAX3, FLAG, FLAG1
  ΠΡΑΓΜΑΤΙΚΕΣ:  F[M], MO_B
  ΧΑΡΑΚΤΗΡΕΣ: ONOMA[N], TAXH[N], ONOMA_SX[M], ONOMA_MATHITI, ONOMA_SXOLEIOU
ΑΡΧΗ
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  N
    ΓΡΑΨΕ 'DOSE TO ONOMATEPONYMO TOU MATHITI'
    ΔΙΑΒΑΣΕ ONOMA[I]
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'DOSE THN TAJH TOU MATHITI (A η B η Γ)'
      ΔΙΑΒΑΣΕ TAXH[I]
    ΜΕΧΡΙΣ_ΟΤΟΥ TAXH[I]='Α' Η TAXH[I]='Β' Η TAXH[I]='Γ'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'DOSE TO BATHMO (1-100)'
      ΔΙΑΒΑΣΕ BATHMOS[I]
    ΜΕΧΡΙΣ_ΟΤΟΥ BATHMOS[I]>0 ΚΑΙ BATHMOS[I]<101
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'DOSE TON KODIKO TOU SXOLEIOU (1-30)'
      ΔΙΑΒΑΣΕ SXOLEIO[I]
    ΜΕΧΡΙΣ_ΟΤΟΥ SXOLEIO[I]>0 ΚΑΙ SXOLEIO[I]<31
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  M
    ΓΡΑΨΕ 'DOSE TO ONOMA TOU SXOLEIOU ΜΕ KODIKO: ', I
    ΔΙΑΒΑΣΕ ONOMA_SX[I]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  M
    F[I] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  N
    KOD <-- SXOLEIO[I]
    F[KOD] <-- F[KOD]+SXOLEIO[I]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  M
    F[I] <-- F[I]/M
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  SUM1 <-- 0
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  N
    ΑΝ TAXH[I]='Β'  ΤΟΤΕ
      SUM1 <-- SUM1+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  MO_B <-- SUM1/N
  MO_B <-- MO_B*100
  ΓΡΑΨΕ 'MO= ', MO_B, '%'
  MAX1 <-- 0
  MAX2 <-- 0
  MAX3 <-- 0
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  N
    ΑΝ    TAXH[I]='Α'  ΤΟΤΕ
      ΑΝ BATHMOS[I]>MAX1  ΤΟΤΕ
        MAX1 <-- BATHMOS[I]
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ TAXH[I]='Β'  ΤΟΤΕ
      ΑΝ BATHMOS[I]>MAX2  ΤΟΤΕ
        MAX2 <-- BATHMOS[I]
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ BATHMOS[I]>MAX3  ΤΟΤΕ
        MAX3 <-- BATHMOS[I]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  N
    ΑΝ BATHMOS[I]=MAX1  ΤΟΤΕ
      ΓΡΑΨΕ TAXH[I],ONOMA[I],BATHMOS[I],SXOLEIO[I]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ BATHMOS[I]=MAX2  ΤΟΤΕ
      ΓΡΑΨΕ TAXH[I],ONOMA[I],BATHMOS[I],SXOLEIO[I]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ BATHMOS[I]=MAX3  ΤΟΤΕ
      ΓΡΑΨΕ TAXH[I],ONOMA[I],BATHMOS[I],SXOLEIO[I]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'DOSE TO ONOMA TOU MATHITI'
  ΔΙΑΒΑΣΕ ONOMA_MATHITI
  FLAG <-- 0
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  N
    ΑΝ ONOMA_MATHITI=ONOMA[I]  ΤΟΤΕ
      ΓΡΑΨΕ TAXH[I], BATHMOS[I], SXOLEIO[I]
      FLAG <-- 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ FLAG=0  ΤΟΤΕ
    ΓΡΑΨΕ 'DEN YPARXEI'
  ΤΕΛΟΣ_ΑΝ
  FLAG1 <-- 0
  ΓΡΑΨΕ 'DOSE TO ONOMA TOU SXOLEIOU'
  ΔΙΑΒΑΣΕ ONOMA_SXOLEIOU
  ΓΙΑ I  ΑΠΟ  1  ΜΕΧΡΙ  M
    ΑΝ ONOMA_SXOLEIOU=ONOMA_SX[I]  ΤΟΤΕ
      ΓΙΑ J  ΑΠΟ  1    ΜΕΧΡΙ  N
        ΑΝ SXOLEIO[J]=I  ΤΟΤΕ
          ΓΡΑΨΕ ONOMA[J], BATHMOS[J], TAXH[J]
          FLAG1 <-- 1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ FLAG1=0  ΤΟΤΕ
    ΓΡΑΨΕ 'TO SXOLEIO DEN YPARXEI'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ




 


Αρκετά δύσκολο πρόγραμμα.
Ελπίζω να βοήθησα


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Σχολικος Διαγωνισμος
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 27 Μαρ 2008 12:41 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 11 Μαρ 2008 05:28 pm
Δημοσιεύσεις: 4
βοηθησες φιλε ευχαριστω πολυ!!
βεβαια καπως αργα αλλα δε πειραζει μωρε ! οντως αρκετα δυσκολο! :P


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Σχολικος Διαγωνισμος
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 27 Μαρ 2008 03:38 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
Mhn xexnas oti epafiesai sthn kalh prothesi ton allon na sou lysoun ta provlhmata sou. Kai mhn xexnas den exoume apeiro xrono sth diathesi mas oste na eimaste pantaxo parontes.

Filika


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters