Τώρα είναι Τρί 07 Απρ 2020 03:15 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 17 Φεβ 2008 01:45 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 03 Ιουν 2007 05:11 pm
Δημοσιεύσεις: 3
Τοποθεσία: Χανιά
Έχω αυτό το πρόγραμμα. Τι κάνω λάθος; Στο times.txt γράφεται μόνο αυτό:
Παράθεση:
ΐ @

Μπορείτε να βοηθήσετε;
Syntax: [ Download ] [ Hide ]
! Αυτό το πρόγραμμα ελέγχει για ποια ν από το αρχικό που δίνει ο χρήστης μέχρι το 10000 ισχύει ότι
! ν^4 + ν^3 + ν^2 + ν + 1 είναι τέλειο τετράγωνο και γράφει αυτά τα ν σε αρχείο ΤΧΤ
ΠΡΟΓΡΑΜΜΑ ΤΕΣΤ

ΜΕΤΑΒΛΗΤΕΣ
   ΠΡΑΓΜΑΤΙΚΕΣ: ν, μ
   ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: τιμες

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε ν'
  ΔΙΑΒΑΣΕ ν
  μ <-- Τ_Ρ( ν^4 + ν^3 + ν^2 + ν + 1 )
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΑΝ Α_Μ(μ) = μ ΤΟΤΕ
        ΓΡΑΨΕ 'ΝΑΙ!, για ν=', ν
        ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ τιμες, 'C:\times.txt'
        ΑΝΟΙΞΕ_ΑΡΧΕΙΟ τιμες
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ τιμες, 3
        ΓΡΑΨΕ_ΑΡΧΕΙΟ τιμες, ν
        ΚΛΕΙΣΕ_ΑΡΧΕΙΟ τιμες
    ΑΛΛΙΩΣ_ΑΝ Α_Μ(μ) <> μ ΤΟΤΕ
        ΓΡΑΨΕ 'οχι, για ν=', ν
    ΤΕΛΟΣ_ΑΝ
   ν<-- ν+1
   μ<-- Τ_Ρ( ν^4 + ν^3 + ν^2 + ν + 1 )
  ΜΕΧΡΙΣ_ΟΤΟΥ ν= 10001

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 17 Φεβ 2008 08:26 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Τα ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ είναι δυαδικής (binary) μορφής και τα περιεχόμενά τους δεν είναι αναγνώσιμα από προγράμματα που ανοίγουν αρχεία κειμένου (πχ. Σημειωματάριο).
Για να διαβάσεις τις πραγματικές τιμές του αρχείου θα πρέπει να φτιάξεις ένα πρόγραμμα που θα χρησιμοποιεί την εντολή ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ.


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Φεβ 2008 12:32 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 03 Ιουν 2007 05:11 pm
Δημοσιεύσεις: 3
Τοποθεσία: Χανιά
:oops:...
Ευχαριστώ πολύ :D


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters