Τώρα είναι Σάβ 22 Φεβ 2020 06:52 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Συναρτήσεις BOOLE
ΔημοσίευσηΔημοσιεύτηκε: Τρί 12 Φεβ 2008 07:13 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 12 Φεβ 2008 07:08 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  Συναρτήσεις
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ  AND(a, b):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
  ΑΝ a=1 ΚΑΙ b=1 ΤΟΤΕ
    AND <-- 1
  ΑΛΛΙΩΣ
    AND <-- 0
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ  OR(a, b):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
  ΑΝ a=1 ή b=1 ΤΟΤΕ
    OR <-- 1
  ΑΛΛΙΩΣ
    OR <-- 0
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ  NOT(a):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a
ΑΡΧΗ
  ΑΝ a=1 ΤΟΤΕ
    NOT <-- 0
  ΑΛΛΙΩΣ
    NOT <-- 1
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ  XOR(a, b):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
  ΑΝ a=1 ή b=1 και a<>b ΤΟΤΕ
    XOR <-- 1
  ΑΛΛΙΩΣ
    XOR <-- 0
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ  NOR(a, b):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
  ΑΝ a=1 ή b=1 ΤΟΤΕ
    NOR <-- 0
  ΑΛΛΙΩΣ
    NOR <-- 1
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ  NAND(a, b):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
  ΑΝ a=1 και b=1 ΤΟΤΕ
    NAND <-- 0
  ΑΛΛΙΩΣ
    NAND <-- 1
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ  NXOR(a, b):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b
ΑΡΧΗ
  ΑΝ a=b  ΤΟΤΕ
    NXOR <-- 1
  ΑΛΛΙΩΣ
    NXOR <-- 0
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters