Τώρα είναι Τρί 25 Φεβ 2020 01:01 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Θεώρημα Bolzano
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 20 Δεκ 2007 05:32 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
!--------------------------------------------------------
! Το πρόγραμμα ζητάει 2 πραγματικούς αριθμούς α, β για το
! διάστημα Δ (a,b)  και 3 πραγματικούς αριθμούς α, β, γ
! Εφαρμόζει το Θεώρημα του Bolzano για την συνάρτηση
! F(x)=αx^2+βx+γ και υπολογίζει τις ρίζές της και βρίσκει
! ποια ανήκει στο Δ.
! Μαθηματικά Κατευθυνσης Τεχν.Γ΄Λυκ./Παρ.1.8/σελ.192.
! Σας παρακαλώ ελεξτε το και πείτε μου πως θα μπορούσαμε
! να το κάνουμε να λειτουργει για οποιαδήποτε συνάρτηση
! οποιοδήποτε βαθμού.
! --------------------------------------------------------
ΠΡΟΓΡΑΜΜΑ Θεώρημα_Bolzano_Αναπτυγμένη_μορφή
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ,a,b,F1,F2,F3,Δ,ρ1,ρ2,ρ,Χο
ΑΡΧΗ
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '  Ν Ι Κ Ο Σ  Γ Ε Ω Ρ Γ Ι Τ Σ Ο Π Ο Υ Λ Ο Σ   '
  ΓΡΑΨΕ '          2 0 0 7- 2 0 0 8                   '
  ΓΡΑΨΕ '  Α΄ Γ Ε Ν.  Λ Υ Κ Ε Ι Ο   Σ Ι Ν Δ Ο Υ       '
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ 'Ειναι F(x)=αx^2+βx+γ'
  ΓΡΑΨΕ_ 'Δώσε το συντελεστή α:'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ_ 'Δώσε το συντελεστή β:'
  ΔΙΑΒΑΣΕ β
  ΓΡΑΨΕ_ 'Δώσε το συντελεστή γ:'
  ΔΙΑΒΑΣΕ γ

  ΓΡΑΨΕ 'Διαστημα Δ [a,b]'
  ΓΡΑΨΕ_ 'Δώσε την μικρότερη τιμή του διαστήματος Δ a:'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ_ 'Δώσε την μεγαλύτερη τιμή του διαστήματος Δ b:'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ b
    ΑΝ b<a ΤΟΤΕ
      ΓΡΑΨΕ 'Μη έγκυρη τιμη,το b πρέπει να είναι μεγαλύτερο του a (b>a)'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ (b>a)

  ΓΡΑΨΕ 'Η συνάρτηση είναι F(x)=(',α,')x^2+(',β,')x+(',γ,')'
  ΑΝ α=0 και β=0 και γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η F δεν ορίζεται είναι ΣΤΑΘΕΡΗ!!!'
  ΑΛΛΙΩΣ_ΑΝ α=0 και β=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η F είναι ΣΤΑΘΕΡΗ!!'
  ΑΛΛΙΩΣ_ΑΝ α=0 και γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το πεδίο ορίσμου της F είναι όλο το R (Σύνολο Πραγματικών αριθμών)'
  ΑΛΛΙΩΣ_ΑΝ β=0 και γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το πεδίο ορίσμου της F είναι όλο το R (Σύνολο Πραγματικών αριθμών)'
  ΑΛΛΙΩΣ_ΑΝ α=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το πεδίο ορίσμου της F είναι όλο το R (Σύνολο Πραγματικών αριθμών)'
  ΑΛΛΙΩΣ_ΑΝ β=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το πεδίο ορίσμου της F είναι όλο το R (Σύνολο Πραγματικών αριθμών)'
  ΑΛΛΙΩΣ_ΑΝ γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το πεδίο ορίσμου της F είναι όλο το R (Σύνολο Πραγματικών αριθμών)'
  ΑΛΛΙΩΣ_ΑΝ α<>0 και β<>0 και γ<>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το πεδίο ορίσμου της F είναι όλο το R (Σύνολο Πραγματικών αριθμών)'
  ΤΕΛΟΣ_ΑΝ


  ΓΡΑΨΕ 'Εφαρμόζω το Θεώρημα του Bolzano για την f στο [',a,',',b,'].'
  ! Υπολογίζεται η πρώτη συνθήκη του BOLZANO
  ΓΡΑΨΕ '1η Συνθήκη του θεωρήματος του BOLZANO:'
  ΑΝ α=0 και β=0 και γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως σταθερή.'
  ΑΛΛΙΩΣ_ΑΝ α=0 και β=0  ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως σταθερή.'
  ΑΛΛΙΩΣ_ΑΝ α=0 και γ=0  ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως πολυωνυμική.'
  ΑΛΛΙΩΣ_ΑΝ β=0 και γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F δεν είναι συνεχής στο [',a,',',b,'] ως πολυωνυμική.'
  ΑΛΛΙΩΣ_ΑΝ α=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως πολυωνυμική.'
  ΑΛΛΙΩΣ_ΑΝ β=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως πολυωνυμική.'
  ΑΛΛΙΩΣ_ΑΝ γ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως πολυωνυμική.'
  ΑΛΛΙΩΣ_ΑΝ α<>0 και β<>0 και γ<>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η συνάρτηση F είναι συνεχής στο [',a,',',b,'] ως πολυωνυμική.'
  ΤΕΛΟΣ_ΑΝ
  ! Υπολογίζεται η δευτερή συνθήκη του BOLZANO
  ΓΡΑΨΕ '2η Συνθήκη του θεωρήματος του BOLZANO:'
  ΓΡΑΨΕ 'Πρέπει F(',a,')*F(',b,')<0 γιατί:'
  F1 <-- α*a^2+β*a+γ
  ΓΡΑΨΕ 'F(',a,')=',F1
  ΑΝ F1>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Άρα F(',a,')>0'
  ΑΛΛΙΩΣ_ΑΝ F1<0 ΤΟΤΕ
    ΓΡΑΨΕ 'Άρα F(',a,')<0'
  ΤΕΛΟΣ_ΑΝ
  F2 <-- α*b^2+β*b+γ
  ΓΡΑΨΕ 'F(',b,')=',F2
  ΑΝ F2>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Άρα F(',b,')>0'
  ΑΛΛΙΩΣ_ΑΝ F2<0 ΤΟΤΕ
    ΓΡΑΨΕ 'Άρα F(',b,')<0'
  ΤΕΛΟΣ_ΑΝ
  F3 <-- F1*F2
  ΑΝ F3>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Επειδή F(',a,')*F(',b,')>0'
    ΓΡΑΨΕ 'Το Θεώρημα του Bolzano ΔΕΝ ΙΣΧΥΕΙ για την F!!'
  ΑΛΛΙΩΣ_ΑΝ F3=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Επειδή F(',a,')*F(',b,')=0'
    ΓΡΑΨΕ 'Το Θεώρημα του Bolzano ΔΕΝ ΙΣΧΥΕΙ για την F!!'
  ΑΛΛΙΩΣ_ΑΝ F3<0 ΤΟΤΕ
    ΓΡΑΨΕ 'Επειδή F(',a,')*F(',b,')<0'
    ΓΡΑΨΕ 'Το θεώρημα του Bolzano ΙΣΧΥΕΙ!!!'
    ΓΡΑΨΕ 'Σύμφωνα με το ΘΕΩΡΗΜΑ του ΒΟΛΖΑΝΟ υπάρχει τουλάχιστον μια ρίζα χ που ανήκει στο (',a,',',b,')'
    ΓΡΑΨΕ 'Ετσι ώστε το F(x)=0, άρα το: (',α,')*x^2+(',β,')*x+(',γ,')=0'
  ΤΕΛΟΣ_ΑΝ
  ! Επίλυση της Συνάρτησης F(x)=0
  ΑΝ α<>0 ΤΟΤΕ
    Δ <-- β^2-4*α*γ
    ΑΝ Δ<0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
    ΑΛΛΙΩΣ_ΑΝ Δ>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΔΥΟ ΡΙΖΕΣ:'
      ρ1 <-- (-β+Τ_Ρ(Δ))/(2*α)
      ρ2 <-- (-β-Τ_Ρ(Δ))/(2*α)
      ΓΡΑΨΕ 'ρ1 =',ρ1
      ΓΡΑΨΕ 'ρ2 =',ρ2
      ΑΝ (ρ1>a) και (ρ1<b) ΤΟΤΕ
        Χο <-- ρ1
        ΓΡΑΨΕ 'Η ρίζα που ανήκει στο (',a,',',b,')είναι η p=',Χο
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η ρίζα ρ1 =',ρ1,'δεν ανήκει στο [',a,',',b,']'
      ΤΕΛΟΣ_ΑΝ
      ΑΝ (ρ2>a) και (ρ2<b) ΤΟΤΕ
        Χο <-- ρ2
        ΓΡΑΨΕ 'Η ρίζα που ανήκει στο (',a,',',b,')είναι η p=',Χο
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η ρίζα  ρ2 =',ρ2,'δεν ανήκει στο [',a,',',b,']'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΜΙΑ ΔΙΠΛΗ ΡΙΖΑ:'
      ρ <-- (-β/(2*α))
      ΓΡΑΨΕ 'ρ ='
      ΑΝ (ρ>a) και (ρ<b) ΤΟΤΕ
        Χο <-- ρ
        ΓΡΑΨΕ 'Η ρίζα που ανήκει στο (',a,',',b,') είναι η p=',Χο
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η ρίζα ρ=',ρ,'δεν ανήκει στο [',a,',',b,']'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΑΝ β<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΜΙΑ ΡΙΖΑ:'
      ρ <-- (-γ/β)
      ΓΡΑΨΕ 'ρ ='
      ΑΝ (ρ>a) και (ρ<b) ΤΟΤΕ
        Χο <-- ρ
        ΓΡΑΨΕ 'Η ρίζα που ανήκει στο (',a,',',b,') είναι η p=',Χο
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ γ<>0 ΤΟΤΕ
        ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η εξίσωση είναι ΑΟΡΙΣΤΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ '                                  '
  ΓΡΑΨΕ '                                  '
  ΓΡΑΨΕ '|','--------------------------','|'
  ΓΡΑΨΕ '|','Made By "ProskoposEthnoy$"','|'
  ΓΡΑΨΕ '|','--------------------------','|'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters