Τώρα είναι Σάβ 22 Φεβ 2020 06:32 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Απλοποίηση κλάσματος
ΔημοσίευσηΔημοσιεύτηκε: Τετ 31 Οκτ 2007 01:58 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 31 Οκτ 2007 01:48 pm
Δημοσιεύσεις: 3
Τοποθεσία: ΛΕΥΚΑΔΑ
Syntax: [ Download ] [ Hide ]
!-----------------------------------------------------------------
!  Το πρόγραμμα διαβάζει τους όρους ενός κλάσματος,
!  υπολογίζει το μέγιστο κοινό τους διαιρέτη και
!  απλοποιεί το κλάσμα
!-----------------------------------------------------------------
ΠΡΟΓΡΑΜΜΑ ΑΠΛΟΠΟΙΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΡ,ΠΑΡ,ΜΕΚΔ
ΑΡΧΗ

  ΓΡΑΨΕ_ 'Δώσε τον αριθμητή '
  ΔΙΑΒΑΣΕ ΑΡ
  ΓΡΑΨΕ_ 'Δώσε τον παρονομαστή '
  ΔΙΑΒΑΣΕ ΠΑΡ
  ΜΕΚΔ <-- ΜΚΔ(ΑΡ,ΠΑΡ)
  ΓΡΑΨΕ 'Το κλάσμα πρίν την απλοποίηση= ',ΑΡ,'/ ',ΠΑΡ
  ΑΡ <-- ΑΡ  DIV  ΜΕΚΔ
  ΠΑΡ <-- ΠΑΡ DIV  ΜΕΚΔ
  ΓΡΑΨΕ 'Το κλάσμα μετά την απλοποίηση= ',ΑΡ,'/ ',ΠΑΡ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΚΔ
!-------------------------------------------------------
ΣΥΝΑΡΤΗΣΗ  ΜΚΔ(Α,Β):  ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,Ι,Μ,ΒΟΗΘ

ΑΡΧΗ
  ΑΝ Α>Β ΤΟΤΕ
    ΒΟΗΘ <-- Α
    Α <-- Β
    Β <-- ΒΟΗΘ
  ΤΕΛΟΣ_ΑΝ
  Ι <-- 1
  Μ <-- 1
  ΟΣΟ Ι<=Α ΕΠΑΝΑΛΑΒΕ
    ΑΝ (Α MOD Ι=0) ΚΑΙ (Β MOD Ι=0) ΤΟΤΕ
      Μ <-- Ι
    ΤΕΛΟΣ_ΑΝ
    Ι <-- Ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΚΔ <-- Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
takis


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters