Τώρα είναι Σάβ 28 Νοέμ 2020 08:15 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πότε "πέφτει" το Πάσχα;
ΔημοσίευσηΔημοσιεύτηκε: Παρ 04 Ιουν 2004 06:28 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Κάτι που μπορεί να φανεί χρήσιμο...

Syntax: [ Download ] [ Hide ]
! ==========================================================
! Η ημερομηνία του Πάσχα κάποιας χρονολογίας υπολογίζεται ως
! εξής:
!   ΕΤ = η χρονολογία (δεδομένο)
!   Π = η ημερομηνία του Πάσχα (αποτέλεσμα)
!   Θέτουμε:
!     ΕΤ:19 = α
!     ΕΤ:4 = β
!     ΕΤ:7 = γ
!     (19α+16):30 = δ
!     (2β+4γ+6δ):7 = ζ
!   όπου το σύμβολο ":" σημαίνει ΑΚΕΡΑΙΟ ΥΠΟΛΟΙΠΟ ΔΙΑΙΡΕΣΗΣ.
!
! Η ημερομηνία του Πάσχα θα δίνεται από τον τύπο:
!
!                  Π = δ + ζ + 3  Απριλίου
!
! Αν δ+ζ+3 > 30 τότε σημαίνει ότι το Πάσχα πέφτει μέσα στον
! Μάιο. Δηλαδή αν δ+ζ+3=35, η ημερομηνία είναι 5 Μαΐου.
! (ΣΗΜ.: Το Πάσχα πέφτει μόνο Απρίλιο & Μάιο)
!
! Σύμφωνα με τα παραπάνω, να γίνει πρόγραμμα το οποίο:
!   α) Να ζητάει μια χρονολογία.
!   β) Να εμφανίζει την ημερομηνία του Πάσχα αυτής της
!      χρονιάς με σωστή αναφορά του μήνα, για παράδειγμα:
!
!             "Ημερομηνία του Πάσχα: 19 Απριλίου"
!                             ή
!               "Ημερομηνία του Πάσχα: 3 Μαΐου"
! ==========================================================


ΠΡΟΓΡΑΜΜΑ Πάσχα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α,β,γ,δ,ζ,ΕΤ,Π
  ΧΑΡΑΚΤΗΡΕΣ: μήνας

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε τη χρονολογία:'
  ΔΙΑΒΑΣΕ ΕΤ

  α <-- ΕΤ MOD 19
  β <-- ΕΤ MOD 4
  γ <-- ΕΤ MOD 7
  δ <-- (19*α+16) MOD 30
  ζ <-- (2*β+4*γ+6*δ) MOD 7
  Π <-- δ+ζ+3

  ΑΝ Π<=30 ΤΟΤΕ
    μήνας <-- ' Απριλίου'
  ΑΛΛΙΩΣ
    μήνας <-- ' Μαΐου'
    Π <-- Π-30
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'Ημερομηνία του Πάσχα: ', Π, μήνας

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πάσχα

 


ΕΝΔΙΑΦΕΡΟΥΣΕΣ ΠΑΡΑΛΛΑΓΕΣ:

1) Ν.Γ.Π. που θα εμφανίζει τις ημερομηνίες που πέφτει το Πάσχα για την επόμενη 50ετία.

2) Ν.Γ.Π. που θα ελέγχει όλες τις χρονολογίες από φέτος μέχρι το 2.500 μ.Χ. και θα εμφανίζει:
    - την ημερομηνία του πιο "πρώιμου" Πάσχα (=ελάχιστη τιμή ημ/νίας) και τις χρονιές στις οποίες παρατηρείται.
    - την ημερομηνία του πιο "όψιμου" Πάσχα (=μέγιστη τιμή ημ/νίας) και τις χρονιές στις οποίες παρατηρείται.

3) Υπάρχει κάποιος κανόνας σχετικά με τη συχνότητα εμφάνισης των παραπάνω μεγίστων ή ελαχίστων;
(Ν.Γ.Π. που τον αναδεικνύει)


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 22 Οκτ 2007 01:05 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
Παρακάτω φαίνεται η 2η παραλλαγή του παραπάνω προγράμματος που υπολογίζει τις ημερομηνίες του Πάσχα μέχρι το 2500 καθώς και ποια έτη είναι το πιο πρώιμο και πιο το πιο όψιμο Πάσχα.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Πάσχα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α,β,γ,δ,ζ,ΕΤ,Π, min,max, min_ET[30,2],max_ET[30,2],i,j,k
  ΧΑΡΑΚΤΗΡΕΣ: μήνας

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε τη χρονολογία:'
  ΔΙΑΒΑΣΕ ΕΤ
  max <-- 1
  min <-- 61
  i <-- 1
  j <-- 1
  k <-- 1

  ΟΣΟ ΕΤ < 2501  ΕΠΑΝΑΛΑΒΕ

    α <-- ΕΤ MOD 19
    β <-- ΕΤ MOD 4
    γ <-- ΕΤ MOD 7
    δ <-- (19*α+16) MOD 30
    ζ <-- (2*β+4*γ+6*δ) MOD 7
    Π <-- δ+ζ+3

    ΑΝ max<= Π ΤΟΤΕ
      max <-- Π
      max_ET[i,1] <-- ΕΤ
      max_ET[i,2] <-- max
      i <-- i+1
    ΤΕΛΟΣ_ΑΝ

    ΑΝ min>= Π ΤΟΤΕ
      min <-- Π
      min_ET[j,1] <-- ΕΤ
      min_ET[j,2] <-- min
      j <-- j+1
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Π<=30 ΤΟΤΕ
      μήνας <-- ' Απριλίου'
    ΑΛΛΙΩΣ
      μήνας <-- ' Μαΐου'
      Π <-- Π-30
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Ημερομηνία του Πάσχα: ', Π, μήνας, ΕΤ
    ΕΤ <-- ΕΤ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΟΣΟ k<j ΕΠΑΝΑΛΑΒΕ
    ΑΝ min_ET[k,2]=min ΤΟΤΕ
      ΓΡΑΨΕ 'Το πιο πρώιμο Πάσχα πέφτει το έτος : ', min_ET[k,1], ' στις :', min, ' Απριλίου'
    ΤΕΛΟΣ_ΑΝ
    k <-- k+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  k <-- 1
  ΟΣΟ k<i ΕΠΑΝΑΛΑΒΕ
    ΑΝ max_ET[k,2]=max ΤΟΤΕ
      ΑΝ max<=30 ΤΟΤΕ
        ΓΡΑΨΕ 'Το πιο όψιμο Πάσχα πέφτει το έτος : ', max_ET[k,1], ' στις :', max, ' Απριλίου'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Το πιο όψιμο Πάσχα πέφτει το έτος : ', max_ET[k,1], ' στις :', max-30, ' Μαΐου'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    k <-- k+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πάσχα
 


Οι ημερομηνίες που το Πάσχα είναι οι πιο ακραίες φαίνονται παρακάτω:

Το πιο πρώιμο Πάσχα πέφτει το έτος : 2010 στις: 4 Απριλίου
Το πιο πρώιμο Πάσχα πέφτει το έτος : 2105 στις : 4 Απριλίου
Το πιο πρώιμο Πάσχα πέφτει το έτος : 2200 στις : 4 Απριλίου
Το πιο πρώιμο Πάσχα πέφτει το έτος : 2447 στις : 4 Απριλίου
Το πιο όψιμο Πάσχα πέφτει το έτος : 2078 στις : 8 Μαϊου
Το πιο όψιμο Πάσχα πέφτει το έτος : 2173 στις : 8 Μαϊου
Το πιο όψιμο Πάσχα πέφτει το έτος : 2268 στις : 8 Μαϊου


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Πότε "πέφτει" το Πάσχα;
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Οκτ 2008 08:34 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 23 Ιούλ 2008 08:39 pm
Δημοσιεύσεις: 5
nomiza oti dn to eixe postarei kanenas
oriste to diko mou:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Οβελίας

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  a,b,c,d,f,g,y,p

ΑΡΧΗ

  ΓΡΑΨΕ 'δωσε το έτος'
  ΔΙΑΒΑΣΕ y

  a <-- y MOD 19
  b <-- y MOD 4
  c <-- y MOD 7
  d <-- (19*a+16) MOD 30
  f <-- (2*b+4*c+6*d) MOD 7
  g <-- d+f+3

  ΑΝ g<30 ΤΟΤΕ
    p <-- g
    ΓΡΑΨΕ ' Το πάσχα πέφτει στις:',p,'Απρίλη'
  ΤΕΛΟΣ_ΑΝ

  ΑΝ g>30 ΤΟΤΕ
    p <-- g-30
    ΓΡΑΨΕ ' Το πάσχα πέφτει στις:',p,'Μαίου'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Οβελίας


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 30 Ιουν 2009 02:09 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 30 Ιουν 2009 02:00 am
Δημοσιεύσεις: 1
Παράθεση:
Οι ημερομηνίες που το Πάσχα είναι οι πιο ακραίες φαίνονται παρακάτω:

Το πιο πρώιμο Πάσχα πέφτει το έτος : 2010 στις: 4 Απριλίου
Το πιο πρώιμο Πάσχα πέφτει το έτος : 2105 στις : 4 Απριλίου
Το πιο πρώιμο Πάσχα πέφτει το έτος : 2200 στις : 4 Απριλίου
Το πιο πρώιμο Πάσχα πέφτει το έτος : 2447 στις : 4 Απριλίου
Το πιο όψιμο Πάσχα πέφτει το έτος : 2078 στις : 8 Μαϊου
Το πιο όψιμο Πάσχα πέφτει το έτος : 2173 στις : 8 Μαϊου
Το πιο όψιμο Πάσχα πέφτει το έτος : 2268 στις : 8 Μαϊου


Γιατί το καημένο το eortologio http://www.eortologio.gr/arthra/pasxa.php λέει άλλα ? :roll:

Πάσχα 2105: Κυριακή.. 5 Απριλίου !!


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters