Τώρα είναι Δευτ 28 Σεπ 2020 06:12 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 1Γ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 31 Μάιος 2007 03:06 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΜΑΙΟΣ 2007 - ΘΕΜΑ 1Γ
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου σε φυσική γλώσσα κατά βήματα
!
! Βήμα 1:  Αν Α > 0 τότε πήγαινε στο Βήμα 5
! Βήμα 2:  Αν Α = 0 τότε πήγαινε στο Βήμα 7
! Βήμα 3:  Τύπωσε “Αρνητικός’’
! Βήμα 4:  Πήγαινε στο Βήμα 8
! Βήμα 5:  Τύπωσε “Θετικός’’
! Βήμα 6:  Πήγαινε στο Βήμα 8
! Βήμα 7:  Τύπωσε “Μηδέν’’
! Βήμα 8:  Τύπωσε “Τέλος’’
!
! Να κωδικοποιήσετε το τμήμα του αλγορίθμου σε ψευδογλώσσα σύμφωνα με τις αρχές του δομημένου
! προγραμματισμού.
! ===============================================================================================
!
ΠΡΟΓΡΑΜΜΑ ΗΜ_2007_05_1Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α
ΑΡΧΗ
  ΔΙΑΒΑΣΕ Α
  ΑΝ Α > 0 ΤΟΤΕ               ! Το ΔΙΑΒΑΣΕ Α δε χρειάζεται να γραφεί αφού δεν υπάρχει στο τμήμα
    ΓΡΑΨΕ 'Θετικός'           ! αλγορίθμού που έχει δοθεί και ζητείται και πάλι τμήμα αλγορίθμου
  ΑΛΛΙΩΣ_ΑΝ Α = 0 ΤΟΤΕ        ! και όχι ολοκληρωμένος αλγόριθμος.
    ΓΡΑΨΕ 'Μηδέν'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Αρνητικός'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Τέλος'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters