Τώρα είναι Πέμ 18 Ιούλ 2019 04:03 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 3
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:16 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΗΜΕΡΗΣΙΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 3
! ===============================================================================================
! Ο Δείκτης Μάζας του ανθρώπινου Σώματος (ΔΜΣ) υπολογίζεται από το βάρος (Β) σε χλγ. και το ύψος
! (Υ) σε μέτρα με τον τύπο ΔΜΣ = Β/Υ^2. Ο ανωτέρω τύπος ισχύει για άτομα άνω των 18 ετών.
! Το άτομο ανάλογα με την τιμή του ΔΜΣ χαρακτηρίζεται σύμφωνα με τον παρακάτω πίνακα:
!        ----------------------------------
!         ΔΜΣ < 18,5        αδύνατο άτομο
!        18,5 <= ΔΜΣ < 25   κανονικό άτομο
!         25 <= ΔΜΣ < 30    βαρύ άτομο
!         30 <= ΔΜΣ         υπέρβαρο άτομο
!        ----------------------------------
! Να γράψετε αλγόριθμο ο οποίος:
!   α. να διαβάζει την ηλικία, το βάρος και το ύψος του ατόμου
!   β. εάν η ηλικία είναι μεγαλύτερη των 18 ετών, τότε
!      1. να υπολογίζει το ΔΜΣ
!      2. να ελέγχει την τιμή του ΔΜΣ από τον ανωτέρω πίνακα και να εμφανίζει τον αντίστοιχο
!          χαρακτηρισμό
!   γ. εάν η ηλικία είναι μικρότερη ή ίση των 18 ετών, τότε να εμφανίζει το μήνυμα "δεν ισχύει
!      ο δείκτης ΔΜΣ".
! Παρατήρηση : Θεωρήστε ότι το βάρος, το ύψος και η ηλικία είναι θετικοί αριθμοί.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2003_06_3
ΜΕΤΑΒΛΗΤΕΣ                                                            
  ΠΡΑΓΜΑΤΙΚΕΣ: DMS,Υ,Β,AGE
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΗΛΙΚΙΑ, ΒΑΡΟΣ, ΥΨΟΣ'
  ΔΙΑΒΑΣΕ AGE , Β , Υ
  ΑΝ AGE > 18 ΤΟΤΕ
    DMS <-- Β/Υ^2
    ΑΝ DMS < 18.5 ΤΟΤΕ
      ΓΡΑΨΕ 'ΑΔΥΝΑΤΟ ΑΤΟΜΟ'
    ΑΛΛΙΩΣ_ΑΝ DMS < 25 ΤΟΤΕ
      ΓΡΑΨΕ 'KANONIKO ATOMO'
    ΑΛΛΙΩΣ_ΑΝ DMS < 30 ΤΟΤΕ
      ΓΡΑΨΕ 'ΒΑΡΥ ATOMO'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΥΠΕΡΒΑΡΟ ATOMO'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο ΔΕΙΚΤΗΣ ΜΑΖΑΣ ΣΩΜΑΤΟΣ ΔΕΝ ΙΣΧΥΕΙ ΓΙΑ ΗΛΙΚΙΕΣ ΚΑΤΩ ΑΠΟ 18 ΕΤΗ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters