Τώρα είναι Δευτ 16 Σεπ 2019 11:31 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Απρ 2007 11:06 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΙΟΥΝΙΟΣ 2003 - ΘΕΜΑ 2
! ===============================================================================================
! Δίνεται ο πίνακας Α (σχήμα 1) και το παρακάτω τμήμα προγράμματος:
!
!  sum <-- 0
!  ΓΙΑ  i ΑΠΟ 1 ΜΕΧΡΙ 5
!    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
!      ΑΝ i = j TOTE
!        sum < sum + A[i,j]
!      AΛΛΙΩΣ
!        A[i,j] < 0
!      Τέλος_αν
!    Τέλος_επανάληψης
!  Τέλος_επανάληψης
!  γραψε sum
!
! Αυτό το τμήμα προγράμματος χρησιμοποιεί τον πίνακα Α, με τις τιμές των στοιχείων του,
! όπως αυτές φαίνονται παρακάτω.
!            1  -1   7   1   1
!            6   2   0   8  -2
!            4   9   3   3   0
!            3   5  -4   2   1                        
!            0   1   2   0   1
!
! 1. Να συμπληρώσετε τον πίνακα Α με τις τιμές που θα έχουν τα στοιχεία του, μετά την εκτέλεση
!    του τμήματος προγράμματος.
!
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ ES_2003_06_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , j ,A[5,5] , sum
ΑΡΧΗ
  A[1,1] <-- 1
  A[1,2] <-- -1
  A[1,3] <-- 7
  A[1,4] <-- 1
  A[1,5] <-- 1
  A[2,1] <-- 6
  A[2,2] <-- 2
  A[2,3] <-- 0
  A[2,4] <-- 8
  A[2,5] <-- -2
  A[3,1] <-- 4
  A[3,2] <-- 9
  A[3,3] <-- 3
  A[3,4] <-- 3
  A[3,5] <-- 0
  A[4,1] <-- 3
  A[4,2] <-- 5
  A[4,3] <-- -4
  A[4,4] <-- 2
  A[4,5] <-- 1              
  A[5,1] <-- 0
  A[5,2] <-- 1
  A[5,3] <-- 2
  A[5,4] <-- 0
  A[5,5] <-- 1
  sum <-- 0
  ΓΡΑΨΕ '====================='
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
      ΑΝ i = j ΤΟΤΕ
        sum <-- sum + A[i,j]
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ A[i,1] , A[i,2] , A[i,3] , A[i,4] , A[i,5]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '====================='
  ΓΡΑΨΕ sum
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters