Τώρα είναι Δευτ 26 Αύγ 2019 08:09 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Διαφορετικά ψηφία
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 01 Φεβ 2007 12:49 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Φεβ 2007 12:46 pm
Δημοσιεύσεις: 3
Να γινει αλγόριθμος ο οποίος θα εμφανίζει τα διαφορετικά ψηφία ενός αριθμού οσονδήποτε ψηφίων


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 03 Φεβ 2007 12:59 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Θα το βρεις εδω: :wink:
http://spinet.gr/glossomatheia/programs/viewtopic.php?p=661&highlight=#661

_________________
Δίνεις Πανελλαδικές εξετάσεις ???

Τότε έλα στο http://www.glyk.co.nr -> ένα φόρουμ για μαθητές Γ Λυκείου


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 04 Φεβ 2007 04:52 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Φεβ 2007 12:46 pm
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Αριθμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:x,i,y,k
  ΛΟΓΙΚΕΣ: ψηφίο
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τον αριθμό'
  ΔΙΑΒΑΣΕ x
  k <-- x
  ΓΡΑΨΕ 'Τα διαφορετικα ψηφία του αριθμού είναι:'
  ΓΙΑ i από 0 μέχρι 9
    ψηφίο <-- ψευδής
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      y <-- x MOD 10
      x <-- x DIV 10
      ΑΝ y=i ΤΟΤΕ
        ψηφίο <-- αληθής
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ x=0
    ΑΝ ψηφίο=αληθής ΤΟΤΕ
      ΓΡΑΨΕ_ i
    ΤΕΛΟΣ_ΑΝ
    x <-- k
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αριθμοί


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters