Τώρα είναι Κυρ 01 Νοέμ 2020 03:21 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: SUPER DEAL
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 24 Δεκ 2006 05:32 pm 
ΓΕΙΑ ΣΑΣ ΕΙΜΑΙ ΜΑΘΗΤΗΣ ΤΗΣ ΤΡΙΤΗΣ ΛΥΚΕΙΟΥ ΚΑΙ ΣΤΟΝ ΕΛΕΥΘΕΡΟ ΧΡΟΝΟ ΜΟΥ ΕΚΑΝΑ ΑΥΤΟ ΤΟ ΠΡΟΓΡΑΜΜΑ. ΕΙΝΑΙ ΛΙΓΟ ΠΡΟΧΕΙΡΟ ΚΑΙ ΔΕΝ ΠΑΙΖΕΤΑΙ ΑΚΡΙΒΩΣ ΟΠΩΣ ΤΟ ΚΑΝΟΝΙΚΟ ΠΑΙΧΝΙΔΙ ΑΛΛΑ ΕΙΝΑΙ ΠΟΛΥ ΚΟΝΤΑ.
ΠΕΡΙΜΕΝΩ ΠΡΟΤΑΣΕΙΣ ΓΙΑ ΒΕΛΤΙΩΣΕΙΣ :D
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ DEAL
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Κ[20],ΤΕΜΠ,ΠΚΟΥ,ΣΥ,ΠΡ,ΔΕΠ,ΜΑΧΠΡ
  ΑΚΕΡΑΙΕΣ: X,Ι,ΕΠ,Ο,ΚΟΥ,ΤΕΛΚΟΥ
  ΧΑΡΑΚΤΗΡΕΣ: ΔΕ,ΑΝΤ


ΑΡΧΗ
  Κ[1] <-- 0.1
  Κ[2] <-- 0.5
  Κ[3] <-- 50
  Κ[4] <-- 100
  Κ[5] <-- 200
  Κ[6] <-- 500
  Κ[7] <-- 1000
  Κ[8] <-- 2000
  Κ[9] <-- 3000
  Κ[10] <-- 4000
  Κ[11] <-- 5000
  Κ[12] <-- 10000
  Κ[13] <-- 25000
  Κ[14] <-- 50000
  Κ[15] <-- 75000
  Κ[16] <-- 100000
  Κ[17] <-- 200000
  Κ[18] <-- 300000
  Κ[19] <-- 500000
  Κ[20] <-- 20
 !ΑΝΑΚΑΤΩΜΑ ΤΩΝ ΤΙΜΩΝ
  ΓΡΑΨΕ 'SUPER DEAL'
  ΓΡΑΨΕ '!!!!!!! ΓΥΡΙΣΤΕ ΤΟ ΠΛΗΚΤΡΟΛΟΓΙΟ ΣΤΑ ΕΛΛΗΝΙΚΑ!!!!!!!!!'
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑ ΤΥΧΑΙΟ ΘΕΤΙΚΟ  ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ ΜΕΓΑΛΥΤΕΡΟ ΤΟΥ ΕΝΑ'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ X
    ΑΝ X <=1 Ή (X MOD 1)<> 0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΡΙΘΜΟΣ.ΔΩΣΤΕ ΕΝΑ ΤΥΧΑΙΟ ΑΚΕΡΑΙΟ ΘΕΤΙΚΟ ΑΡΙΘΜΟ ΜΕΓΑΛΥΤΕΡΟ ΤΟΥ ΕΝΑ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ X>1 ΚΑΙ (X MOD 1)= 0
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΜΠ <-- Κ[1]
    Κ[1] <-- Κ[16]
    Κ[16] <-- Κ[3]
    Κ[3] <-- Κ[17]
    Κ[17] <-- Κ[2]
    Κ[2] <-- Κ[19]
    Κ[19] <-- Κ[11]
    Κ[11] <-- Κ[8]
    Κ[8] <-- Κ[5]
    Κ[5] <-- Κ[10]
    Κ[10] <-- Κ[13]
    Κ[13] <-- Κ[4]
    Κ[4] <-- Κ[14]
    Κ[14] <-- Κ[18]
    Κ[18] <-- Κ[6]
    Κ[6] <-- Κ[7]
    Κ[7] <-- Κ[9]
    Κ[9] <-- Κ[12]
    Κ[12] <-- Κ[15]
    Κ[15] <-- Κ[20]
    Κ[20] <-- ΤΕΜΠ
    Ι <-- Ι + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=X
 !ΑΡΧΗ ΤΟΥ ΠΑΙΧΝΙΔΙΟΥ
  !ΕΠΙΛΟΓΗ ΚΟΥΤΙΟΥ
  ΓΡΑΨΕ 'ΠΟΙΟ ΚΟΥΤΙ ΘΕΣ; (ΓΡΑΨΕ ΕΝΑ ΑΡΙΘΜΟ ΑΠΟ ΤΟ 1 ΕΩΣ ΤΟ 20)'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΚΟΥ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΚΟΥ>0 ΚΑΙ ΚΟΥ<=20
  ΠΚΟΥ <-- Κ[ΚΟΥ]
  Κ[ΚΟΥ] <-- 0
  !ΠΡΩΤΟΣ ΓΥΡΟΣ
  !ΕΠΙΌΓΗ ΚΟΥΤΙΩΝ
  ΓΡΑΨΕ 'ΑΣ ΑΡΧΙΣΟΥΜΕ ΛΟΙΠΟΝ'
  ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΔΙΑΛΕΞΕΙΣ 5 ΚΟΥΤΙΑ'
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΕΝΑ ΚΟΥΤΙ;'
    ΔΙΑΒΑΣΕ ΕΠ
    ΑΝ ΕΠ>0 ΚΑΙ ΕΠ<=20 ΚΑΙ Κ[ΕΠ]<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΚΟΥΤΙ ',ΕΠ,' ΠΕΡΙΕΧΕΙ '[ΕΠ], 'ΕΥΡΩ'
      Κ[ΕΠ] <-- 0
      Ι <-- Ι+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΡΙΘΜΟΣ Ή ΗΔΗ ΕΠΙΛΕΓΜΕΝΟ ΚΟΥΤΙ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=5
  !ΤΡΑΠΕΖΙΤΗΣ
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΣΥ <-- ΣΥ + Κ[Ο]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ, ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ'
  ΠΡ <--  ΣΥ/55
  ΓΡΑΨΕ' Ο ΤΡΑΠΕΖΙΤΗΣ ΠΡΟΣΦΕΡΕΙ ', ΠΡ, 'ΕΥΡΩ ΓΙΑ ΝΑ ΠΑΡΕΙ ΤΟ ΚΟΥΤΙ ΣΟΥ'
  ΓΡΑΨΕ 'ΘΑ ΣΥΝΕΧΙΣΕΙΣ;(ΑΠΑΝΤΑ ΜΕ Ν ΓΙΑ ΝΑΙ ΚΑΙ Ο ΓΙΑ ΟΧΙ)'
  ΜΑΧΠΡ <-- ΠΡ
  !ΣΥΝΕΧΕΙΑ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- 0
    ΔΙΑΒΑΣΕ ΔΕ
    ΑΝ ΔΕ='Ν' ΤΟΤΕ
      Ι <-- 1
    ΑΛΛΙΩΣ_ΑΝ ΔΕ= 'Ο'ΤΟΤΕ
      ΓΡΑΨΕ 'Ο ΤΡΑΠΕΖΙΤΗΣ ΑΓΟΡΑΣΕ ΤΟ ΚΟΥΤΙ ΣΟΥ ΓΙΑ',ΠΡ, 'ΕΥΡΩ'
      ΓΡΑΨΕ 'ΑΣ ΔΟΥΜΕ ΤΙ ΘΑ ΚΕΡΔΙΖΕΣ ΑΝ ΣΥΝΕΧΙΖΕΣ'
      ΔΕΠ <-- ΠΡ
      Ι <-- 1
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=1
 !ΔΕΥΤΕΡΟΣ ΓΥΡΟΣ
 !ΕΠΙΛΟΓΗ ΚΟΥΤΙΩΝ
  ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΔΙΑΛΕΞΕΙΣ ΤΕΣΣΕΡΑ ΑΚΟΜΑ ΚΟΥΤΙΑ'
  ΓΡΑΨΕ 'ΥΠΕΝΘΙΜΙΖΩ ΟΤΙ ΤΑ ΚΟΥΤΙΑ ΠΟΥ ΜΕΝΟΥΝ ΕΙΝΑΙ:'
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ Κ[Ο]>0 ΤΟΤΕ
      ΓΡΑΨΕ Ο
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΕΝΑ ΚΟΥΤΙ;'
    ΔΙΑΒΑΣΕ ΕΠ
    ΑΝ ΕΠ>0 ΚΑΙ ΕΠ<=20 ΚΑΙ Κ[ΕΠ]<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΚΟΥΤΙ ',ΕΠ,' ΠΕΡΙΕΧΕΙ '[ΕΠ], 'ΕΥΡΩ'
      Κ[ΕΠ] <-- 0
      Ι <-- Ι+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΡΙΘΜΟΣ Ή ΗΔΗ ΕΠΙΛΕΓΜΕΝΟ ΚΟΥΤΙ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=4
  !ΤΡΑΠΕΖΙΤΗΣ
  ΣΥ <-- 0
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΣΥ <-- ΣΥ + Κ[Ο]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ, ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ'
  ΠΡ <--  ΣΥ/30
  ΓΡΑΨΕ' Ο ΤΡΑΠΕΖΙΤΗΣ ΠΡΟΣΦΕΡΕΙ ', ΠΡ, 'ΕΥΡΩ ΓΙΑ ΝΑ ΠΑΡΕΙ ΤΟ ΚΟΥΤΙ ΣΟΥ'
  ΜΑΧΠΡ <-- ΠΡ
  ΑΝ ΔΕ='Ν'  ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ ' ΘΑ ΣΥΝΕΧΙΣΕΙΣ;(ΑΠΑΝΤΑ ΜΕ Ν ΓΙΑ ΝΑΙ ΚΑΙ Ο ΓΙΑ ΟΧΙ)'
      Ι <-- 0
      ΔΙΑΒΑΣΕ ΔΕ
      ΑΝ ΔΕ='Ν' ΤΟΤΕ
        Ι <-- 1
      ΑΛΛΙΩΣ_ΑΝ ΔΕ= 'Ο'ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ΤΡΑΠΕΖΙΤΗΣ ΑΓΟΡΑΣΕ ΤΟ ΚΟΥΤΙ ΣΟΥ ΓΙΑ',ΠΡ, 'ΕΥΡΩ'
        ΓΡΑΨΕ 'ΑΣ ΔΟΥΜΕ ΤΙ ΘΑ ΚΕΡΔΙΖΕΣ ΑΝ ΣΥΝΕΧΙΖΕΣ'
        ΔΕΠ <-- ΠΡ
        Ι <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Ι=1
  ΤΕΛΟΣ_ΑΝ
  !ΤΡΙΤΟΣ ΓΥΡΟΣ
  ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΔΙΑΛΕΞΕΙΣ ΤΡΙΑ ΑΚΟΜΑ ΚΟΥΤΙΑ'
  ΓΡΑΨΕ 'ΥΠΕΝΘΙΜΙΖΩ ΟΤΙ ΤΑ ΚΟΥΤΙΑ ΠΟΥ ΜΕΝΟΥΝ ΕΙΝΑΙ:'
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ Κ[Ο]>0 ΤΟΤΕ
      ΓΡΑΨΕ Ο
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΕΝΑ ΚΟΥΤΙ;'
    ΔΙΑΒΑΣΕ ΕΠ
    ΑΝ ΕΠ>0 ΚΑΙ ΕΠ<=20 ΚΑΙ Κ[ΕΠ]<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΚΟΥΤΙ ',ΕΠ,' ΠΕΡΙΕΧΕΙ '[ΕΠ], 'ΕΥΡΩ'
      Κ[ΕΠ] <-- 0
      Ι <-- Ι+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΡΙΘΜΟΣ Ή ΗΔΗ ΕΠΙΛΕΓΜΕΝΟ ΚΟΥΤΙ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=3
  !ΤΡΑΠΕΖΙΤΗΣ
  ΣΥ <-- 0
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΣΥ <-- ΣΥ + Κ[Ο]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ, ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ'
  ΠΡ <--  ΣΥ/25
  ΓΡΑΨΕ' Ο ΤΡΑΠΕΖΙΤΗΣ ΠΡΟΣΦΕΡΕΙ ', ΠΡ, 'ΕΥΡΩ ΓΙΑ ΝΑ ΠΑΡΕΙ ΤΟ ΚΟΥΤΙ ΣΟΥ'
  ΜΑΧΠΡ <-- ΠΡ
  ΑΝ ΔΕ='Ν'  ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ ' ΘΑ ΣΥΝΕΧΙΣΕΙΣ;(ΑΠΑΝΤΑ ΜΕ Ν ΓΙΑ ΝΑΙ ΚΑΙ Ο ΓΙΑ ΟΧΙ)'
      Ι <-- 0
      ΔΙΑΒΑΣΕ ΔΕ
      ΑΝ ΔΕ='Ν' ΤΟΤΕ
        Ι <-- 1
      ΑΛΛΙΩΣ_ΑΝ ΔΕ= 'Ο'ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ΤΡΑΠΕΖΙΤΗΣ ΑΓΟΡΑΣΕ ΤΟ ΚΟΥΤΙ ΣΟΥ ΓΙΑ',ΠΡ, 'ΕΥΡΩ'
        ΓΡΑΨΕ 'ΑΣ ΔΟΥΜΕ ΤΙ ΘΑ ΚΕΡΔΙΖΕΣ ΑΝ ΣΥΝΕΧΙΖΕΣ'
        ΔΕΠ <-- ΠΡ
        Ι <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Ι=1
  ΤΕΛΟΣ_ΑΝ

!ΤΕΤΑΡΤΟΣ ΓΥΡΟΣ
  ΓΡΑΨΕ'ΠΡΕΠΕΙ ΝΑ ΔΙΑΛΕΞΕΙΣ ΤΡΙΑ ΑΚΟΜΑ ΚΟΥΤΙΑ'
  ΓΡΑΨΕ 'ΥΠΕΝΘΙΜΙΖΩ ΟΤΙ ΤΑ ΚΟΥΤΙΑ ΠΟΥ ΜΕΝΟΥΝ ΕΙΝΑΙ:'
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ Κ[Ο]>0 ΤΟΤΕ
      ΓΡΑΨΕ Ο
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΕΝΑ ΚΟΥΤΙ;'
    ΔΙΑΒΑΣΕ ΕΠ
    ΑΝ ΕΠ>0 ΚΑΙ ΕΠ<=20 ΚΑΙ Κ[ΕΠ]<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΚΟΥΤΙ ',ΕΠ,' ΠΕΡΙΕΧΕΙ '[ΕΠ], 'ΕΥΡΩ'
      Κ[ΕΠ] <-- 0
      Ι <-- Ι+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΡΙΘΜΟΣ Ή ΗΔΗ ΕΠΙΛΕΓΜΕΝΟ ΚΟΥΤΙ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=3
  !ΤΡΑΠΕΖΙΤΗΣ
  ΣΥ <-- 0
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΣΥ <-- ΣΥ + Κ[Ο]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ, ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ'
  ΠΡ <--  ΣΥ/20
  ΓΡΑΨΕ' Ο ΤΡΑΠΕΖΙΤΗΣ ΠΡΟΣΦΕΡΕΙ ', ΠΡ, 'ΕΥΡΩ ΓΙΑ ΝΑ ΠΑΡΕΙ ΤΟ ΚΟΥΤΙ ΣΟΥ'
  ΜΑΧΠΡ <-- ΠΡ
  ΑΝ ΔΕ='Ν'  ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ ' ΘΑ ΣΥΝΕΧΙΣΕΙΣ;(ΑΠΑΝΤΑ ΜΕ Ν ΓΙΑ ΝΑΙ ΚΑΙ Ο ΓΙΑ ΟΧΙ)'
      Ι <-- 0
      ΔΙΑΒΑΣΕ ΔΕ
      ΑΝ ΔΕ='Ν' ΤΟΤΕ
        Ι <-- 1
      ΑΛΛΙΩΣ_ΑΝ ΔΕ= 'Ο'ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ΤΡΑΠΕΖΙΤΗΣ ΑΓΟΡΑΣΕ ΤΟ ΚΟΥΤΙ ΣΟΥ ΓΙΑ',ΠΡ, 'ΕΥΡΩ'
        ΓΡΑΨΕ 'ΑΣ ΔΟΥΜΕ ΤΙ ΘΑ ΚΕΡΔΙΖΕΣ ΑΝ ΣΥΝΕΧΙΖΕΣ'
        ΔΕΠ <-- ΠΡ
        Ι <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Ι=1
  ΤΕΛΟΣ_ΑΝ
  !ΠΕΜΠΤΟΣ ΓΥΡΟΣ
  ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΔΙΑΛΕΞΕΙΣ ΤΡΙΑ ΑΚΟΜΑ ΚΟΥΤΙΑ'
  ΓΡΑΨΕ 'ΥΠΕΝΘΙΜΙΖΩ ΟΤΙ ΤΑ ΚΟΥΤΙΑ ΠΟΥ ΜΕΝΟΥΝ ΕΙΝΑΙ:'
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ Κ[Ο]>0 ΤΟΤΕ
      ΓΡΑΨΕ Ο
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΕΝΑ ΚΟΥΤΙ;'
    ΔΙΑΒΑΣΕ ΕΠ
    ΑΝ ΕΠ>0 ΚΑΙ ΕΠ<=20 ΚΑΙ Κ[ΕΠ]<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΚΟΥΤΙ ',ΕΠ,' ΠΕΡΙΕΧΕΙ '[ΕΠ], 'ΕΥΡΩ'
      Κ[ΕΠ] <-- 0
      Ι <-- Ι+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΡΙΘΜΟΣ Ή ΗΔΗ ΕΠΙΛΕΓΜΕΝΟ ΚΟΥΤΙ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=3
  !ΤΡΑΠΕΖΙΤΗΣ
  ΣΥ <-- 0
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΣΥ <-- ΣΥ + Κ[Ο]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ, ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ'
  ΠΡ <--  ΣΥ/3
  ΓΡΑΨΕ' Ο ΤΡΑΠΕΖΙΤΗΣ ΠΡΟΣΦΕΡΕΙ ', ΠΡ, 'ΕΥΡΩ ΓΙΑ ΝΑ ΠΑΡΕΙ ΤΟ ΚΟΥΤΙ ΣΟΥ'
  ΜΑΧΠΡ <-- ΠΡ
  ΑΝ ΔΕ='Ν'  ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ ' ΘΑ ΣΥΝΕΧΙΣΕΙΣ;(ΑΠΑΝΤΑ ΜΕ Ν ΓΙΑ ΝΑΙ ΚΑΙ Ο ΓΙΑ ΟΧΙ)'
      Ι <-- 0
      ΔΙΑΒΑΣΕ ΔΕ
      ΑΝ ΔΕ='Ν' ΤΟΤΕ
        Ι <-- 1
      ΑΛΛΙΩΣ_ΑΝ ΔΕ= 'Ο'ΤΟΤΕ
        ΓΡΑΨΕ 'Ο ΤΡΑΠΕΖΙΤΗΣ ΑΓΟΡΑΣΕ ΤΟ ΚΟΥΤΙ ΣΟΥ ΓΙΑ',ΠΡ, 'ΕΥΡΩ'
        ΓΡΑΨΕ 'ΑΣ ΔΟΥΜΕ ΤΙ ΘΑ ΚΕΡΔΙΖΕΣ ΑΝ ΣΥΝΕΧΙΖΕΣ'
        ΔΕΠ <-- ΠΡ
        Ι <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Ι=1
  ΤΕΛΟΣ_ΑΝ
!ΤΕΛΕΥΤΑΙΟΣ ΓΥΡΟΣ
  !ΑΝΤΑΛΛΑΓΗ
  ΓΡΑΨΕ 'ΕΝΑ ΚΟΥΤΙ ΑΚΟΜΑ ΜΕΝΕΙ ΑΚΟΜΑ'                                                    
  ΓΡΑΨΕ 'ΝΤΡΙΝΝΝΝΝΝΝΝΝΝ, ΝΤΡΙΝΝΝΝΝΝΝΝΝΝΝ'
  ΓΡΑΨΕ 'Ο ΤΡΑΠΕΖΙΤΗΣ ΠΡΟΣΦΕΡΕΙ ΑΝΤΑΛΛΑΓΗ'
  ΓΡΑΨΕ 'ΘΑ ΑΝΤΑΛΛΑΣΕΤΕ ΤΟ ΚΟΥΤΙ ΣΑΣ ΜΕ ΤΟ ΤΕΛΕΥΤΑΙΟ ΚΟΥΤΙ;'
  ΓΙΑ Ο ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ Κ[Ο]>0 ΤΟΤΕ
      ΤΕΛΚΟΥ <-- Ο
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΑΝ ΝΑΙ ΠΑΤΗΣΤΕ Ν , ΑΝ ΟΧΙ ΠΑΤΗΣΕ Ο'            

  Ι <-- Ο
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΑΝΤ
    ΑΝ ΑΝΤ='Ν' ΤΟΤΕ
      ΤΕΜΠ <-- ΠΚΟΥ
      ΠΚΟΥ <-- Κ[ΤΕΛΚΟΥ]
      Κ[ΤΕΛΚΟΥ] <-- ΤΕΜΠ
      Ι <-- 1
    ΑΛΛΙΩΣ_ΑΝ ΑΝΤ='Ο' ΤΟΤΕ
      Ι <-- 1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΑΠΑΝΤΗΣΗ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ι=1
  ΓΡΑΨΕ 'ΕΧΟΥ ΜΕΙΝΕΙ ΔΥΟ ΚΟΥΤΙΑ'
  ΓΡΑΨΕ 'ΤΟ ΔΙΚΟ ΣΟΥ ΚΑΙ ΤΟ ΚΟΥΤΙ ', ΤΕΛΚΟΥ
  ΓΡΑΨΕ 'ΑΣ ΑΝΟΙΞΟΥΜΕ ΛΟΙΠΟΝ ΤΑ ΚΟΥΤΙΑ'
  ΓΡΑΨΕ 'ΤΟ ΔΙΚΟ ΣΟΥ ΚΟΥΤΙ ΠΕΡΙΕΧΕΙ ',ΠΚΟΥ,'ΕΥΡΩ'
  ΓΡΑΨΕ 'ΕΝΩ ΤΟ ΚΟΥΤΙ ', ΤΕΛΚΟΥ ,' ΠΕΡΙΕΧΕΙ' , Κ[ΤΕΛΚΟΥ] , 'ΕΥΡΩ'
  ΑΝ ΔΕ= 'Ν' ΤΟΤΕ
    ΑΝ ΜΑΧΠΡ>ΠΚΟΥ ΤΟΤΕ
      ΓΡΑΨΕ 'ΘΑ ΜΠΟΡΟΥΣΕΣ ΝΑ ΕΙΧΕΣ ΠΑΡΕΙ', ΜΑΧΠΡ, 'ΕΥΡΩ ΑΠΟ ΤΟΝ ΤΡΑΠΕΖΙΤΗ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ  'ΕΚΑΝΕΣ ΤΟ ΚΑΛΥΤΕΡΟ DEAL'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ ΔΕ= 'Ο' ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ' ,ΔΕΠ ,'ΕΥΡΩ'
    ΑΝ ΔΕΠ < ΜΑΧΠΡ Ή ΔΕΠ< ΠΚΟΥ ΤΟΤΕ
      ΑΝ ΜΑΧΠΡ>ΠΚΟΥ ΤΟΤΕ
        ΓΡΑΨΕ 'ΔΕΝ ΕΚΑΝΕΣ ΤΟ ΚΑΛΥΤΕΡΟ DEAL'
        ΓΡΑΨΕ 'ΘΑ ΜΟΡΟΥΣΕΣ ΝΑ  ΕΙΧΕΣ ΠΑΡΕΙ ΤΑ', ΜΑΧΠΡ, ' ΕΥΡΩ ΤΟΥ ΤΡΑΠΕΖΙΤΗ'
      ΑΛΛΙΩΣ_ΑΝ ΠΚΟΥ>ΜΑΧΠΡ ΤΟΤΕ
        ΓΡΑΨΕ 'ΔΕΝ ΕΚΑΝΕΣ ΤΟ ΚΑΛΥΤΕΡΟ DEAL'
        ΓΡΑΨΕ 'ΘΑ ΜΠΡΟΥΣΕΣ ΝΑ ΕΙΧΕΣ ΠΑΡΕΙ ΤΑ ', ΠΚΟΥ,' ΕΥΡΩ ΠΟΥ ΠΕΡΙΕΙΧΕ ΤΟ ΚΟΥΤΙ ΣΟΥ'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΕΚΑΝΕΣ ΤΟ ΚΑΛΥΤΕΡΟ DEAL'
      ΓΡΑΨΕ'ΚΕΡΔΙΣΕΣ' , ΔΕΠ , ' ΕΥΡΩ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ'     ======================================'
  ΓΡΑΨΕ'  ============================================='
  ΓΡΑΨΕ' ====           ΑΠΟ TON  BULUBA89            ===='
  ΓΡΑΨΕ'  ============================================='
  ΓΡΑΨΕ'    ======================================'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters