Τώρα είναι Πέμ 16 Ιούλ 2020 07:25 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Βαθμολογίες μαθημάτων
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 12 Σεπ 2005 03:33 pm 
    Να γραφεί πρόγραμμα που θα διαβάζει τους βαθμούς 6 μαθητών σε 3 διαφορετικά μαθήματα και θα τους καταχωρεί σε κατάλληλα ορισμένο δισδιάστατο πίνακα. Η εισαγωγή των τιμών θα γίνεται ανά μάθημα. Κατόπιν θα εμφανίζει για το πρώτο μάθημα, πόσοι μαθητές ανήκουν σε κάθε μια από τις παρακάτω κατηγορίες.

    Κατηγορία
    p1 περνά (10 <= βαθμός <= 20)
    p2 αριστούχος (18,5 <= βαθμός <= 20)
    r1 απορρίπτεται (βαθμός < 10)
    r2 απορρίπτεται οριακά (9<= βαθμός < 10)

    Οδηγίες:
    Οι κατηγορίες p2 και r2 είναι υποκατηγορίες των p1 και r1 αντίστοιχα, άρα ενδείκνυται να χρησιμοποιηθούν εμφωλευμένες δομές ΑΝ.
    Ένας βαθμός ανήκει μόνο σε μία από τις παραπάνω μεγάλες κατηγορίες p1 και r1, γι’αυτό ενδείκνυται να χρησιμοποιηθεί δομή ΑΝ ΑΛΛΙΩΣ_ΑΝ.


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 10 Μαρ 2006 11:49 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Ορίστε και η λύση:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Κατηγορίες_Μαθητών
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, p1, p2, r1, r2
  ΠΡΑΓΜΑΤΙΚΕΣ: Β[6,3]
ΑΡΧΗ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Δώσε το βαθμό του',i,'μαθητή στο',j,'μάθημα'
        ΔΙΑΒΑΣΕ Β[i,j]
      ΜΕΧΡΙΣ_ΟΤΟΥ Β[i,j]>=0 ΚΑΙ Β[i,j]<=20
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  p1 <-- 0
  p2 <-- 0
  r1 <-- 0
  r2 <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΑΝ Β[i,1]>=10 ΤΟΤΕ
      p1 <-- p1+1
      ΑΝ Β[i,1]>=18.5 ΤΟΤΕ
        p2 <-- p2+1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      r1 <-- r1+1
      ΑΝ Β[i,1]>=9 ΤΟΤΕ
        r2 <-- r2+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Μαθητές που περνούν το πρώτο μάθημα', p1
  ΓΡΑΨΕ 'Μαθητές που αρίστευσαν στο πρώτο μάθημα', p2
  ΓΡΑΨΕ 'Μαθητές που κόπηκαν στο πρώτο μάθημα', r1
  ΓΡΑΨΕ 'Μαθητές που κόπηκαν οριακά στο πρώτο μάθημα', r2
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters