Τώρα είναι Παρ 05 Ιουν 2020 03:19 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 14 Φεβ 2006 10:43 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =========================================================
! ΝΓΠ το οποίο αφού ζητήσει έναν ακέραιο αριθμό Ν (Ν>0) θα
! υπολογίζει την τιμή της σύνθετης παράστασης που
! δημιουργείται από τους αριθμούς 1 έως Ν, σύμφωνα με το
! παρακάτω παράδειγμα:
!
! Αν Ν=9 τότε ζητούμενη είναι η τιμή του σύνθετου κλάσματος
!
!                      1+2
!                      ___ + 4
!
!                       3
!                      _______ + 6
!
!                         5
!                      ___________ + 8
!
!                           7
!                      _______________
!
!                             9
! =========================================================

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 14 Φεβ 2006 11:35 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 14 Φεβ 2006 09:24 pm
Δημοσιεύσεις: 2
Τοποθεσία: Κέρκυρα
Νέοπας στο forum, ολίγον τι ψαρωμένος, αλλά νομίζω πως ο κώδικάς μου είναι σωστός. Ορίστε:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Τιμή_Σύνθετης_Παράστασης
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν, i
  ΠΡΑΓΜΑΤΙΚΕΣ: ΤΣΠ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε έναν ακέραιο αριθμό μεγαλύτερο του μηδενός'
  ΔΙΑΒΑΣΕ Ν
  ΤΣΠ <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ (i=2) Ή (i MOD 2=0) ΤΟΤΕ
      ΤΣΠ <-- ΤΣΠ+i
    ΑΛΛΙΩΣ
      ΤΣΠ <-- ΤΣΠ/i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Η τιμή της σύνθετης παράστασης είναι:', ΤΣΠ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τιμή_Σύνθετης_Παράστασης


Είναι αυτονόητο πως περιμένω σχόλια αν κάτι είναι λάθος!

Υ.Γ: Δε θα μπορούσα στο πρώτο μου post να μην ευχόμουν καλή επιτυχία σε όλους εμάς που δίνουμε Πανελλήνιες Εξετάσεις φέτος! Υπομονή παιδιά...φάγαμε το γάιδαρο και μας μένει η ουρά (όπως λέει μια συγγενής μου κάθε φορά που με βλέπει και που προφανώς δε ξέρει τι σημαίνει...ουρά Πανελληνίων! :D)

_________________
3w.GreekManager.com


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 15 Φεβ 2006 12:48 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Μάλιστα.
Σωστός!
(αν και με μερικούς πλεονασμούς)
Καμιά πιο σύντομη λύση; :wink:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 15 Φεβ 2006 11:57 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 14 Φεβ 2006 09:24 pm
Δημοσιεύσεις: 2
Τοποθεσία: Κέρκυρα
Εδώ είμαστε:

Ο πρώτος τρόπος, χωρίς τον πλεονασμό:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Τιμή_Σύνθετης_Παράστασης
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν, i
  ΠΡΑΓΜΑΤΙΚΕΣ: ΤΣΠ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε έναν ακέραιο αριθμό μεγαλύτερο του μηδενός'
  ΔΙΑΒΑΣΕ Ν
  ΤΣΠ <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ i MOD 2 = 0 ΤΟΤΕ
      ΤΣΠ <-- ΤΣΠ+i
    ΑΛΛΙΩΣ
      ΤΣΠ <-- ΤΣΠ/i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Η τιμή της σύνθετης παράστασης είναι:', ΤΣΠ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τιμή_Σύνθετης_Παράστασης                            


O δεύτερος τρόπος, ο συντομότερος:*
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Τιμή_Σύνθετης_Παράστασης
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: ΤΣΠ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε έναν ακέραιο αριθμό μεγαλύτερο του μηδενός'
  ΔΙΑΒΑΣΕ Ν
  ΑΝ Ν MOD 2 = 0 ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή της παράστασης είναι:'+1
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η τιμή της παράστασης είναι:',1
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τιμή_Σύνθετης_Παράστασης


*Παρατηρώντας πως όταν έχουμε ακέραιο η τιμή της παράστασης είναι ο αριθμός αυτός αυξημένος κατά μια μονάδα (Ν+1) ενώ όταν έχουμε περιττό η τιμή της παράστασης είναι η μονάδα.

_________________
3w.GreekManager.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters