Τώρα είναι Σάβ 06 Ιουν 2020 04:36 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 20 Ιούλ 2005 06:40 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Μαρ 2005 04:06 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
! =======================================================================
! 1)Να γίνει πρόγραμμα που να ζητάει το μέγεθος ενός δυσδιάστατου πίνακα (π.χ 5x7)
! 2)Να διαβάζει τον πίνακα.
! 3)Να εμφανίζει τον πίνακα που δημιουργήσαμε.
! 4)Να βρίσκει το ΜΑΧ στοιχείο του πίνακα και να το εμφανίζει
! 5)Να ελέγχει αν ο μέσος όρος των στοιχείων του πίνακα είναι πάνω 10
! ΣΗΜΕΙΩΣΗ:
! - Το διάβασμα των τιμών του πίνακα να γίνεται με ΔΙΑΔΙΚΑΣΙΑ
! - Η εύρεση του ΜΑΧ στοιχείου να γίνεται με ΔΙΑΔΙΚΑΣΙΑ
! =======================================================================

ΠΡΟΓΡΑΜΜΑ ΣΩΤ

!SOS ΓΙΑ ΑΓΝΩΣΤΟ ΜΕΓΕΘΟΣ ΠΙΝΑΚΑ ΠΡΕΠΕΙ ΝΑ ΔΕΣΜΕΥΕΤΕ ΑΡΚΕΤΟΣ ΧΩΡΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΠΙΝ[100,100],ΜΑΧ1,ΜΟ,ΑΘΡ
  ΑΚΕΡΑΙΕΣ: Λ,Α,Μ,Β

ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΜΕΓΕΘΟΣ ΤΟΥ ΠΙΝΑΚΑ Π.Χ 5Χ7'
  ΔΙΑΒΑΣΕ Λ,Μ

  ΚΑΛΕΣΕ ΔΗΜΙΟΥΡΓΙΑ_ΠΙΝΑΚΑ_Λ_Μ_ΘΕΣΕΩΝ(ΠΙΝ,Λ,Μ)

  ΓΡΑΨΕ 'TΑ ΣΤΟΙΧΕΙΑ ΤΟΥ ΠΙΝΑΚΑ ΕΙΝΑΙ ΤΑ ΕΞΕΙΣ:'

  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ Λ
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ Μ
      ΓΡΑΨΕ ΠΙΝ[Α,Β]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΚΑΛΕΣΕ ΕΥΡΕΣΗ_ΜΑΧ_ΣΤΟΙΧΕΙΟΥ(ΠΙΝ,ΜΑΧ1)

  ΓΡΑΨΕ 'TO MAX ΣΤΟΙΧΕΙΟ ΤΟΥ ΠΙΝΑΚΑ ΕΙΝΑΙ:',ΜΑΧ1
  ΑΘΡ <-- 0
  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ Λ
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ Μ
      ΑΘΡ <-- ΑΘΡ+ΠΙΝ[Α,Β]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΜΟ <-- ΑΘΡ/(Λ*Μ)
  ΑΝ ΜΟ>10 ΤΟΤΕ
    ΓΡΑΨΕ   ' ο μέσος όρος των στοιχείων του πίνακα είναι πάνω 10'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ   ' ο μέσος όρος των στοιχείων του πίνακα ΔΕΝ είναι πάνω 10 '
  ΤΕΛΟΣ_ΑΝ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΩΤ

!.....................................................................
ΔΙΑΔΙΚΑΣΙΑ ΔΗΜΙΟΥΡΓΙΑ_ΠΙΝΑΚΑ_Λ_Μ_ΘΕΣΕΩΝ(Χ,Κ,Φ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Κ,Φ,J
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ[100,100]
ΑΡΧΗ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ Φ
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ  ', Ι  , ':',   J ,' ΣΤΟΙΧΕΙΟ'
      ΔΙΑΒΑΣΕ Χ[Ι,J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!........................................................................
ΔΙΑΔΙΚΑΣΙΑ ΕΥΡΕΣΗ_ΜΑΧ_ΣΤΟΙΧΕΙΟΥ(ΕΕ,ΜΑΧ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Γ,Δ, Λ, Μ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΑΧ,ΕΕ[100,100]
ΑΡΧΗ
  ΜΑΧ <-- ΕΕ[1,1]
  ΓΙΑ Γ ΑΠΟ 1 ΜΕΧΡΙ Λ
    ΓΙΑ Δ ΑΠΟ 1 ΜΕΧΡΙ Μ
      ΑΝ ΕΕ[Γ,Δ]>ΜΑΧ ΤΟΤΕ
        ΜΑΧ <-- ΕΕ[Γ,Δ]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!........................................................................


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters