Τώρα είναι Κυρ 01 Νοέμ 2020 05:00 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: DVD Searching.....
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 22 Ιαν 2005 01:42 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]

! =====================================================================
! Δύο υποκαταστήματα πώλησης DVD (Α και Β) της ίδιας εταιρίας
! καταχωρούν τους τίτλους των DVD σε έναν πίνακα 200 θέσεων το καθένα.
! Να αναπτύξετε πρόγραμμα το οποίο:
! i) να διαβάζει το πλήθος των DVD (Ν), του κάθε υποκαταστήματος
!    (θα πρέπει 1<=ΝΑ<=200 και 1<=ΝΒ<=200)
! ii) να διαβάζει τους τίτλους των DVD και για το κάθε υποκατάστημα.
! iii) να εμφανίζει τους τίτλους των DVD  που υπάρχουν
!      ταυτόχρονα και στα δύο καταστήματα.
! iv) να εμφανίζει τους τίτλους των DVD που υπάρχουν στο πρώτο
!     αλλά δεν υπάρχουν στο δεύτερο υποκατάστημα.
! v) να εμφανίζει τους τίτλους των 20 πρώτων DVD
!    κατά αλφαβητική σειρά του δεύτερου υποκαταστήματος
!
!  Θεωρήστε ότι κάθε υποκατάστημα έχει κάθε τίτλο μονο μια φορά.
!=====================================================================
 


(για αυτο περιμένουμε να δουμε μια ταινία τόσες ημέρες :lol: )

Syntax: [ Download ] [ Hide ]

ΠΡΟΓΡΑΜΜΑ DVD_Searching
ΣΤΑΘΕΡΕΣ
  size=200
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,NA,ΝΒ,lim
  ΧΑΡΑΚΤΗΡΕΣ: DVDA[size],DVDB[size],temp
  ΛΟΓΙΚΕΣ: όμοιο,μοναδικό
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δωσε πλήθος DVD του A υποκαταστήματος'
    ΔΙΑΒΑΣΕ NA
  ΜΕΧΡΙΣ_ΟΤΟΥ  (NA>=1) ΚΑΙ ( NA<=200 )

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δωσε πλήθος DVD του B υποκαταστήματος'
    ΔΙΑΒΑΣΕ ΝΒ
  ΜΕΧΡΙΣ_ΟΤΟΥ  (ΝΒ>=1) ΚΑΙ ( ΝΒ<=200 )
!-------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ NA
    ΓΡΑΨΕ 'Δωσε ',i, 'ο τιτλο του A υποκαταστήματος'
    ΔΙΑΒΑΣΕ DVDA[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ ΝΒ
    ΓΡΑΨΕ 'Δωσε ',i, 'ο τιτλο του B υποκαταστήματος'
    ΔΙΑΒΑΣΕ DVDB[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!-------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ NA
    όμοιο <-- ψευδής
    j <-- 1
    ΟΣΟ (j<=ΝΒ) ΚΑΙ (όμοιο=ψευδής) ΕΠΑΝΑΛΑΒΕ
      ΑΝ DVDA[i]=DVDB[j] ΤΟΤΕ
        ΓΡΑΨΕ 'ο τίτλος: ',DVDA[i],' υπάρχει και στα δυο καταστήματα'
        όμοιο <-- αληθής
      ΤΕΛΟΣ_ΑΝ
      j <-- j+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!-------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ NA
    μοναδικό <-- αληθής
    j <-- 1
    ΟΣΟ (j<=ΝΒ) ΚΑΙ (μοναδικό=αληθής) ΕΠΑΝΑΛΑΒΕ
      ΑΝ DVDA[i]=DVDB[j] ΤΟΤΕ
        μοναδικό <-- ψευδής
      ΤΕΛΟΣ_ΑΝ
      j <-- j+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ μοναδικό=αληθής ΤΟΤΕ
      ΓΡΑΨΕ 'ο τίτλος: ', DVDA[i],' υπάρχει μονο στο 1ο κατάστημα'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!-------
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ ΝΒ
    ΓΙΑ j ΑΠΟ ΝΒ ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ DVDB[j-1]>DVDB[j] ΤΟΤΕ
        temp <-- DVDB[j-1]
        DVDB[j-1] <-- DVDB[j]
        DVDB[j] <-- temp
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ ΝΒ>=20 ΤΟΤΕ
    lim <-- 20
  ΑΛΛΙΩΣ
    lim <-- ΝΒ
  ΤΕΛΟΣ_ΑΝ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ lim
    ΓΡΑΨΕ DVDB[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters