Τώρα είναι Παρ 29 Μάιος 2020 11:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Πόσο βερνίκι χρειαζόμαστε?
ΔημοσίευσηΔημοσιεύτηκε: Τρί 25 Μάιος 2004 12:13 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
! =====================================================================================
! To κεντρικό αμφιθέατρο της Σχολής Θετικών Επιστημών (ΣΘΕ) έχει 30 σειρές εδράνων.
! Η κάτω-κάτω σειρά (1η σειρά) αποτελείται από 20 έδρανα και για κάθε σειρά πιο πάνω
! τα έδρανα αυξάνονται κατά 3. Η ΣΘΕ αποφάσισε να περάσει με βερνίκι όλα τα έδρανα.
! Κάθε έδρανο απαιτεί 2000 gr βερνικιού, και ο προμηθευτής στης ΣΘΕ, διαθέτει βερνίκι
! σε κουτιά των 7 Kg με κόστος 4 € το καθένα.
! Να γίνει αλγόριθμος που να υπολογίζει πόσα έδρανα έχει συνολικά το αμφιθέατρο,
! πόσα κουτία βερνίκι απαιτούνται, και ποιο είναι το συνολικό κόστος.
! =====================================================================================


ΠΡΟΓΡΑΜΜΑ Αμφιθέατρο
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Εδρ,i,ΣΕ,Βερνίκι,Κουτιά
ΑΡΧΗ
  ! ----------- 1ος Τρόπος ---------------
  ΣΕ <-- 0            
  Εδρ <-- 20
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
    ΣΕ <-- ΣΕ + Εδρ
    Εδρ <-- Εδρ + 3
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ! --------------------------------------

  ΓΡΑΨΕ 'Το Αμφιθέατρο έχει συνολικά ',ΣΕ, ' έδρανα'
  Βερνίκι <-- 2*ΣΕ
  Κουτιά <-- Βερνίκι DIV 7

  ΑΝ Βερνίκι MOD 7 <>0 ΤΟΤΕ
    Κουτιά <-- Κουτιά +1
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Απαιτούνται συνολικά ',Κουτιά, ' κουτιά βερνίκι με κόστος ',Κουτιά*4, ' ευρώ'

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Syntax: [ Download ] [ Hide ]
! ----------- 2ος Τρόπος ---------------
ΣΕ <-- 20
Εδρ <-- 20
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 30
  Εδρ <-- Εδρ + 3
  ΣΕ <-- ΣΕ + Εδρ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! --------------------------------------
 


Syntax: [ Download ] [ Hide ]
! ----------- 3ος Τρόπος ---------------
ΣΕ <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
  ΣΕ <-- ΣΕ + (i-1)*3 + 20
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! --------------------------------------
 


Τελευταία επεξεργασία από kfrei και Παρ 28 Μάιος 2004 01:00 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Πόσο βερνίκι χρειαζόμαστε?
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 27 Μάιος 2004 06:51 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Πραγματικά πολύ ωραία άσκηση, έχει και αυτό το κάτι παραπάνω

Μήπως οι διαιρέσεις με τα div και mod πρέπει να γίνουν με το 7 (και όχι με το 5) καθώς είναι 7κιλα τα κουτιά του βερνικιού?

Και πάλι μπράβο

Με εκτίμηση, Τσιωτάκης Παναγιώτης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 27 Μάιος 2004 02:04 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Αγαπητέ Παναγιώτη,
ευχαριστώ καταρχήν για τα σχόλια σου, και κατά δεύτερον έχεις απόλυτο δίκιο........ :shock: μου ξέφυγε η αλλαγή της άσκησης μια και το πόσο ήταν λίγο μεγάλο και με τα ίδια ευρώ έφτιαχνες ένα αμφιθέατρο ακόμη....
(πράγματι όπου "DIV 5" και "MOD 5" πρέπει να αντικατασταθεί με "DIV 7" και "MOD 7", το οποίο και έκανα μετα την παρατήρηση σου)


Φρειδερίκος Κώστας
kfrei


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Ενισχυμένο
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 27 Νοέμ 2005 09:50 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 06 Νοέμ 2005 01:44 am
Δημοσιεύσεις: 2
Τοποθεσία: ΑΘΗΝΑ
Έχω να κάνω μια προταση για να το δυσκολέψουμε.Να γίνει η άσκηση αλλά χωρίς δομη επάναληψης.Αυτό μπορεί να γίνει με τον τύπο της αριθμητικής προόδου που αποδίδει το άθροισμα ν όρων αν γνωρίζουμε τον πρώτο όρο,τον αριθμό με τον οποία άυξάνει η αριθμητική πρόοδος και των αριθμο των όρων.Εδώ η δομή επανάληψης μπορεί να αντικτασταθεί με την εντολη


ΣΕ=ν/2[2α1+(ν―1)ω]
με ν των αριθμων των σειρών,α1 τον αριθμό των εδράνων της πρώτης σειράς και ω τον αριθμο κατα τον οποίο διαφέρουν δύο διαδιχικές σειρές.
Ακούω απόψεις... :idea:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ενισχυμένο
ΔημοσίευσηΔημοσιεύτηκε: Τετ 30 Νοέμ 2005 01:52 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Αγαπητε Χαράλαμπε,
Σε ευχαριστω για την πρότασή σου, αλλα πεποίθηση μου ειναι πως στα πλάσια του μαθήματος της ΑΕΠΠ, προσπαθούμε συνήθως να υλοποιήσουμε το αντίθετο από αυτό που προτείνεις. Δηλαδή να αποστασιοποιήσουμε το μάθημα από "σκληρά" μαθηματικά και αριθμητικούς "τύπους" τα οποία απαιτούν απο τους μαθητές "κατι παραπάνω από βασικές μαθηματικές γνώσεις" και να προσανατολιστούμε σε λύσεις οι οποίες βασίζονται στις βασικές δομές προγραμματισμού (ακολουθία, επιλογή, επανάληψη).

Ακόμη όμως και οι ασκήσεις που ¨ξεφεύγουν¨ σε μαθηματικές απαιτήσεις, (υπολογισμός σειρών, ΜΚΔ, ΕΚΠ, κλπ ) προτρέπουν τους μαθητές σε στοιχειώδεις μαθηματικές δομές και ενεδεχομένως σε πολυπλοκότερες υπολογιστικές δομές.


Με εκτίμηση
Φρειδερίκος Κώστας
kfrei

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters