Τώρα είναι Τετ 03 Ιουν 2020 06:44 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 6 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Δευτεροβάθμια εξίσωση
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 26 Απρ 2009 08:27 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Το παρακάτω πρόγραμμα βρίσκει τις λύσεις της εξίσωσης που θα του δοθεί, αν η εξίσωση είναι δευτέρου βαθμού και αν είναι πρώτου ή μηδενικού εμφανίζει αντίστοιχο μήνυμα και λύση.
Τα σύμβολα του πολλαπλασιασμού ανάμεσα σε άγνωστο με παρένθεση/αριθμό/άγνωστο ή παρένθεση με αριθμό/άγνωστο/παρένθεση μπορούν να παραλειφθούν αλλά αν η εξίσωση + τα σύμβολα που έχουν παραλειφθεί υπερβαίνουν τους 126 χαρακτήρες θα οδηγήσει σε μήνυμα/σφάλμα .
Σε κάποια σημεία έχω αφήσει πράξεις όπως η 1+1 για να είναι πιο κατανοητή η διαδικασία σκέψης και επειδή το ‘’παράταγα’’ για μεγάλα διαστήματα και ήθελα εύκολα να μπορώ να καταλάβω τη σκεφτόμουν :oops: :)
Δεν το έχω δοκιμάσει για κάθε εκδοχή αφού δεν μπορώ να το δοκιμάσω για όλες τις περιπτώσεις … (αφού οι εξισώσεις είναι άπειρες)
Σχόλια, διορθώσεις, παρατηρήσεις ευπρόσδεχτα
Σημείωση : Παρακαλώ κανείς να μην προσθέσει κάποια συνάρτηση ή κομμάτι στον κώδικα που να δείχνει τα βήματα για την επίλυση της εξίσωσης.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ δευτεροβάθμια_εξίσωση
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΑΑ, Β, Γ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΞΙΣ, ΣΥΜΒ[126]              !ΜΕΓΙΣΤΟΣ ΑΡΙΘΜΟΣ ΧΑΡΑΚΤΗΡΩΝ ΣΕ ΜΙΑ ΜΕΤΑΒΛΗΤΗ ΕΙΝΑΙ 126 ΣΤΗ ΓΛΩΣΣΟΜΑΘΕΙΑ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛ[126], ΔΥΝΧ[126], Δ, Ψ !ΔΥΝΧ : Η ΔΥΝΑΜΗ ΣΤΗΝ ΟΠΟΙΑ ΕΙΝΑΙ ΥΨΩΜΕΝΟ ΤΟ Χ, Α^0=1 ΟΠΟΤΕ Χ^0=1
  ΑΚΕΡΑΙΕΣ: Ι, ΤΕΛ, Ξ, Α, ΜΕΤΡΗΤΗΣ         !ΣΥΝΤΕΛ : Ο ΣΥΝΤΕΛΕΣΤΗΣ ΤΟΥ Χ
  ΑΚΕΡΑΙΕΣ: ΜΕΤΡΗΤΗΣ2                      !ΣΥΜΒ : ΟΤΙ ΣΥΜΒΟΛΟ ΥΠΑΡΧΕΙ ΕΙΤΕ * / ^ + - ΕΙΤΕ = . ( ) ΓΡΑΦΕΤΕ ΕΔΩ
  ΛΟΓΙΚΕΣ: ΕΠΑΝ, Λ, Σ                      !ΤΟ ΔΥΝΧ ΣΤΗΝ ΑΡΧΗ ΕΧΕΙ ΜΟΝΟ ΤΙΣ ΤΙΜΕΣ 0 ΚΑΙ 1 ( ΚΑΙ -1 )ΟΠΟΤΕ ΜΠΟΡΟΥΜΕ ΝΑ ΤΟ ΧΡΗΣΙΜΟΠΟΙΗΣΟΥΜΕ
ΑΡΧΗ                                           !ΩΣ ΜΕΤΡΗΤΗ ΨΗΦΙΩΝ ΑΛΛΑ ΟΤΑΝ ΧΡΗΣΙΜΕΥΕΙ ΩΣ ΜΕΤΡΗΤΗΣ ΨΗΦΙΩΝ ΘΑ ΕΙΝΑΙ ΠΑΝΤΑ ΑΡΝΗΤΙΚΗ
  ΓΡΑΨΕ 'ΚΑΛΩΣΗΡΘΑΤΕ'                          !ΤΙΜΗ ΓΙΑ ΝΑ ΜΗΝ ΜΠΕΡΔΕΥΕΤΕ ΜΕ ΤΟ 1. ΜΕΤΑ ΟΛΕΣ ΟΙ ΑΡΝΗΤΙΚΕΣ ΤΙΜΕΣ ΘΑ ΓΙΝΟΥΝ 0 ΓΙΑ
  ΚΑΛΕΣΕ ΚΑΝΟΝΕΣ                               !ΤΗΝ ΕΠΙΛΥΣΗ ΤΗΣ ΕΞΙΣΩΣΗΣ (ΜΟΛΙΣ ΣΧΗΜΑΤΙΣΤΟΥΝ ΟΙ ΔΕΚΑΔΙΚΟΙ).
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ                                      
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                            ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΗΝ ΕΞΙΣΩΣΗ'           !ΕΙΣΑΓΩΓΗ ΕΞΙΣΩΣΗΣ
                            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                              ΔΙΑΒΑΣΕ ΕΞΙΣ
                            ΜΕΧΡΙΣ_ΟΤΟΥ ΕΛΕΓΧΟΣ_ΚΑΝ(ΕΞΙΣ) = ΑΛΗΘΗΣ       !ΤΕΛΟΣ ΕΙΣΑΓΩΓΗΣ ΕΞΙΣΩΣΗΣ
                            ΚΑΛΕΣΕ ΚΑΤΑΧΩΡΗΣΗ_ΜΕΤΑΒΛΗΤΕΣ(ΕΞΙΣ, ΣΥΜΒ, ΣΥΝΤΕΛ, ΔΥΝΧ, Α)
                          ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
!ΣΥΜΒΟΛΑ ΣΤΗΝ ΑΡΧΗ ΚΑΙ ΣΤΟ ΤΕΛΟΣ
                          ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)
                            ΑΝ Ι=1 ΤΟΤΕ                !ΔΕΝ ΜΠΟΡΕΙ ΝΑ ΜΠΕΙ ΕΔΩ ΤΟ Ή ΣΥΜΒ[Ι-1]= '=' ΕΠΕΙΔΗ ΘΑ ΕΔΙΝΑ ΣΦΑΛΜΑ ΓΙΑ Ι =ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)
                              ΑΝ ΣΥΜΒ[Ι]<>' ' ΚΑΙ ΣΥΜΒ[Ι] <> '+' ΚΑΙ ΣΥΜΒ[Ι] <> '-' ΚΑΙ ΣΥΜΒ[Ι] <> '(' ΤΟΤΕ
                                Α <-- 14
                                ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                              ΤΕΛΟΣ_ΑΝ
                            ΑΛΛΙΩΣ_ΑΝ Ι=ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ) ΤΟΤΕ
                              ΑΝ ΣΥΜΒ[Ι]<>' ' ΚΑΙ ΣΥΜΒ[Ι] <> ')' ΤΟΤΕ
                                Α <-- 14
                                ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                              ΤΕΛΟΣ_ΑΝ
                            ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι+1]='=' ΤΟΤΕ
                              ΑΝ ΣΥΜΒ[Ι]<>' ' ΚΑΙ ΣΥΜΒ[Ι] <> ')' ΤΟΤΕ
                                Α <-- 14
                                ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                              ΤΕΛΟΣ_ΑΝ
                            ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι-1]='=' ΤΟΤΕ
                              ΑΝ ΣΥΜΒ[Ι]<>' ' ΚΑΙ ΣΥΜΒ[Ι] <> '+' ΚΑΙ ΣΥΜΒ[Ι] <> '-' ΚΑΙ ΣΥΜΒ[Ι] <> '(' ΤΟΤΕ
                                Α <-- 14
                                ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                              ΤΕΛΟΣ_ΑΝ
                            ΤΕΛΟΣ_ΑΝ
                          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                        ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
                        ΤΕΛ <-- ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)
                        ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)-1
                          ΑΝ ΣΥΜΒ[Ι] <> ' ' ΚΑΙ ΣΥΜΒ[Ι+1] <> ' ' ΚΑΙ ΣΥΜΒ[Ι] <> '(' ΚΑΙ ΣΥΜΒ[Ι] <> ')' ΚΑΙ ΣΥΜΒ[Ι+1] <> '(' ΚΑΙ ΣΥΜΒ[Ι+1] <> ')' ΚΑΙ ΣΥΜΒ[Ι+1]='=' ΚΑΙ ΣΥΜΒ[Ι]='=' ΤΟΤΕ
                            Α <-- 17
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΤΕΛΟΣ_ΑΝ
                          ΑΝ ( ΣΥΜΒ[Ι]='(' ΚΑΙ ΣΥΜΒ[Ι+1]=')' ) Ή ( ΣΥΜΒ[Ι]=')' ΚΑΙ ΣΥΜΒ[Ι+1]='(' ) ΤΟΤΕ
                            Α <-- 17
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                        ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ
                          ΑΝ ΔΥΝΧ[Ι]>0 ΤΟΤΕ
                            ΑΝ Ι = 1 ΤΟΤΕ
                              ΑΝ ΣΥΜΒ[Ι+1] = ' ' Ή ΣΥΜΒ[Ι+1] = '(' ΤΟΤΕ
                                ΑΝ ΤΕΛ = 126 ΤΟΤΕ
                                  Α <-- 10
                                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                                ΑΛΛΙΩΣ
                                  ΓΙΑ Ξ ΑΠΟ ΤΕΛ ΜΕΧΡΙ Ι+1 ΜΕ ΒΗΜΑ -1
                                    ΣΥΝΤΕΛ[Ξ+1] <-- ΣΥΝΤΕΛ[Ξ]
                                    ΣΥΜΒ[Ξ+1] <-- ΣΥΜΒ[Ξ]
                                    ΔΥΝΧ[Ξ+1] <-- ΔΥΝΧ[Ξ]
                                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                  ΣΥΝΤΕΛ[Ι+1] <-- 0
                                  ΣΥΜΒ[Ι+1] <-- '*'
                                  ΔΥΝΧ[Ι+1] <-- 0
                                  ΤΕΛ <-- ΤΕΛ+1
                                ΤΕΛΟΣ_ΑΝ
                              ΤΕΛΟΣ_ΑΝ
                            ΑΛΛΙΩΣ_ΑΝ Ι = ΤΕΛ ΤΟΤΕ
                              ΑΝ ΣΥΜΒ[Ι-1] = ' ' Ή ΣΥΜΒ[Ι-1] = ')' ΤΟΤΕ
                                ΑΝ ΤΕΛ = 126 ΤΟΤΕ
                                  Α <-- 10
                                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                                ΑΛΛΙΩΣ
                                  ΣΥΝΤΕΛ[ΤΕΛ+1] <-- ΣΥΝΤΕΛ[ΤΕΛ]
                                  ΣΥΜΒ[ΤΕΛ+1] <-- ΣΥΜΒ[ΤΕΛ]
                                  ΔΥΝΧ[ΤΕΛ+1] <-- ΔΥΝΧ[ΤΕΛ]
                                  ΣΥΝΤΕΛ[ΤΕΛ] <-- 0
                                  ΣΥΜΒ[ΤΕΛ] <-- '*'
                                  ΔΥΝΧ[ΤΕΛ] <-- 0
                                  ΤΕΛ <-- ΤΕΛ+1
                                ΤΕΛΟΣ_ΑΝ
                              ΤΕΛΟΣ_ΑΝ
                            ΑΛΛΙΩΣ
                              ΑΝ ΣΥΜΒ[Ι-1] = ' ' Ή ΣΥΜΒ[Ι+1] = ' ' Ή ΣΥΜΒ[Ι-1] = ')' Ή ΣΥΜΒ[Ι+1] = '(' ΤΟΤΕ
                                ΑΝ ΤΕΛ = 126 ΤΟΤΕ
                                  Α <-- 10
                                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                                ΑΛΛΙΩΣ
                                  ΑΝ ΣΥΜΒ[Ι+1] = ' ' Ή ΣΥΜΒ[Ι+1] = '(' ΤΟΤΕ
                                    ΓΙΑ Ξ ΑΠΟ ΤΕΛ ΜΕΧΡΙ Ι+1 ΜΕ ΒΗΜΑ -1
                                      ΣΥΝΤΕΛ[Ξ+1] <-- ΣΥΝΤΕΛ[Ξ]
                                      ΣΥΜΒ[Ξ+1] <-- ΣΥΜΒ[Ξ]
                                      ΔΥΝΧ[Ξ+1] <-- ΔΥΝΧ[Ξ]
                                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                    ΣΥΝΤΕΛ[Ι+1] <-- 0
                                    ΣΥΜΒ[Ι+1] <-- '*'
                                    ΔΥΝΧ[Ι+1] <-- 0
                                    ΤΕΛ <-- ΤΕΛ+1
                                  ΤΕΛΟΣ_ΑΝ
                                  ΑΝ ΣΥΜΒ[Ι-1] = ' ' Ή ΣΥΜΒ[Ι-1] = ')' ΤΟΤΕ
                                    ΓΙΑ Ξ ΑΠΟ ΤΕΛ ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
                                      ΣΥΝΤΕΛ[Ξ+1] <-- ΣΥΝΤΕΛ[Ξ]
                                      ΣΥΜΒ[Ξ+1] <-- ΣΥΜΒ[Ξ]
                                      ΔΥΝΧ[Ξ+1] <-- ΔΥΝΧ[Ξ]
                                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                    ΣΥΝΤΕΛ[Ι] <-- 0
                                    ΣΥΜΒ[Ι] <-- '*'
                                    ΔΥΝΧ[Ι] <-- 0
                                    ΤΕΛ <-- ΤΕΛ+1
                                  ΤΕΛΟΣ_ΑΝ
                                ΤΕΛΟΣ_ΑΝ
                              ΤΕΛΟΣ_ΑΝ
                            ΤΕΛΟΣ_ΑΝ
                          ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                      ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
!"ΚΑΤΑΣΚΕΒΗ" ΤΩΝ ΑΡΙΘΜΩΝ ! ------------------------------------------------------------------------------!
                      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ-1
                        ΑΝ ΔΥΝΧ[Ι] <= 0 ΚΑΙ ΣΥΜΒ[Ι]= ' ' ΚΑΙ ΔΥΝΧ[Ι+1] <= 0 ΚΑΙ ΣΥΜΒ[Ι+1]= ' ' ΤΟΤΕ
                          ΣΥΝΤΕΛ[Ι] <-- (ΣΥΝΤΕΛ[Ι]*10) + ΣΥΝΤΕΛ[Ι+1]
                          ΔΥΝΧ[Ι] <-- ΔΥΝΧ[Ι]+ΔΥΝΧ[Ι+1]
                          ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                          Ι <-- Ι - 1
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   !ΤΕΛΟΣ "ΚΑΤΑΣΚΕΒΗΣ" ΤΩΝ ΑΡΙΘΜΩΝ ! ----------------------------------------------------------------------!
!"ΚΑΤΑΣΚΕΒΗ" ΚΑΙ ΤΩΝ ΔΕΚΑΔΙΚΩΝ ! ----------------------------------------------------------------------!
                      ΓΙΑ Ι ΑΠΟ 1+1 ΜΕΧΡΙ ΤΕΛ-1
                        ΑΝ ΣΥΜΒ[Ι]='.' ΤΟΤΕ
                          ΑΝ ΣΥΜΒ[Ι-1] <> ' ' Ή  ΣΥΜΒ[Ι+1] <> ' ' Ή ΔΥΝΧ[Ι-1] > 0 Ή ΔΥΝΧ[Ι+1] > 0 ΤΟΤΕ
                            Α <-- 3
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΑΛΛΙΩΣ_ΑΝ ΣΥΝΤΕΛ[Ι-1] <> Α_Μ(ΣΥΝΤΕΛ[Ι-1]) Ή ΣΥΝΤΕΛ[Ι+1] <> Α_Μ(ΣΥΝΤΕΛ[Ι+1]) ΤΟΤΕ
                            Α <-- 4
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΑΛΛΙΩΣ
                            Δ <-- ΔΥΝΧ[Ι+1]
                            ΣΥΝΤΕΛ[Ι-1] <-- ΣΥΝΤΕΛ[Ι-1]+(ΣΥΝΤΕΛ[Ι+1]*(10^Δ))
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                            Ι <-- Ι - 2
                          ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!ΤΕΛΟΣ "ΚΑΤΑΣΚΕΒΗΣ" ΚΑΙ ΤΩΝ ΔΕΚΑΔΙΚΩΝ ! ----------------------------------------------------------------------!
                    ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
  !Η ΔΥΝΧ ΑΠΟ ΕΔΩ ΚΑΙ ΚΑΤΩ ΘΑ ΠΕΡΙΕΧΕΙ ΜΟΝΟ ΤΗΝ ΔΥΝΑΜΗ ΣΤΗΝ ΟΠΟΙΑ ΕΙΝΑΙ ΥΨΩΜΕΝΟ ΤΟ Χ
                    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ
                      ΑΝ ΔΥΝΧ[Ι] <0 ΤΟΤΕ
                        ΔΥΝΧ[Ι] <-- 0
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Η ΔΥΝΧ ΑΠΟ ΕΔΩ ΚΑΙ ΚΑΤΩ ΘΑ ΠΕΡΙΕΧΕΙ ΜΟΝΟ ΤΗΝ ΔΥΝΑΜΗ ΣΤΗΝ ΟΠΟΙΑ ΕΙΝΑΙ ΥΨΩΜΕΝΟ ΤΟ Χ
!ΔΥΝΑΜΕΙΣ
                    ΓΙΑ Ι ΑΠΟ 1+1 ΜΕΧΡΙ ΤΕΛ-1
                      ΑΝ ΣΥΜΒ[Ι]='^' ΤΟΤΕ
                        ΑΝ ΣΥΜΒ[Ι-1]=' ' ΚΑΙ ΣΥΜΒ[Ι+1] = ' ' ΤΟΤΕ
                          ΑΝ ΔΥΝΧ[Ι+1] = 0 ΤΟΤΕ
                            Δ <-- ΣΥΝΤΕΛ[Ι+1]
                            Ψ <-- ΣΥΝΤΕΛ[Ι-1]
                            ΣΥΝΤΕΛ[Ι-1] <-- Ψ^Δ
                            ΔΥΝΧ[Ι-1] <-- ΔΥΝΧ[Ι-1] * ΣΥΝΤΕΛ[Ι+1]
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                            Ι <-- Ι - 2
                          ΑΛΛΙΩΣ
                            Α <-- 16
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΤΕΛΟΣ_ΑΝ
                        ΑΛΛΙΩΣ_ΑΝ (ΣΥΜΒ[Ι-1] <> ' ' ΚΑΙ ΣΥΜΒ[Ι-1] <> ')' ) Ή (ΣΥΜΒ[Ι+1] <> ' ' ΚΑΙ ΣΥΜΒ[Ι+1] <> '(' ) ΤΟΤΕ
                          Α <-- 9
                          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                  ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
  !ΤΕΛΟΣ ΔΥΝΑΜΕΩΝ
!-Α ΓΡΑΦΕΤΕ ΩΣ [-|9] ΣΕ ΔΙΑΦΟΡΕΤΙΚΕΣ ΣΤΗΛΕΣ (ΔΙΑΦΟΡΕΤΙΚΑ Ι)) ΕΔΩ ΘΑ ΜΕΤΑΤΡΕΠΟΝΤΑΙ ΣΕ 1 ΣΤΗΛΗ (ΙΔΙΟ Ι) ( [-9] )
                  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ-1
                    ΑΝ ΣΥΜΒ[Ι]='-' ΤΟΤΕ
                      ΕΠΑΝ <-- ΑΛΗΘΗΣ
                      ΑΝ Ι <> ΤΕΛ-2 ΤΟΤΕ
                        ΑΝ ΣΥΜΒ[Ι+2] = '^' ΤΟΤΕ
                          ΕΠΑΝ <-- ΨΕΥΔΗΣ
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ ΣΥΜΒ[Ι+1]=' ' ΤΟΤΕ
                        ΑΝ ΕΠΑΝ ΤΟΤΕ
                          ΣΥΝΤΕΛ[Ι] <-- - ΣΥΝΤΕΛ[Ι+1]
                          ΔΥΝΧ[Ι] <-- ΔΥΝΧ[Ι+1]
                          ΣΥΜΒ[Ι] <-- ' '
                          ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                          Ι <-- Ι - 1
                        ΤΕΛΟΣ_ΑΝ
                      ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι+1] <> '(' ΤΟΤΕ
                        Α <-- 12
                        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                      ΤΕΛΟΣ_ΑΝ
                    ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι]='+' ΤΟΤΕ
                      ΑΝ ΣΥΜΒ[Ι+1] = ' ' Ή ΣΥΜΒ[Ι+1] = '(' ΤΟΤΕ
                        ΣΥΝΤΕΛ[Ι] <-- ΣΥΝΤΕΛ[Ι+1]
                        ΔΥΝΧ[Ι] <-- ΔΥΝΧ[Ι+1]
                        ΣΥΜΒ[Ι] <-- ΣΥΜΒ[Ι+1]
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                        Ι <-- Ι -1
                      ΑΛΛΙΩΣ
                        Α <-- 12
                        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΜΕΧΡΙΣ_ΟΤΟΥ Α=0
 !ΤΕΛΟΣ -Α ΓΡΑΦΕΤΕ ΩΣ [-|9] ΣΕ ΔΙΑΦΟΡΕΤΙΚΕΣ ΣΤΗΛΕΣ (ΔΙΑΦΟΡΕΤΙΚΑ Ι)) ΕΔΩ ΘΑ ΜΕΤΑΤΡΕΠΟΝΤΑΙ ΣΕ 1 ΣΤΗΛΗ (ΙΔΙΟ Ι) ( [-9] )
  !ΔΙΑΙΡΕΣΗ ( 5/4=5*[4^(-1)] ) ( ΟΙ ΔΙΑΙΡΕΣΕΙΣ ΜΕ ΠΑΡΕΝΘΕΣΗ ΔΕΝ ΓΙΝΟΝΤΑΙ ΕΔΩ ΔΗΛΑΔΗ ΤΟ 5/(9+4) ΔΕΝ ΘΑ ΓΙΝΕΙ ΕΔΩ )
                ΓΙΑ Ι ΑΠΟ 1+1 ΜΕΧΡΙ ΤΕΛ-1
                  ΑΝ ΣΥΜΒ[Ι]='/' ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ι+1]=' ' ΤΟΤΕ
                      ΣΥΜΒ[Ι] <-- '*'
                      Δ <-- -1
                      Ψ <-- ΣΥΝΤΕΛ[Ι+1]
                      ΑΝ ΣΥΝΤΕΛ[Ι+1] = 0 ΤΟΤΕ
                        Α <-- 22
                        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ Α = 0 ΤΟΤΕ
                        ΣΥΝΤΕΛ[Ι+1] <-- Ψ^Δ
                        ΔΥΝΧ[Ι+1] <-- ΔΥΝΧ[Ι+1] * (-1)
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ ΔΥΝΧ[Ι+1] < 0 ΤΟΤΕ
                        Α <-- 6
                        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                      ΤΕΛΟΣ_ΑΝ
                    ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι+1] <> '(' ΤΟΤΕ
                      Α <-- 7
                      ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!ΤΕΛΟΣ ΕΠΕΞΕΡΓΑΣΙΑΣ ΔΙΑΙΡΕΣΕΩΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ Α =0
 !ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΙ ( ΟΙ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΙ ΜΕ ΠΑΡΕΝΘΕΣΗ ΔΕΝ ΓΙΝΟΝΤΑΙ ΕΔΩ ΔΗΛΑΔΗ ΤΟ 5*(9+4) ΔΕΝ ΘΑ ΓΙΝΕΙ ΕΔΩ )
              ΓΙΑ Ι ΑΠΟ 1+1 ΜΕΧΡΙ ΤΕΛ-1
                ΑΝ ΣΥΜΒ[Ι]='*' ΤΟΤΕ
                  ΑΝ ΣΥΜΒ[Ι-1] = ' ' ΚΑΙ ΣΥΜΒ[Ι+1] = ' ' ΤΟΤΕ
                    ΑΝ Υ_Π(ΣΥΜΒ, Ι, ΤΕΛ) ΤΟΤΕ
                      ΣΥΝΤΕΛ[Ι-1] <-- ΣΥΝΤΕΛ[Ι-1] * ΣΥΝΤΕΛ[Ι+1]
                      ΔΥΝΧ[Ι-1] <-- ΔΥΝΧ[Ι-1] + ΔΥΝΧ[Ι+1]
                      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                      Ι <-- Ι - 2
                    ΤΕΛΟΣ_ΑΝ
                  ΑΛΛΙΩΣ_ΑΝ (ΣΥΜΒ[Ι-1] <> ' ' ΚΑΙ ΣΥΜΒ[Ι-1] <> ')' ) Ή (ΣΥΜΒ[Ι+1] <> ' ' ΚΑΙ ΣΥΜΒ[Ι+1] <> '(' ) ΤΟΤΕ
                    Α <-- 5
                    ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                  ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
!ΤΕΛΟΣ ΠΟΛΛΑΠΛΑΣΙΑΣΜΩΝ
!ΠΑΡΕΝΘΕΣΕΙΣ
            Ι <-- 0
            Ξ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              Ι <-- Ι + 1
              ΑΝ ΣΥΜΒ[Ι] = ')' ΤΟΤΕ
                Ξ <-- 1
              ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι] = '(' ΤΟΤΕ
                Ξ <-- 2
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Ξ <> 0 Ή ΣΥΜΒ[Ι] = '='
            ΑΝ Ξ = 1 ΤΟΤΕ
              Α <-- 19
              ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
            ΤΕΛΟΣ_ΑΝ
            Ι <-- 0
            Ξ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              Ι <-- Ι + 1
            ΜΕΧΡΙΣ_ΟΤΟΥ ΣΥΜΒ[Ι]='='
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              Ι <-- Ι + 1
              ΑΝ ΣΥΜΒ[Ι] = ')' ΤΟΤΕ
                Ξ <-- 1
              ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι] = '(' ΤΟΤΕ
                Ξ <-- 2
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Ξ <> 0 Ή Ι=ΤΕΛ
            ΑΝ Ξ = 1 ΤΟΤΕ
              Α <-- 19
              ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
            ΤΕΛΟΣ_ΑΝ
  !ΠΑΡΕΝΘΕΣΕΙΣ ΣΤΟ 1ο ΜΕΛΟΣ
            ΜΕΤΡΗΤΗΣ <-- 0
            ΜΕΤΡΗΤΗΣ2 <-- 0
            Ι <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              Ι <-- Ι + 1
              ΑΝ ΣΥΜΒ[Ι] = '(' ΤΟΤΕ
                ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ + 1
              ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι] = ')' ΤΟΤΕ
                ΜΕΤΡΗΤΗΣ2 <-- ΜΕΤΡΗΤΗΣ2 + 1
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ ΣΥΜΒ[Ι+1] = '='
            ΑΝ ΜΕΤΡΗΤΗΣ <> ΜΕΤΡΗΤΗΣ2 ΤΟΤΕ
              Α <-- 8
              ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
            ΤΕΛΟΣ_ΑΝ
          ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
!ΠΑΡΕΝΘΕΣΕΙΣ ΣΤΟ 2ο ΜΕΛΟΣ
          ΜΕΤΡΗΤΗΣ <-- 0
          ΜΕΤΡΗΤΗΣ2 <-- 0
          Ι <-- Ι +1
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            Ι <-- Ι + 1
            ΑΝ ΣΥΜΒ[Ι] = '(' ΤΟΤΕ
              ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ + 1
            ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι] = ')' ΤΟΤΕ
              ΜΕΤΡΗΤΗΣ2 <-- ΜΕΤΡΗΤΗΣ2 + 1
            ΤΕΛΟΣ_ΑΝ
          ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΤΕΛ
          ΑΝ ΜΕΤΡΗΤΗΣ <> ΜΕΤΡΗΤΗΣ2 ΤΟΤΕ
            Α <-- 8
            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
          ΤΕΛΟΣ_ΑΝ
        ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
        !ΤΕΛΟΣ ΕΛΕΓΧΟΥ ΠΑΡΕΝΘΕΣΕΩΝ
        ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ-2
          ΑΝ Α = 0 ΤΟΤΕ
            ΑΝ ΣΥΜΒ[Ι]='(' ΤΟΤΕ               !ΣΥΝΕΧΙΖΕΙ ΑΝ ΒΡΕΙ ΠΑΡΕΝΘΕΣΗ
              ΑΝ Ε_Π(ΣΥΜΒ, Ι) ΤΟΤΕ              !ΣΥΝΕΧΙΖΕΙ ΑΝ ΔΕΝ ΕΧΕΙ ΑΛΛΕΣ ΠΑΡΕΝΘΕΣΕΙΣ ΜΕΣΑ
                ΕΠΑΝ <-- ΑΛΗΘΗΣ
!ΠΡΟΣΘΕΣΗ ΜΟΝΩΝΥΜΩΝ ΜΕΣΑ ΣΤΗΝ ΠΑΡΕΝΘΕΣΗ
                Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                ΚΑΛΕΣΕ ΠΡ_ΜΟΝ(Ι, Ξ, ΣΥΜΒ, ΣΥΝΤΕΛ, ΔΥΝΧ, ΤΕΛ)
!ΤΕΛΟΣ ΠΡΟΣΘΕΣΗΣ ΜΟΝΟΝΗΜΩΝ ΜΕΣΑ ΣΤΗΝ ΠΑΡΕΝΘΕΣΗ
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
!ΔΥΝΑΜΕΙΣ
  !ΠΡΙΝ
                  ΑΝ Ι <> 1 ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ι-1] = '^' ΤΟΤΕ
                      ΑΝ Ξ-Ι <> 2 Ή ΔΥΝΧ[Ι+1] <> 0 ΤΟΤΕ
                        Α <-- 20
                        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ ΣΥΜΒ[Ι-2] = ' ' ΤΟΤΕ
                        Δ <-- ΣΥΝΤΕΛ[Ι+1]
                        Ψ <-- ΣΥΝΤΕΛ[Ι-2]
                        ΣΥΝΤΕΛ[Ι+1] <-- Ψ^Δ
                        Ψ <-- ΔΥΝΧ[Ι-2]
                        ΔΥΝΧ[Ι+1] <-- Ψ*Δ
                        ΑΝ ΔΥΝΧ[Ι+1] < 0 ΤΟΤΕ
                          Α <-- 6
                          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                        ΤΕΛΟΣ_ΑΝ
                        Ι <-- Ι-1
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                        Ι <-- Ι-1
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                      ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι-2] = ')' ΤΟΤΕ
                        ΑΝ ΣΥΝΤΕΛ[Ι+1] <> Α_Μ( ΣΥΝΤΕΛ[Ι+1] ) ΤΟΤΕ
                          Α <-- 21
                          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                        ΑΛΛΙΩΣ
                          Ξ <-- 0
                          ΜΕΤΡΗΤΗΣ <-- 0
                          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                            Ξ <-- Ξ + 1
                            ΑΝ ΣΥΜΒ[Ξ]='(' ΤΟΤΕ
                              ΑΝ Κ_Π(Ξ, ΣΥΜΒ)=Ι-2 ΤΟΤΕ
                                ΜΕΤΡΗΤΗΣ <-- 1
                              ΤΕΛΟΣ_ΑΝ
                            ΤΕΛΟΣ_ΑΝ
                          ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΤΡΗΤΗΣ=1
                          ΑΝ ΣΥΝΤΕΛ[Ι+1]=0 ΤΟΤΕ
                            ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ξ+1 ΜΕΧΡΙ Ι+1
                              ΜΕΤΡΗΤΗΣ2 <-- Ξ+1
                              ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, ΤΕΛ)
                            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                            Ψ <-- 1
                            Δ <-- 0
                            ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ξ, ΤΕΛ, Δ, Ψ)
                            Ι <-- Ξ
                          ΑΛΛΙΩΣ_ΑΝ Α_Τ(ΣΥΝΤΕΛ[Ι+1])=1 ΤΟΤΕ
                            Δ <-- ΣΥΝΤΕΛ[Ι+1]
                            ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ι-1 ΜΕΧΡΙ Ι+2
                              ΜΕΤΡΗΤΗΣ2 <-- Ι-1
                              ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, ΤΕΛ)
                            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                            ΑΝ Δ = -1 ΤΟΤΕ
                              ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ξ+1 ΜΕΧΡΙ Ι-3
                                ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] <-- 1/ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ]
                                ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] <-- -ΔΥΝΧ[ΜΕΤΡΗΤΗΣ]
                                ΑΝ ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] < 0 ΤΟΤΕ
                                  Α <-- 6
                                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                                ΤΕΛΟΣ_ΑΝ
                              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                            ΤΕΛΟΣ_ΑΝ
                            Ι <-- Ξ
                          ΑΛΛΙΩΣ
                            ΚΑΛΕΣΕ ΔΥΝ_ΠΑΡ(Ξ, Ι, ΣΥΝΤΕΛ, ΔΥΝΧ, Α, ΣΥΜΒ, ΤΕΛ)
                            Ι <-- Ξ
                            ΑΝ Α <> 0 ΤΟΤΕ
                              ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                            ΤΕΛΟΣ_ΑΝ
                          ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
  !ΜΕΤΑ
                  Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                  ΑΝ Ξ <> ΤΕΛ ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ξ+1] = '^' ΤΟΤΕ
                      ΑΝ ΣΥΜΒ[Ξ+2] = '(' ΤΟΤΕ
                        ΕΠΑΝ <-- ΨΕΥΔΗΣ
                      ΑΛΛΙΩΣ
                        ΑΝ ΣΥΜΒ[Ξ+2] <> ' ' ΤΟΤΕ
                          Α <-- 9
                          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                        ΑΛΛΙΩΣ
                          ΑΝ ΔΥΝΧ[Ξ+2] <> 0 ΤΟΤΕ
                            Α <-- 16
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΑΛΛΙΩΣ_ΑΝ ΣΥΝΤΕΛ[Ξ+2] = 1 ΤΟΤΕ
                            ΜΕΤΡΗΤΗΣ <-- Ξ + 2
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                            ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ - 1
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                          ΑΛΛΙΩΣ_ΑΝ ΣΥΝΤΕΛ[Ξ+2] = -1 ΤΟΤΕ
                            ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ι + 1 ΜΕΧΡΙ Ξ-1
                              ΑΝ Α = 0 ΤΟΤΕ
                                ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] <-- 1/ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ]
                                ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] <-- -ΔΥΝΧ[ΜΕΤΡΗΤΗΣ]
                                ΑΝ ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] < 0 ΤΟΤΕ
                                  Α <-- 6
                                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                                ΤΕΛΟΣ_ΑΝ
                              ΤΕΛΟΣ_ΑΝ
                            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                            ΜΕΤΡΗΤΗΣ <-- Ξ + 2
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                            ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ - 1
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                          ΑΛΛΙΩΣ_ΑΝ ΣΥΝΤΕΛ[Ξ+2] = 0 ΤΟΤΕ
                            ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ι+1 ΜΕΧΡΙ Ξ-1
                              ΜΕΤΡΗΤΗΣ2 <-- Ι+1
                              ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, ΤΕΛ)
                            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                            Ψ <-- 1
                            Δ <-- 0
                            ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ, Δ, Ψ)
                          ΑΛΛΙΩΣ_ΑΝ ΣΥΝΤΕΛ[Ξ+2]<>Α_Μ(ΣΥΝΤΕΛ[Ξ+2]) ΤΟΤΕ
                            Α <-- 21
                            ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                          ΑΛΛΙΩΣ
                            ΚΑΛΕΣΕ ΔΥΝ_ΠΑΡ2(Ι, Ξ, ΣΥΝΤΕΛ, ΔΥΝΧ, Α, ΣΥΜΒ, ΤΕΛ, ΣΥΝΤΕΛ[Ξ+2])
                            Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                            ΜΕΤΡΗΤΗΣ <-- Ξ + 2
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                            ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ - 1
                            ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                          ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
!ΤΕΛΟΣ ΔΥΝΑΜΕΩΝ
!ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ
!ΠΡΙΝ
                  ΑΝ Ι <> 1 ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ι-1] = '*' ΚΑΙ Α = 0 ΤΟΤΕ
                      Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                      ΑΝ ΣΥΜΒ[Ι-2] = ' ' ΤΟΤΕ
                        ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ι + 1 ΜΕΧΡΙ Ξ-1
                          ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] <-- ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ]*ΣΥΝΤΕΛ[Ι-2]
                          ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] <-- ΔΥΝΧ[ΜΕΤΡΗΤΗΣ]+ΔΥΝΧ[Ι-2]
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                        Ι <-- Ι-1
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                        Ι <-- Ι-1
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                      ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι-2] = ')' ΤΟΤΕ
                        ΜΕΤΡΗΤΗΣ2 <-- 0
                        ΜΕΤΡΗΤΗΣ <-- 0
                        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                          ΜΕΤΡΗΤΗΣ2 <-- ΜΕΤΡΗΤΗΣ2 + 1
                          ΑΝ ΣΥΜΒ[ΜΕΤΡΗΤΗΣ2]='(' ΤΟΤΕ
                            ΑΝ Κ_Π(ΜΕΤΡΗΤΗΣ2, ΣΥΜΒ)=Ι-2 ΤΟΤΕ
                              ΜΕΤΡΗΤΗΣ <-- 1
                            ΤΕΛΟΣ_ΑΝ
                          ΤΕΛΟΣ_ΑΝ
                        ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΤΡΗΤΗΣ=1
                        ΚΑΛΕΣΕ ΠΟΛ_ΠΑΡ(Ι, Ξ, ΣΥΝΤΕΛ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, Α, ΣΥΜΒ, ΤΕΛ)
                        Ι <-- ΜΕΤΡΗΤΗΣ2
                        ΑΝ Α <> 0 ΤΟΤΕ
                          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
!ΜΕΤΑ
                  Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                  ΑΝ Ξ <> ΤΕΛ ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ξ+1] = '*' ΤΟΤΕ
                      ΑΝ ΣΥΜΒ[Ξ+2] = '(' ΤΟΤΕ
                        ΕΠΑΝ <-- ΨΕΥΔΗΣ
                      ΑΛΛΙΩΣ
                        ΑΝ ΣΥΜΒ[Ξ+2] <> ' ' ΤΟΤΕ
                          Α <-- 5
                          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                        ΑΛΛΙΩΣ
                          ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ι + 1 ΜΕΧΡΙ Ξ - 1
                            ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] <-- ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] * ΣΥΝΤΕΛ [Ξ+2]
                            ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] <-- ΔΥΝΧ[ΜΕΤΡΗΤΗΣ] + ΔΥΝΧ[Ξ+2]
                          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                          ΜΕΤΡΗΤΗΣ <-- Ξ + 2
                          ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                          ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ - 1
                          ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                        ΤΕΛΟΣ_ΑΝ
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
!ΤΕΛΟΣ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΥ
!ΔΙΑΙΡΕΣΗ
!ΠΡΙΝ
                  ΑΝ Ι <> 1 ΚΑΙ Α = 0 ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ι-1] = '/' ΤΟΤΕ
                      ΑΝ Ξ-Ι <> 2 Ή ΔΥΝΧ[Ι+1] <> 0 ΤΟΤΕ
                        Α <-- 20
                        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ ΣΥΜΒ[Ι-2] = ' ' ΚΑΙ Α = 0 ΤΟΤΕ
                        ΣΥΝΤΕΛ[Ι+1] <-- ΣΥΝΤΕΛ[Ι-1] / ΣΥΝΤΕΛ[Ι+1]
                        ΔΥΝΧ[Ι+1] <-- ΔΥΝΧ[Ι-1]
                        Ι <-- Ι - 1
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                        Ι <-- Ι - 1
                        ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                      ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι-2] = ')' ΚΑΙ Α = 0 ΤΟΤΕ
                        Ξ <-- 0
                        ΜΕΤΡΗΤΗΣ <-- 0
                        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                          Ξ <-- Ξ + 1
                          ΑΝ ΣΥΜΒ[Ξ]='(' ΤΟΤΕ
                            ΑΝ Κ_Π(Ξ, ΣΥΜΒ)=Ι-2 ΤΟΤΕ
                              ΜΕΤΡΗΤΗΣ <-- 1
                            ΤΕΛΟΣ_ΑΝ
                          ΤΕΛΟΣ_ΑΝ
                        ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΤΡΗΤΗΣ=1
                        Ψ <-- ΣΥΝΤΕΛ[Ι+1]
                        ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ξ+1 ΜΕΧΡΙ Ι-3
                          Δ <-- ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ]
                          ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] <-- Δ/ Ψ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                        ΓΙΑ Ψ ΑΠΟ Ι-2 ΜΕΧΡΙ Ι + 1
                          ΜΕΤΡΗΤΗΣ <-- Ι-3
                          ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ, ΤΕΛ)
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                        Ι <-- Ξ
                      ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
!ΜΕΤΑ
                  ΑΝ ΣΥΜΒ[Ξ+1] = '/' ΤΟΤΕ
                    ΕΠΑΝ <-- ΨΕΥΔΗΣ
                  ΤΕΛΟΣ_ΑΝ
!ΤΕΛΟΣ ΔΙΑΙΡΕΣΗΣ
!ΑΦΑΙΡΕΣΗ
!ΠΡΙΝ
                  ΑΝ Ι <> 1 ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ι-1] = '-' ΚΑΙ Α = 0 ΤΟΤΕ
                      Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                      ΓΙΑ ΜΕΤΡΗΤΗΣ ΑΠΟ Ι+1 ΜΕΧΡΙ Ξ-1
                        ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ] <-- -ΣΥΝΤΕΛ[ΜΕΤΡΗΤΗΣ]
                      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                      Ι <-- Ι-1
                      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                    ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
!ΜΕΤΑ
!----!
!ΤΕΛΟΣ ΑΦΑΙΡΕΣΗΣ
!ΠΡΟΣΘΕΣΗ
!----!
!ΤΕΛΟΣ ΠΡΟΣΘΕΣΗΣ
                  Ξ <-- Κ_Π(Ι, ΣΥΜΒ)
                  Λ <-- ΨΕΥΔΗΣ
                  Σ <-- ΨΕΥΔΗΣ
                  ΑΝ Ι <> 1 ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ι-1]=' ' Ή ΣΥΜΒ[Ι-1]=')' Ή ΣΥΜΒ[Ι-1]='(' Ή ΣΥΜΒ[Ι-1]='=' ΤΟΤΕ
                      Λ <-- ΑΛΗΘΗΣ
                    ΤΕΛΟΣ_ΑΝ
                  ΑΛΛΙΩΣ
                    Λ <-- ΑΛΗΘΗΣ
                  ΤΕΛΟΣ_ΑΝ
                  ΑΝ Ξ <> ΤΕΛ ΤΟΤΕ
                    ΑΝ ΣΥΜΒ[Ξ+1]=' ' Ή ΣΥΜΒ[Ξ+1]=')' Ή ΣΥΜΒ[Ξ+1]='(' Ή ΣΥΜΒ[Ξ+1]='=' Ή ΣΥΜΒ[Ξ+1]='-' ΤΟΤΕ
                      Σ <-- ΑΛΗΘΗΣ
                    ΤΕΛΟΣ_ΑΝ
                  ΑΛΛΙΩΣ
                    Σ <-- ΑΛΗΘΗΣ
                  ΤΕΛΟΣ_ΑΝ
                  ΑΝ Σ=ΑΛΗΘΗΣ ΚΑΙ Λ=ΑΛΗΘΗΣ ΤΟΤΕ
                    Λ <-- ΑΛΗΘΗΣ
                  ΑΛΛΙΩΣ
                    Λ <-- ΨΕΥΔΗΣ
                  ΤΕΛΟΣ_ΑΝ
                ΜΕΧΡΙΣ_ΟΤΟΥ Λ Ή ΕΠΑΝ=ΨΕΥΔΗΣ
                ΑΝ ΕΠΑΝ ΤΟΤΕ
                  Ξ <-- Κ_Π(Ι, ΣΥΜΒ) - 1
                  ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
                  ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ξ, ΤΕΛ)
                  Ι <-- 0
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
      ΕΠΑΝ <-- ΨΕΥΔΗΣ
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ
        ΑΝ ΣΥΜΒ[Ι] = '=' ΤΟΤΕ
          ΕΠΑΝ <-- ΑΛΗΘΗΣ
          ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
          Ι <-- Ι - 1
        ΑΛΛΙΩΣ_ΑΝ ΕΠΑΝ ΤΟΤΕ
          ΣΥΝΤΕΛ[Ι] <-- -ΣΥΝΤΕΛ[Ι]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      Ι <-- 1
      Ξ <-- ΤΕΛ + 1
      ΚΑΛΕΣΕ ΠΡ_ΜΟΝ(Ι, Ξ, ΣΥΜΒ, ΣΥΝΤΕΛ, ΔΥΝΧ, ΤΕΛ)
      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ
        ΑΝ ΔΥΝΧ[Ι] <> 0 ΚΑΙ ΔΥΝΧ[Ι] <> 1 ΚΑΙ ΔΥΝΧ[Ι] <> 2 ΤΟΤΕ
          Α <-- 15
          ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
    ΑΝ ΤΕΛ > 3 ΤΟΤΕ
      Α <-- 23
      ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Α = 0
  ΑΑ <-- 0
  Β <-- 0
  Γ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΤΕΛ
    ΑΝ ΔΥΝΧ[Ι] = 2 ΤΟΤΕ
      ΑΑ <-- ΣΥΝΤΕΛ[Ι]
    ΑΛΛΙΩΣ_ΑΝ ΔΥΝΧ[Ι] = 1 ΤΟΤΕ
      Β <-- ΣΥΝΤΕΛ[Ι]
    ΑΛΛΙΩΣ_ΑΝ ΔΥΝΧ[Ι] = 0 ΤΟΤΕ
      Γ <-- ΣΥΝΤΕΛ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΑΑ = 0 ΤΟΤΕ
    ΑΝ Β = 0 ΤΟΤΕ
      ΑΝ Γ = 0 ΤΟΤΕ
        ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΤΑΥΤΟΤΗΤΑ'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΔΕΝ ΕΧΕΙ ΛΥΣΕΙΣ'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ ΠΡΩΤΟΒΑΘΜΙΑ'
      ΓΡΑΨΕ 'ΜΕ ΡΙΖΑ Χ =', - (Γ/Β)
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    Δ <-- (Β^2)-4*ΑΑ*Γ
    ΑΝ Δ < 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΔΕΝ ΕΧΕΙ ΛΥΣΕΙΣ ΣΤΟ ΣΥΝΟΛΟ ΤΩΝ ΠΡΑΓΜΑΤΙΚΩΝ ΑΡΙΘΜΩΝ'
    ΑΛΛΙΩΣ_ΑΝ Δ = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΕΧΕΙ ΜΙΑ ΔΙΠΛΗ ΡΙΖΑ ΤΗΝ Χ =', (-Β)/(2*ΑΑ)
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΟΙ ΡΙΖΕΣ ΤΗΣ ΕΞΙΣΩΣΗΣ ΕΙΝΑΙ:'
      ΓΡΑΨΕ 'Χ =', ((-Β)+(Δ^(1/2)))/(2*ΑΑ)
      ΓΡΑΨΕ 'Χ =', ((-Β)-(Δ^(1/2)))/(2*ΑΑ)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!-------------------------------------------------------ΔΙΑΔΙΚΑΣΙΕΣ------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΔΥΝ_ΠΑΡ2(Ε, Ξ, ΣΥΝΤΕΛ, ΔΥΝΧ, Α, ΣΥΜΒ, ΤΕΛ, ΨΧ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Γ, Ε, Ξ, Θ, ΑΧ, ΤΕΛ, ΜΕΓ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛΑ[126, 2], ΔΥΝΧΑ[126, 2], ΣΥΝΤΕΛ[126], ΔΥΝΧ[126], Κ, Λ, ΨΧ
  ΛΟΓΙΚΕΣ: Ζ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΜΕΓ <-- 126-ΤΕΛ+Ξ-Ε-1
  ΓΙΑ ΑΧ ΑΠΟ Ε+1 ΜΕΧΡΙ Ξ-1
    ΣΥΝΤΕΛΑ[ΑΧ-(Ε+1)+1, 1] <-- ΣΥΝΤΕΛ[ΑΧ]
    ΔΥΝΧΑ[ΑΧ-(Ε+1)+1, 1] <-- ΔΥΝΧ[ΑΧ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ΑΧ ΑΠΟ 1 ΜΕΧΡΙ Α_Τ(ΨΧ)-1
    ΑΝ Α = 0 ΤΟΤΕ
      ΑΝ ΑΧ MOD 2 = 1 ΤΟΤΕ
        ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 126
          ΑΝ Α = 0 ΤΟΤΕ
            ΣΥΝΤΕΛΑ[Β, 2] <-- 0
            ΔΥΝΧΑ[Β, 2] <-- -1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΙΑ Β ΑΠΟ Ε+1 ΜΕΧΡΙ Ξ-1
          ΑΝ Α = 0 ΤΟΤΕ
            Θ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΝ Α=0 ΤΟΤΕ
                Θ <-- Θ + 1
                Γ <-- 0
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  Γ <-- Γ + 1
                ΜΕΧΡΙΣ_ΟΤΟΥ ΔΥΝΧΑ[Γ, 2]=-1 Ή ΔΥΝΧΑ[Γ, 2]=ΔΥΝΧΑ[Θ, 1]+ΔΥΝΧ[Β] Ή Γ = 126
                ΑΝ Γ = 126 ΚΑΙ ΔΥΝΧΑ[Γ, 2]<>-1 ΚΑΙ ΔΥΝΧΑ[Γ, 2]<>ΔΥΝΧΑ[Θ, 1]+ΔΥΝΧ[Β] ΤΟΤΕ
                  Α <-- 18
                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                ΑΛΛΙΩΣ
                  ΔΥΝΧΑ[Γ, 2] <-- ΔΥΝΧΑ[Θ, 1]+ΔΥΝΧ[Β]
                  ΣΥΝΤΕΛΑ[Γ, 2] <-- ΣΥΝΤΕΛΑ[Γ, 2] + ( ΣΥΝΤΕΛΑ[Θ, 1]*ΣΥΝΤΕΛ[Β])
                ΤΕΛΟΣ_ΑΝ
                Ζ <-- ΨΕΥΔΗΣ
                ΑΝ Θ <> 126 ΤΟΤΕ
                  ΑΝ ΔΥΝΧΑ[Θ+1, 1]=-1 ΤΟΤΕ
                    Ζ <-- ΑΛΗΘΗΣ
                  ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Θ = 126 Ή Ζ = ΑΛΗΘΗΣ Ή Α <> 0
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ
        ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 126
          ΣΥΝΤΕΛΑ[Β, 1] <-- 0
          ΔΥΝΧΑ[Β, 1] <-- -1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΙΑ Β ΑΠΟ Ε+1 ΜΕΧΡΙ Ξ-1
          ΑΝ Α = 0 ΤΟΤΕ
            Θ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΝ Α=0 ΤΟΤΕ
                Θ <-- Θ + 1
                Γ <-- 0
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  Γ <-- Γ + 1
                ΜΕΧΡΙΣ_ΟΤΟΥ ΔΥΝΧΑ[Γ, 1]=-1 Ή ΔΥΝΧΑ[Γ, 1]=ΔΥΝΧΑ[Θ, 2]+ΔΥΝΧ[Β] Ή Γ = 126
                ΑΝ Γ = 126 ΚΑΙ ΔΥΝΧΑ[Γ, 1]<>-1 ΚΑΙ ΔΥΝΧΑ[Γ, 1]<>ΔΥΝΧΑ[Θ, 2]+ΔΥΝΧ[Β] ΤΟΤΕ
                  Α <-- 18
                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                ΑΛΛΙΩΣ
                  ΔΥΝΧΑ[Γ, 1] <-- ΔΥΝΧΑ[Θ, 2]+ΔΥΝΧ[Β]
                  ΣΥΝΤΕΛΑ[Γ, 1] <-- ΣΥΝΤΕΛΑ[Γ, 1] + ( ΣΥΝΤΕΛΑ[Θ, 2]*ΣΥΝΤΕΛ[Β])
                ΤΕΛΟΣ_ΑΝ
                Ζ <-- ΨΕΥΔΗΣ
                ΑΝ Θ <> 126 ΤΟΤΕ
                  ΑΝ ΔΥΝΧΑ[Θ+1, 2]=-1 ΤΟΤΕ
                    Ζ <-- ΑΛΗΘΗΣ
                  ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Θ = 126 Ή Ζ = ΑΛΗΘΗΣ Ή Α <> 0
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Α = 0 ΤΟΤΕ
    ΑΝ ΣΥΝΤΕΛ[Ξ+2] < 0 ΤΟΤΕ
      Ζ <-- ΨΕΥΔΗΣ
    ΑΛΛΙΩΣ
      Ζ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    Β <-- Ε + 1
    ΓΙΑ Γ ΑΠΟ Ε+1 ΜΕΧΡΙ Ξ-1
      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Β, ΤΕΛ)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΧ MOD 2 = 1 ΤΟΤΕ
      Θ <-- 1
    ΑΛΛΙΩΣ
      Θ <-- 2
    ΤΕΛΟΣ_ΑΝ
    Β <-- Ε
    ΑΧ <-- 0
    Γ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Γ <-- Γ + 1
      ΑΝ ΣΥΝΤΕΛΑ[Γ, Θ] <> 0 ΤΟΤΕ
        ΑΝ Ζ ΤΟΤΕ
          Κ <-- ΔΥΝΧΑ[Γ, Θ]
          Λ <-- ΣΥΝΤΕΛΑ[Γ, Θ]
        ΑΛΛΙΩΣ
          Κ <-- -ΔΥΝΧΑ[Γ, Θ]
          Λ <-- 1 / ΣΥΝΤΕΛΑ[Γ, Θ]
        ΤΕΛΟΣ_ΑΝ
        ΑΝ Κ < 0 ΤΟΤΕ
          Α <-- 6
        ΤΕΛΟΣ_ΑΝ
        ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Β, ΤΕΛ, Κ, Λ)
        ΑΧ <-- ΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Γ = 126 Ή ΔΥΝΧΑ[Γ+1, Θ]=-1 Ή ( Γ+1 > ΜΕΓ ΚΑΙ ΣΥΝΤΕΛΑ[Γ+1, Θ] <> 0 )
    ΑΝ Γ <> 126 ΤΟΤΕ
      ΑΝ Γ+1 > ΜΕΓ ΚΑΙ ΣΥΝΤΕΛΑ[Γ+1, Θ] <> 0 ΚΑΙ ΔΥΝΧΑ[Γ+1, Θ]<>-1 ΤΟΤΕ
        Α <-- 18
        ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΑΧ = 0 ΤΟΤΕ
      Κ <-- 0
      Λ <-- 0
      ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Β, ΤΕΛ, Κ, Λ)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!------------------------------------------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΔΥΝ_ΠΑΡ(Ε, Ι, ΣΥΝΤΕΛ, ΔΥΝΧ, Α, ΣΥΜΒ, ΤΕΛ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Γ, Ε, Ι, Θ, ΑΧ, ΤΕΛ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛΑ[126, 2], ΔΥΝΧΑ[126, 2], ΣΥΝΤΕΛ[126], ΔΥΝΧ[126], Κ, Λ
  ΛΟΓΙΚΕΣ: Ζ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΓΙΑ ΑΧ ΑΠΟ Ε+1 ΜΕΧΡΙ Ι-3
    ΣΥΝΤΕΛΑ[ΑΧ-(Ε+1)+1, 1] <-- ΣΥΝΤΕΛ[ΑΧ]
    ΔΥΝΧΑ[ΑΧ-(Ε+1)+1, 1] <-- ΔΥΝΧ[ΑΧ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ΑΧ ΑΠΟ 1 ΜΕΧΡΙ Α_Τ(ΣΥΝΤΕΛ[Ι+1])-1
    ΑΝ Α = 0 ΤΟΤΕ
      ΑΝ ΑΧ MOD 2 = 1 ΤΟΤΕ
        ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 126
          ΑΝ Α = 0 ΤΟΤΕ
            ΣΥΝΤΕΛΑ[Β, 2] <-- 0
            ΔΥΝΧΑ[Β, 2] <-- -1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΙΑ Β ΑΠΟ Ε+1 ΜΕΧΡΙ Ι-3
          ΑΝ Α = 0 ΤΟΤΕ
            Θ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΝ Α=0 ΤΟΤΕ
                Θ <-- Θ + 1
                Γ <-- 0
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  Γ <-- Γ + 1
                ΜΕΧΡΙΣ_ΟΤΟΥ ΔΥΝΧΑ[Γ, 2]=-1 Ή ΔΥΝΧΑ[Γ, 2]=ΔΥΝΧΑ[Θ, 1]+ΔΥΝΧ[Β] Ή Γ = 126
                ΑΝ Γ = 126 ΚΑΙ ΔΥΝΧΑ[Γ, 2]<>-1 ΚΑΙ ΔΥΝΧΑ[Γ, 2]<>ΔΥΝΧΑ[Θ, 1]+ΔΥΝΧ[Β] ΤΟΤΕ
                  Α <-- 18
                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                ΑΛΛΙΩΣ
                  ΔΥΝΧΑ[Γ, 2] <-- ΔΥΝΧΑ[Θ, 1]+ΔΥΝΧ[Β]
                  ΣΥΝΤΕΛΑ[Γ, 2] <-- ΣΥΝΤΕΛΑ[Γ, 2] + ( ΣΥΝΤΕΛΑ[Θ, 1]*ΣΥΝΤΕΛ[Β])
                ΤΕΛΟΣ_ΑΝ
                Ζ <-- ΨΕΥΔΗΣ
                ΑΝ Θ <> 126 ΤΟΤΕ
                  ΑΝ ΔΥΝΧΑ[Θ+1, 1]=-1 ΤΟΤΕ
                    Ζ <-- ΑΛΗΘΗΣ
                  ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Θ = 126 Ή Ζ = ΑΛΗΘΗΣ Ή Α <> 0
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ
        ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 126
          ΣΥΝΤΕΛΑ[Β, 1] <-- 0
          ΔΥΝΧΑ[Β, 1] <-- -1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΙΑ Β ΑΠΟ Ε+1 ΜΕΧΡΙ Ι-3
          ΑΝ Α = 0 ΤΟΤΕ
            Θ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΝ Α=0 ΤΟΤΕ
                Θ <-- Θ + 1
                Γ <-- 0
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  Γ <-- Γ + 1
                ΜΕΧΡΙΣ_ΟΤΟΥ ΔΥΝΧΑ[Γ, 1]=-1 Ή ΔΥΝΧΑ[Γ, 1]=ΔΥΝΧΑ[Θ, 2]+ΔΥΝΧ[Β] Ή Γ = 126
                ΑΝ Γ = 126 ΚΑΙ ΔΥΝΧΑ[Γ, 1]<>-1 ΚΑΙ ΔΥΝΧΑ[Γ, 1]<>ΔΥΝΧΑ[Θ, 2]+ΔΥΝΧ[Β] ΤΟΤΕ
                  Α <-- 18
                  ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
                ΑΛΛΙΩΣ
                  ΔΥΝΧΑ[Γ, 1] <-- ΔΥΝΧΑ[Θ, 2]+ΔΥΝΧ[Β]
                  ΣΥΝΤΕΛΑ[Γ, 1] <-- ΣΥΝΤΕΛΑ[Γ, 1] + ( ΣΥΝΤΕΛΑ[Θ, 2]*ΣΥΝΤΕΛ[Β])
                ΤΕΛΟΣ_ΑΝ
                Ζ <-- ΨΕΥΔΗΣ
                ΑΝ Θ <> 126 ΤΟΤΕ
                  ΑΝ ΔΥΝΧΑ[Θ+1, 2]=-1 ΤΟΤΕ
                    Ζ <-- ΑΛΗΘΗΣ
                  ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Θ = 126 Ή Ζ = ΑΛΗΘΗΣ Ή Α <> 0
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Α = 0 ΤΟΤΕ
    ΑΝ ΣΥΝΤΕΛ[Ι+1] < 0 ΤΟΤΕ
      Ζ <-- ΨΕΥΔΗΣ
    ΑΛΛΙΩΣ
      Ζ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΓΙΑ Γ ΑΠΟ 1 ΜΕΧΡΙ Ι-Ε+1
      Β <-- Ε + 1
      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Β, ΤΕΛ)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Β <-- Ε
    ΑΝ ΑΧ MOD 2 = 1 ΤΟΤΕ
      Θ <-- 1
    ΑΛΛΙΩΣ
      Θ <-- 2
    ΤΕΛΟΣ_ΑΝ
    ΑΧ <-- 0
    Γ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Γ <-- Γ + 1
      ΑΝ ΣΥΝΤΕΛΑ[Γ, Θ] <> 0 ΤΟΤΕ
        ΑΝ Ζ ΤΟΤΕ
          Κ <-- ΔΥΝΧΑ[Γ, Θ]
          Λ <-- ΣΥΝΤΕΛΑ[Γ, Θ]
        ΑΛΛΙΩΣ
          Κ <-- -ΔΥΝΧΑ[Γ, Θ]
          Λ <-- 1 / ΣΥΝΤΕΛΑ[Γ, Θ]
        ΤΕΛΟΣ_ΑΝ
        ΑΝ Κ < 0 ΤΟΤΕ
          Α <-- 6
        ΤΕΛΟΣ_ΑΝ
        ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Β, ΤΕΛ, Κ, Λ)
        ΑΧ <-- ΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Γ=126 Ή ΔΥΝΧΑ[Γ+1, Θ]=-1
    ΑΝ ΑΧ = 0 ΤΟΤΕ
      Κ <-- 0
      Λ <-- 0
      ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Β, ΤΕΛ, Κ, Λ)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΠΟΛ_ΠΑΡ(Ι, Ξ, ΣΥΝΤΕΛ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, Α, ΣΥΜΒ, ΤΕΛ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Ξ, ΨΙ, ΨΨ, ΨΞ, Α, ΤΕΛ, ΜΕΤΡΗΤΗΣ2
  ΛΟΓΙΚΕΣ: ΒΨ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛ[126], ΔΥΝΧ[126], ΣΥΝΤΕΛΨ[126], ΔΥΝΧΨ[126]
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΓΙΑ ΨΙ ΑΠΟ 1 ΜΕΧΡΙ 126
    ΔΥΝΧΨ[ΨΙ] <-- -1
    ΣΥΝΤΕΛΨ[ΨΞ] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ΨΙ ΑΠΟ Ι+1 ΜΕΧΡΙ Ξ-1
    ΓΙΑ ΨΨ ΑΠΟ ΜΕΤΡΗΤΗΣ2+1 ΜΕΧΡΙ Ι-3
      ΑΝ Α = 0 ΤΟΤΕ
        ΨΞ <-- 0
        ΒΨ <-- ΨΕΥΔΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΨΞ <-- ΨΞ+1
          ΑΝ ΔΥΝΧΨ[ΨΞ] = ΔΥΝΧ[ΨΙ]+ΔΥΝΧ[ΨΨ] ΤΟΤΕ
            ΣΥΝΤΕΛΨ[ΨΞ] <-- ΣΥΝΤΕΛΨ[ΨΞ] + ( ΣΥΝΤΕΛ[ΨΙ]*ΣΥΝΤΕΛ[ΨΨ] )
            ΒΨ <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ_ΑΝ ΔΥΝΧΨ[ΨΞ]=-1 ΤΟΤΕ
            ΣΥΝΤΕΛΨ[ΨΞ] <-- ΣΥΝΤΕΛ[ΨΙ]*ΣΥΝΤΕΛ[ΨΨ]
            ΔΥΝΧΨ[ΨΞ] <-- ΔΥΝΧ[ΨΙ]+ΔΥΝΧ[ΨΨ]
            ΒΨ <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
        ΜΕΧΡΙΣ_ΟΤΟΥ ΨΞ=126 Ή ΒΨ = ΑΛΗΘΗΣ
        ΑΝ ΨΞ=126 ΚΑΙ ΒΨ = ΨΕΥΔΗΣ ΤΟΤΕ
          Α <-- 18
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Α = 0 ΤΟΤΕ
    ΨΙ <-- 0
    ΒΨ <-- ΨΕΥΔΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΨΙ <-- ΨΙ+1
      ΑΝ ΨΙ <> 126 ΤΟΤΕ
        ΑΝ ΔΥΝΧΨ[ΨΙ+1]=-1 ΤΟΤΕ
          ΒΨ <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΒΨ = ΑΛΗΘΗΣ Ή ΨΙ=126
    ΓΙΑ ΨΞ ΑΠΟ 1 ΜΕΧΡΙ Ξ-1-ΜΕΤΡΗΤΗΣ2
      ΨΨ <-- ΜΕΤΡΗΤΗΣ2 + 1
      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΨΨ, ΤΕΛ)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΨΞ <-- 0
    ΓΙΑ ΨΨ ΑΠΟ 1 ΜΕΧΡΙ ΨΙ
      ΑΝ ΣΥΝΤΕΛΨ[ΨΨ] <> 0 ΤΟΤΕ
        ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, ΤΕΛ, ΔΥΝΧΨ[ΨΨ], ΣΥΝΤΕΛΨ[ΨΨ])
        ΨΞ <-- ΨΞ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΨΞ = 0 ΤΟΤΕ
      ΔΥΝΧΨ[1] <-- 0
      ΣΥΝΤΕΛΨ[1] <-- 0
      ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΜΕΤΡΗΤΗΣ2, ΤΕΛ, ΔΥΝΧΨ[1], ΣΥΝΤΕΛΨ[1])
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΠΡ_ΜΟΝ(Ι, Ξ, ΣΥΜΒ, ΣΥΝΤΕΛ, ΔΥΝΧ, ΤΕΛ)
ΜΕΤΑΒΛΗΤΕΣ
  ΛΟΓΙΚΗ: ΒΧ
  ΑΚΕΡΑΙΕΣ: ΑΧ, Ι, Ξ, Α2Χ, ΤΕΛ, ΓΧ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛΧ[126], ΔΥΝΧΧ[126], ΣΥΝΤΕΛ[126], ΔΥΝΧ[126]
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΓΙΑ ΑΧ ΑΠΟ 1 ΜΕΧΡΙ 126
    ΔΥΝΧΧ[ΑΧ] <-- -1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ΑΧ ΑΠΟ Ι ΜΕΧΡΙ Ξ-1
    ΑΝ ΣΥΜΒ[ΑΧ] = ' ' ΤΟΤΕ
      ΒΧ <-- ΨΕΥΔΗΣ
      ΓΙΑ Α2Χ ΑΠΟ 1 ΜΕΧΡΙ 126
        ΑΝ ΔΥΝΧ[ΑΧ]=ΔΥΝΧΧ[Α2Χ] ΤΟΤΕ
          ΣΥΝΤΕΛΧ[Α2Χ] <-- ΣΥΝΤΕΛΧ[Α2Χ]+ΣΥΝΤΕΛ[ΑΧ]
          Α2Χ <-- 126
          ΒΧ <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ ΒΧ = ΨΕΥΔΗΣ ΤΟΤΕ
        Α2Χ <-- 0
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          Α2Χ <-- Α2Χ + 1
        ΜΕΧΡΙΣ_ΟΤΟΥ ΔΥΝΧΧ[Α2Χ]=-1
        ΔΥΝΧΧ[Α2Χ] <-- ΔΥΝΧ[ΑΧ]
        ΣΥΝΤΕΛΧ[Α2Χ] <-- ΣΥΝΤΕΛ[ΑΧ]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΧ <-- 0
  ΒΧ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΧ <-- ΑΧ+1
    ΑΝ ΑΧ <> 126 ΤΟΤΕ
      ΑΝ ΔΥΝΧΧ[ΑΧ+1]=-1 ΤΟΤΕ
        ΒΧ <-- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΒΧ = ΑΛΗΘΗΣ Ή ΑΧ=126
  ΓΙΑ Α2Χ ΑΠΟ 1 ΜΕΧΡΙ Ξ-1-Ι
    ΓΧ <-- Ι + 1
    ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, ΓΧ, ΤΕΛ)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΧ <-- 0
  ΓΙΑ Α2Χ ΑΠΟ 1 ΜΕΧΡΙ ΑΧ
    ΑΝ ΣΥΝΤΕΛΧ[Α2Χ] <> 0 ΤΟΤΕ
      ΓΧ <-- ΓΧ+1
      ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ, ΔΥΝΧΧ[Α2Χ], ΣΥΝΤΕΛΧ[Α2Χ])
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΓΧ = 0 ΤΟΤΕ
    ΔΥΝΧΧ[1] <-- 0
    ΣΥΝΤΕΛΧ[1] <-- 0
    ΚΑΛΕΣΕ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ, ΔΥΝΧΧ[1], ΣΥΝΤΕΛΧ[1])
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΚΑΤΑΧΩΡΗΣΗ_ΜΕΤΑΒΛΗΤΕΣ(ΕΞΙΣ, ΣΥΜΒ, ΣΥΝΤΕΛ, ΔΥΝΧ, Α)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΞΙΣ, ΣΥΜΒ[126]
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛ[126], ΔΥΝΧ[126]
  ΑΚΕΡΑΙΕΣ: Α, Ι

ΑΡΧΗ
  Α <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)            !ΚΑΤΑΧΩΡΗΣΗ ΣΤΙΣ ΜΕΤΑΒΛΗΤΕΣ
    ΑΝ ΕΞΙΣ[Ι]='1' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 1
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='2' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 2
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='3' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 3
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='4' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 4
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='5' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 5
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='6' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 6
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='7' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 7
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='8' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 8
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='9' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 9
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='0' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- -1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='Χ' Ή ΕΞΙΣ[Ι]='X' Ή ΕΞΙΣ[Ι]='χ' Ή ΕΞΙΣ[Ι]='x' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 1
      ΔΥΝΧ[Ι] <-- 1
      ΣΥΜΒ[Ι] <-- ' '
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='+' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '+'
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='-' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '-'
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='*' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '*'
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='/' Ή ΕΞΙΣ[Ι]=':' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '/'
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='^' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '^'
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='=' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '='
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]='(' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '('
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι]=')' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- ')'
    ΑΛΛΙΩΣ_ΑΝ ΕΞΙΣ[Ι] = '.' Ή ΕΞΙΣ[Ι] = ',' ΤΟΤΕ
      ΣΥΝΤΕΛ[Ι] <-- 0
      ΔΥΝΧ[Ι] <-- 0
      ΣΥΜΒ[Ι] <-- '.'
    ΑΛΛΙΩΣ
      Α <-- 1
      ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ                                      
!--------------------------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛ[126], ΔΥΝΧ[126]
  ΑΚΕΡΑΙΕΣ: Ι, ΤΕΛ, Ξ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΓΙΑ Ξ ΑΠΟ Ι+1 ΜΕΧΡΙ ΤΕΛ-1
    ΣΥΝΤΕΛ[Ξ] <-- ΣΥΝΤΕΛ[Ξ+1]
    ΣΥΜΒ[Ξ] <-- ΣΥΜΒ[Ξ+1]
    ΔΥΝΧ[Ξ] <-- ΔΥΝΧ[Ξ+1]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛ <-- ΤΕΛ-1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!--------------------------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΑΝΑΝΕΩΣΗ2(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛ[126], ΔΥΝΧ[126]
  ΑΚΕΡΑΙΕΣ: Ι, ΤΕΛ, Ξ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΓΙΑ Ξ ΑΠΟ Ι ΜΕΧΡΙ ΤΕΛ-1
    ΣΥΝΤΕΛ[Ξ] <-- ΣΥΝΤΕΛ[Ξ+1]
    ΣΥΜΒ[Ξ] <-- ΣΥΜΒ[Ξ+1]
    ΔΥΝΧ[Ξ] <-- ΔΥΝΧ[Ξ+1]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛ <-- ΤΕΛ-1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!--------------------------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΑΝΤΙΑΝΑΝΕΩΣΗ(ΣΥΝΤΕΛ, ΣΥΜΒ, ΔΥΝΧ, Ι, ΤΕΛ, ΑΨ, ΒΨ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, ΤΕΛ, Ξ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝΤΕΛ[126], ΔΥΝΧ[126], ΑΨ, ΒΨ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
ΑΡΧΗ
  ΓΙΑ Ξ ΑΠΟ ΤΕΛ ΜΕΧΡΙ Ι+1 ΜΕ ΒΗΜΑ -1
    ΣΥΝΤΕΛ[Ξ+1] <-- ΣΥΝΤΕΛ[Ξ]
    ΣΥΜΒ[Ξ+1] <-- ΣΥΜΒ[Ξ]
    ΔΥΝΧ[Ξ+1] <-- ΔΥΝΧ[Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΣΥΝΤΕΛ[Ι+1] <-- ΒΨ
  ΣΥΜΒ[Ι+1] <-- ' '
  ΔΥΝΧ[Ι+1] <-- ΑΨ
  ΤΕΛ <-- ΤΕΛ+1
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-----------------------------------------------------------------------------------------------!
ΔΙΑΔΙΚΑΣΙΑ ΚΑΝΟΝΕΣ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΚΑΝΟΝΕΣ:'
  ΓΡΑΨΕ 'Ο ΑΓΝΩΣΤΟΣ ΠΡΕΠΕΙ ΝΑ ΓΡΑΦΕΤΕ ΩΣ Χ, ΠΑΡΑΜΕΤΡΟΙ ΔΕΝ ΕΠΙΤΡΕΠΟΝΤΑΙ'                  !ΚΑΝΟΝΑΣ 1!
  ΓΡΑΨΕ 'ΔΕΝ ΕΠΙΤΡΕΠΟΝΤΑΙ ΤΑ ΚΕΝΑ (SPACE)'                                                !ΚΑΝΟΝΑΣ 2!
  ΓΡΑΨΕ 'ΟΛΕΣ ΟΙ ΠΑΡΕΝΘΕΣΕΙΣ ΓΡΑΦΟΝΤΑΙ ΩΣ ( ΚΑΙ )'                                        !ΚΑΝΟΝΑΣ 3!
  ΓΡΑΨΕ 'Η ΕΞΙΣΩΣΗ ΔΕΝ ΠΡΕΠΕΙ ΝΑ ΠΕΡΙΕΧΕΙ ΤΟ Χ ΣΕ ΠΑΡΑΝΟΜΑΣΤΗ ΚΛΑΣΜΑΤΟΣ'                  !ΚΑΝΟΝΑΣ 4!
  ΓΡΑΨΕ 'ΤΑ ΣΥΜΒΟΛΑ ΤΟΥ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΥ ΔΕΝ ΣΥΝΙΣΤΑΤΑΙ ΝΑ ΠΑΡΑΛΕΙΠΟΝΤΑΙ'                  !ΚΑΝΟΝΕΣ 5!
  ΓΡΑΨΕ '      ΣΕ ΜΕΓΑΛΕΣ ΕΞΙΣΩΣΕΙΣ'                                                      !ΚΑΝΟΝΑΣ 5β!
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------------ΣΥΝΑΡΤΗΣΕΙΣ------------------------------------------------------------!
ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ_ΚΑΝ(ΕΞΙΣ) :ΛΟΓΙΚΗ          !ΜΕΡΙΚΩΣ ΕΛΕΓΧΟΣ ΚΑΤΑ ΤΗΝ ΕΙΣΑΓΩΓΗ ΤΗΣ ΕΞΙΣΩΣΗΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΞΙΣ
  ΑΚΕΡΑΙΕΣ: Ι, Α, ΜΕΤΡΗΤΗ
ΑΡΧΗ
  ΕΛΕΓΧΟΣ_ΚΑΝ <-- ΑΛΗΘΗΣ
  Α <-- 0
 !ΚΑΝΟΝΑΣ 1, 2, 3, 4!
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)
    ΑΝ ΕΞΙΣ[Ι] <> '1' ΚΑΙ ΕΞΙΣ[Ι] <> '2' ΚΑΙ ΕΞΙΣ[Ι] <> '3' ΚΑΙ ΕΞΙΣ[Ι] <> '4' ΚΑΙ ΕΞΙΣ[Ι] <> '5' ΚΑΙ ΕΞΙΣ[Ι] <> '6' ΤΟΤΕ
      ΑΝ ΕΞΙΣ[Ι] <> '7' ΚΑΙ ΕΞΙΣ[Ι] <> '8' ΚΑΙ ΕΞΙΣ[Ι] <> '9' ΚΑΙ ΕΞΙΣ[Ι] <> '0' ΚΑΙ ΕΞΙΣ[Ι] <> 'Χ' ΚΑΙ ΕΞΙΣ[Ι] <> '+' ΤΟΤΕ
        ΑΝ ΕΞΙΣ[Ι] <> '-' ΚΑΙ ΕΞΙΣ[Ι] <> '*' ΚΑΙ ΕΞΙΣ[Ι] <> '/' ΚΑΙ ΕΞΙΣ[Ι] <> '^' ΚΑΙ ΕΞΙΣ[Ι] <> '(' ΚΑΙ ΕΞΙΣ[Ι] <> ')' ΤΟΤΕ
          ΑΝ ΕΞΙΣ[Ι] <> '=' ΚΑΙ ΕΞΙΣ[Ι] <> '.' ΚΑΙ ΕΞΙΣ[Ι] <> 'X' ΚΑΙ ΕΞΙΣ[Ι] <> 'χ' ΚΑΙ ΕΞΙΣ[Ι] <> 'x' ΚΑΙ ΕΞΙΣ[Ι] <> ':' ΤΟΤΕ
            ΑΝ ΕΞΙΣ[Ι] <> ',' ΤΟΤΕ
              ΕΛΕΓΧΟΣ_ΚΑΝ <-- ΨΕΥΔΗΣ
              Α <-- 1
              ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  !ΜΕΛΗ!
  ΜΕΤΡΗΤΗ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΞΙΣ)
    ΑΝ ΕΞΙΣ[Ι] = '=' ΤΟΤΕ
      ΜΕΤΡΗΤΗ <-- ΜΕΤΡΗΤΗ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΜΕΤΡΗΤΗ<>1 ΤΟΤΕ
    ΕΛΕΓΧΟΣ_ΚΑΝ <-- ΨΕΥΔΗΣ
    Α <-- 2
    ΓΡΑΨΕ ΣΦΑΛΜΑ_ΚΑΝ(Α)
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Α <> 0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΤΕ ΤΗΝ ΕΞΙΣΩΣΗ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-------------------------------------------------------------------------------------------!
ΣΥΝΑΡΤΗΣΗ Δ_ΠΡ(Ι, ΔΥΝΧ, ΣΥΝΤΕΛ, Ξ):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Ξ, Γ, Δ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΔΥΝΧ[126], ΣΥΝΤΕΛ[126], Β
ΑΡΧΗ
  Δ_ΠΡ <-- ΨΕΥΔΗΣ
  Β <-- -1
  ΓΙΑ Γ ΑΠΟ Ι ΜΕΧΡΙ Ξ
    ΑΝ ΣΥΝΤΕΛ[Γ] <> 0 ΤΟΤΕ
      Β <-- ΔΥΝΧ[Γ]
      ΓΙΑ Δ ΑΠΟ Ι ΜΕΧΡΙ Ξ
        ΑΝ ΔΥΝΧ[Δ]=ΔΥΝΧ[Γ] ΚΑΙ Γ <> Δ ΤΟΤΕ
          Δ_ΠΡ <-- ΑΛΗΘΕΣ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-------------------------------------------------------------------------------------------!
ΣΥΝΑΡΤΗΣΗ Κ_Π(Ι, ΣΥΜΒ) :ΑΚΕΡΑΙΕΣ   !ΕΠΙΣΤΡΕΦΕΙ ΤΗΝ ΘΕΣΗ ΣΤΗΝ ΟΠΟΙΑ ΚΛΕΙΝΕΙ Η ΠΑΡΕΝΘΕΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
  ΑΚΕΡΑΙΕΣ: Ι, Α, Β
ΑΡΧΗ
  Κ_Π <-- 0
  Α <-- 0
  Β <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι + 1
    ΑΝ ΣΥΜΒ[Ι] = '(' ΤΟΤΕ
      Β <-- Β + 1
    ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι] = ')' ΤΟΤΕ
      ΑΝ Β = 0 ΤΟΤΕ
        Α <-- Ι
      ΑΛΛΙΩΣ
        Β <-- Β - 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Α <> 0
  Κ_Π <-- Α
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-------------------------------------------------------------------------------------------!
ΣΥΝΑΡΤΗΣΗ Ε_Π(ΣΥΜΒ, Ι) :ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
  ΑΚΕΡΑΙΕΣ: Ι
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι + 1
    ΑΝ ΣΥΜΒ[Ι] = '(' ΤΟΤΕ
      Ε_Π <-- ΨΕΥΔΗΣ
    ΑΛΛΙΩΣ_ΑΝ ΣΥΜΒ[Ι] = ')' ΤΟΤΕ
      Ε_Π <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΥΜΒ[Ι] = ')' Ή ΣΥΜΒ[Ι] = '('
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-----------------------------------------------------------------------------------------------!
ΣΥΝΑΡΤΗΣΗ Υ_Π(ΣΥΜΒ, Ι, ΤΕΛ) :ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΣΥΜΒ[126]
  ΑΚΕΡΑΙΕΣ: Ι, Ξ, ΤΕΛ
  ΛΟΓΙΚΗ: Β, Γ
ΑΡΧΗ
  Β <-- ΑΛΗΘΗΣ
  ΑΝ Ι <> 2 ΤΟΤΕ
    ΑΝ ΣΥΜΒ[Ι-2] = '^' ΤΟΤΕ
      Β <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Ι <> ΤΕΛ - 1 ΤΟΤΕ
    ΑΝ ΣΥΜΒ[Ι+2] = '^' ΤΟΤΕ
      Β <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  Υ_Π <-- Β
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-----------------------------------------------------------------------------------------------!
ΣΥΝΑΡΤΗΣΗ ΣΦΑΛΜΑ_ΚΑΝ(Α) :ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α
ΑΡΧΗ
  ΑΝ Α = 1 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΔΕΝ ΕΧΕΤΕ ΑΚΟΛΟΥΘΗΣΕΙ ΚΑΠΟΙΟΥΣ ΑΠΟ ΤΟΥΣ ΚΑΝΟΝΕΣ 1 Ή 2 Ή 3'
  ΑΛΛΙΩΣ_ΑΝ Α=2 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΜΙΑ ΕΞΙΣΩΣΗ ΕΧΕΙ 2 ΜΕΛΗ, ΔΗΛΑΔΗ ΜΟΝΟ 1 ='
  ΑΛΛΙΩΣ_ΑΝ Α=3 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΔΙΠΛΑ ΣΕ ΥΠΟΔΙΑΣΤΟΛΗ ΒΡΕΘΗΚΕ ΑΛΛΟ ΣΥΜΒΟΛΟ Ή Ο ΑΓΝΩΣΤΟΣ'
  ΑΛΛΙΩΣ_ΑΝ Α=4 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΕΝΑΣ ΑΡΙΘΜΟΣ ΔΕΝ ΜΠΟΡΕΙ ΝΑ ΕΧΕΙ ΠΕΡΙΣΣΟΤΕΡΕΣ ΑΠΟ 1 ΥΠΟΔΙΑΣΤΟΛΕΣ'
  ΑΛΛΙΩΣ_ΑΝ Α=5 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕ ΣΥΜΒΟΛΟ Π.Χ. 9*-'
  ΑΛΛΙΩΣ_ΑΝ Α=6 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ Ο ΑΓΝΩΣΤΟΣ Χ ΥΨΩΜΕΝΗ ΣΕ ΑΡΝΗΤΙΚΟ ΕΚΘΕΤΗ (Ή ΣΕ ΠΑΡΑΝΟΜΑΣΤΗ ΚΛΑΣΜΑΤΟΣ) (ΚΑΝΟΝΑΣ 4 ΠΑΡΑΒΙΑΣΤΗΚΕ)'
  ΑΛΛΙΩΣ_ΑΝ Α=7 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΔΙΑΙΡΕΣΗ ΜΕ ΣΥΜΒΟΛΟ Π.Χ. 9/+'
  ΑΛΛΙΩΣ_ΑΝ Α=8 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'Ο ΑΡΙΘΜΟΙ ΑΝΟΙΓΜΑΤΟΣ ΚΑΙ ΚΛΕΙΣΙΜΑΤΟΣ ΠΑΡΕΝΘΕΣΕΩΝ ΔΕΝ ΕΙΝΑΙ ΙΣΟΙ'
  ΑΛΛΙΩΣ_ΑΝ Α=9 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΥΨΩΣΗ ΣΥΜΒΟΛΟΥ ΣΕ ΚΑΠΟΙΑ ΔΥΝΑΜΗ Π.Χ. -^9 Ή ΥΨΩΣΗ ΑΡΙΘΜΟΥ/ΑΓΝΩΣΤΟΥ ΣΕ ΣΥΜΒΟΛΟ Π.Χ. 9^-'
  ΑΛΛΙΩΣ_ΑΝ Α=10 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΕΧΕΤΕ ΠΑΡΑΛΕΙΨΕΙ ΣΥΜΒΟΛΟ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΥ'
  ΑΛΛΙΩΣ_ΑΝ Α=11 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΠΟΥ ΔΕΝ ΕΧΕΙ ΓΙΝΕΙ ΕΝΩ ΘΑ ΕΠΡΕΠΕ ΝΑ ΕΙΧΕ'
  ΑΛΛΙΩΣ_ΑΝ Α=12 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΑΝ 2 ΣΥΜΒΟΛΑ ΣΤΗΝ ΣΕΙΡΑ (ΑΠΟ ΤΑ ΟΠΟΙΑ ΚΑΝΕΝΑ ΔΕΝ ΕΙΝΑΙ ΠΑΡΕΝΘΕΣΗ)'
  ΑΛΛΙΩΣ_ΑΝ Α=13 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΑΝ ΠΕΡΙΣΣΟΤΕΡΑ ΑΠΟ ΕΝΑ ΣΥΜΒΟΛΑ Ή ΣΥΜΒΟΛΟ ΠΡΙΝ ΑΠΟ ΚΛΕΙΣΙΜΟ ΠΑΡΕΝΘΕΣΗΣ Ή ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΠΟΥ ΔΕΝ ΕΧΕΙ ΓΙΝΕΙ ΕΝΩ ΘΑ ΕΠΡΕΠΕ'
  ΑΛΛΙΩΣ_ΑΝ Α=14 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΣΤΗΝ ΑΡΧΗ ΤΩΝ ΜΕΛΩΝ ΔΕΝ ΜΠΟΡΕΙ ΝΑ ΥΠΑΡΧΟΥΝ ΣΥΜΒΟΛΑ ΔΙΑΦΟΡΕΤΙΚΑ ΤΩΝ: - + ( ΚΑΙ ΣΤΟ ΤΕΛΟΣ ΤΩΝ ΜΕΛΩΝ: )'
  ΑΛΛΙΩΣ_ΑΝ Α=15 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΥΨΩΣΗ ΤΟΥ ΑΓΝΩΣΤΟΥ ΣΕ ΕΚΘΕΤΗ ΔΙΑΦΟΡΕΤΙΚΟ ΤΩΝ 0, 1, 2'
  ΑΛΛΙΩΣ_ΑΝ Α=16 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΥΨΩΣΗ ΣΤΟΝ ΑΓΝΩΣΤΟ'
  ΑΛΛΙΩΣ_ΑΝ Α=17 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΔΕΝ ΕΧΕΤΕ ΑΚΟΛΟΥΘΗΣΕΙ ΤΟΝ 5 ΚΑΝΟΝΑ'
  ΑΛΛΙΩΣ_ΑΝ Α=18 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΔΕΝ ΥΠΑΡΧΕΙ ΑΡΚΕΤΟΣ ΧΩΡΟΣ ΣΤΟΥΣ ΠΙΝΑΚΕΣ'
  ΑΛΛΙΩΣ_ΑΝ Α=19 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΚΛΕΙΣΙΜΟ ΠΑΡΕΝΘΕΣΗΣ ΠΡΙΝ ΑΠΟ ΑΝΟΙΓΜΑ'
  ΑΛΛΙΩΣ_ΑΝ Α=20 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΔΙΑΙΡΕΣΗ ΜΕ ΔΥΝΑΜΗ ΤΟΥ Χ ΣΤΟΝ ΔΙΑΙΡΕΤΗ Ή ΥΨΩΣΗ ΣΕ ΔΥΝΑΜΗ ΤΟΥ Χ'
  ΑΛΛΙΩΣ_ΑΝ Α=21 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΥΨΩΣΗ ΠΑΡΕΝΘΕΣΗΣ ΣΕ ΔΕΚΑΔΙΚΟ ΑΡΙΘΜΟ, ΚΑΤΙ ΠΟΥ ΔΕΝ ΥΠΟΣΤΗΡΙΖΕΤΕ'
  ΑΛΛΙΩΣ_ΑΝ Α=22 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ 0'
  ΑΛΛΙΩΣ_ΑΝ Α=23 ΤΟΤΕ
    ΣΦΑΛΜΑ_ΚΑΝ <-- 'ΒΡΕΘΗΚΕ ΜΕΓΕΘΟΣ ΕΞΙΣΩΣΗΣ ΜΕΓΑΛΥΤΕΡΟ ΑΠΟ ΤΟ ΑΝΑΜΕΝΟΜΕΝΟ ΣΕ ΑΥΤΟ ΤΟ ΒΗΜΑ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Δευτεροβάθμια εξίσωση
ΔημοσίευσηΔημοσιεύτηκε: Τρί 10 Αύγ 2010 06:35 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 08 Αύγ 2010 04:11 pm
Δημοσιεύσεις: 8
1)φιλος το εβαλα στη γλωσσομαθεια και μου εμφανιζει λαθος στη γραμμη 1026.......(θα το διορθωνα αλλα δεν εχω και πολλες γνωσεις ακομα πανω στο αντικειμενο
2)ολο αυτο το πραγμα υπολογιζει εξισωσεις μεχρι δευτερου βαθμου;;;;;;;;(πολυ δεν ειναι;;;;;;;;;;) :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Δευτεροβάθμια εξίσωση
ΔημοσίευσηΔημοσιεύτηκε: Τετ 11 Αύγ 2010 05:03 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Το πρόγραμμα πρέπει να το βάλεις στην γλωσσομάθεια με το εμπλουτισμένο συντακτικό (μεταγλωττιστή) για να τρέξει, μήπως δεν το τρέχεις με την εμπλουτισμένου ? στην v8.5 τρέχει κανονικά σε μένα.

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Δευτεροβάθμια εξίσωση
ΔημοσίευσηΔημοσιεύτηκε: Παρ 28 Ιουν 2013 03:15 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 28 Ιουν 2013 03:08 pm
Δημοσιεύσεις: 1
Γιατι ολο αυτο αφου υπαρχει και αυτο για την δευτεροβαθμια εξισωση

Εικόνα


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Δευτεροβάθμια εξίσωση
ΔημοσίευσηΔημοσιεύτηκε: Παρ 28 Ιουν 2013 07:46 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Η απλή απάντηση στο "γιατί όλο αυτό" είναι επειδή δεν λύνουν το ίδιο πρόβλημα. Για το πρόγραμμα που δείχνεις χρειάζεται να γίνει η αρχική επεξεργασία της δευτεροβάθμιας (πιθανότατα από τον χρήστη) ώστε να έρθει στην μορφή αχ^2+βχ+γ=0. Αντιθέτως, για το πρόγραμμα που είχα παραθέσει, η εξίσωση μπορούσε να δοθεί σε οποιαδήποτε μορφή. Για παράδειγμα, θα μπορούσες να δώσεις ως είσοδο το
Κώδικας:
Χ^2+78*5934+Χ*Χ+2859872-498402+0*Χ-Χ^3+Χ^3-983+4^2*3/6-Χ^423=9589*Χ^2-Χ^423+895*Χ/784-9834.5
και να σου επιστρέψει τις ρίζες (προσοχή ότι η εξίσωση παρόλο που έχει X^423 ανάγεται σε δευτεροβάθμια)

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Δευτεροβάθμια εξίσωση
ΔημοσίευσηΔημοσιεύτηκε: Τρί 17 Σεπ 2019 01:33 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 17 Σεπ 2019 01:07 am
Δημοσιεύσεις: 3
Εν έτει 2019, με Windows 10 και Γλωσσομάθεια 8.5, όταν πάω να το εκτελέσω ο μεταγλωττιστής το "επεξεργάζεται" επ' άπειρον, κάποια στιγμή βαριέμαι και κλείνω τη Γλωσσομάθεια με τη βία. Λογικό είναι, αφού έχει πάνω από 1000 γραμμές. Μήπως έχει γίνει το πρόγραμμα τόσο παμπάλαιο (φαίνεται λίγο εδώ που τα λέμε);


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 6 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 4 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters