Τώρα είναι Παρ 10 Απρ 2020 08:59 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΤΑΙΡΙΑ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Μαρ 2009 01:47 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΑΣΚΗΣΗ 7.62 ΑΠΟ ΤΟ ΒΙΒΛΙΟ ΤΟΥ ΝΤΖΙΟΥ ΚΑΙ ΚΟΨΙΝΗ ΣΕΛ 259 .
ΕΚΦΩΝΗΣΗ :
ΜΙΑ ΜΕΓΑΛΗ ΕΙΣΑΓΩΓΙΚΗ ΕΤΑΙΡΙΑ ΜΕ ΕΔΡΑ ΤΗΝ ΑΘΗΝΑ ΕΧΕΙ ΥΠΟΚΑΤΑΣΤΗΜΑΤΑ ΣΤΗΝ ΠΑΤΡΑ , ΣΤΟΝ ΠΥΡΓΟ , ΣΤΗΝ ΚΑΡΔΙΤΣΑ ΚΑΙ ΣΤΙΣ ΣΕΡΡΕΣ. ΟΛΑ ΤΑ ΥΠΟΚΑΤΑΣΤΗΜΑΤΑ ΕΧΟΥΝ ΑΠΟ 20 ΠΩΛΗΤΕΣ ΤΟ ΚΑΘΕΝΑ. ΓΙΑ ΝΑ ΜΠΟΡΕΙ ΝΑ ΕΛΕΓΧΕΙ ΑΠΟΤΕΛΕΣΜΑΤΙΚΑ ΟΛΑ ΤΑ ΚΑΤΑΣΤΗΜΑΤΑ ΚΑΙ ΤΟΥΣ ΠΩΛΗΤΕΣ ΤΗΣ ΣΕ ΕΒΔΟΜΑΔΙΑΙΑ ΒΑΣΗ , ΧΡΕΙΑΖΕΤΑΙ ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΣΤΟ ΟΠΟΙΟ ΣΤΟ ΤΕΛΟΣ ΚΑΘΕ ΕΒΔΟΜΑΔΑΣ ΘΑ ΚΑΤΑΧΩΡΕΙ ΣΕ ΕΝΑΝ ΠΙΝΑΚΑ 5 ΓΡΑΜΜΩΝ ΚΑΙ 20 ΣΤΗΛΩΝ ΤΙΣ ΣΥΝΟΛΙΚΕΣ ΠΩΛΗΣΕΙΣ ΚΑΘΕ ΠΩΛΗΤΗ ΣΕ ΚΑΘΕ ΚΑΤΑΣΤΗΜΑ ΓΙΑ ΤΗΝ ΕΒΔΟΜΑΔΑ ΠΟΥ ΠΕΡΑΣΕ.

i)ΝΑ ΔΟΘΕΙ ΑΛΓΟΡΙΘΜΟΣ Ο ΟΠΟΙΟΣ ΝΑ ΥΠΟΛΟΓΙΖΕΙ ΤΙΣ ΣΥΓΚΕΝΤΡΩΤΙΚΕΣ ΠΩΛΗΣΕΙΣ ΤΗΣ ΕΤΑΙΡΙΑΣ ΓΙΑ ΤΗΝ ΕΒΔΟΜΑΔΑ ΠΟΥ ΠΕΡΑΣΕ ΚΑΘΩΣ ΚΑΙ ΤΟ ΚΑΛΥΤΕΡΟ ΚΑΤΑΣΤΗΜΑ ΤΗΣ ΕΒΔΟΜΑΔΑΣ.

ii)Η ΕΤΑΙΡΙΑ ΘΕΛΟΝΤΑΣ ΝΑ ΤΟΝΩΣΕΙ ΤΟ ΕΝΔΙΑΦΕΡΟΝ ΤΩΝ ΠΩΛΗΤΩΝ ΤΗΣ ΚΑΙ ΝΑ ΑΥΞΗΣΕΙ ΤΟΝ ΑΝΤΑΓΩΝΙΣΜΟ ΣΕ ΚΑΘΕ ΚΑΤΑΣΤΗΜΑ ΑΠΟΦΑΣΙΣΕ ΝΑ ΔΩΣΕΙ ΠΡΙΜ ΣΤΟΝ ΚΑΛΥΤΕΡΟ ΠΩΛΗΤΗ ΤΟΥ ΚΑΘΕ ΚΑΤΑΣΤΗΜΑΤΟΣ . ΟΙ ΔΙΑΦΟΡΕΤΙΚΕΣ ΠΡΟΤΑΣΕΙΣ ΠΟΥ ΕΓΙΝΑΝ ΑΠΟ ΤΟΥ ΣΥΜΒΟΥΛΟΥΣ ΤΗΣ ΕΤΑΙΡΙΑΣ ΕΙΝΑΙ ΔΥΟ.
Η ΠΡΩΤΗ ΠΡΟΤΑΣΗ ΕΙΝΑΙ Ο ΚΑΛΥΤΕΡΟΣ ΠΩΛΗΤΗΣ ΤΟΥ ΚΑΘΕ ΚΑΤΑΣΤΗΜΑΤΟΣ ΝΑ ΠΑΙΡΝΕΙ ΠΡΙΜ 1.5 ΕΥΡΩ ΓΙΑ ΚΑΘΕ ΠΩΛΗΣΗ ΠΟΥ ΕΚΑΝΕ, ΕΝΩ Η ΔΕΥΤΕΡΗ ΕΙΝΑΙ Ο ΚΑΛΥΤΕΡΟΣ ΠΩΛΗΤΗΣ ΤΟΥ ΚΑΘΕ ΚΑΤΑΣΤΗΜΑΤΟΣ , ΣΤΗΝ ΠΕΡΙΠΤΩΣΗ ΠΟΥ ΕΧΕΙ ΠΟΥΛΗΣΕΙ ΠΑΝΩ ΑΠΟ 20 ΚΟΜΜΑΤΙΑ ΝΑ ΠΑΙΡΝΕΙ ΠΡΙΜ 60 ΕΥΡΩ. ΦΥΣΙΚΑ , Ο ΠΡΟΕΔΡΟΣ ΤΗΣ ΕΤΑΙΡΙΑΣ ΘΕΛΕΙ ΝΑ ΠΛΗΡΩΣΕΙ ΤΑ ΛΙΓΟΤΕΡΑ . ΝΑ ΕΠΕΚΤΕΙΝΕΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ ΤΟΥ ΕΡΩΤΗΜΑΤΟΣ (i) ΜΕ ΤΕΤΟΙΟ ΤΡΟΠΟ ΩΣΤΕ ΝΑ ΥΠΟΛΟΓΙΖΕΙ ΚΑΙ ΝΑ ΤΥΠΩΝΕΙ ΤΗΝ ΠΙΟ ΣΥΜΦΕΡΟΥΣΑ ΠΡΟΤΑΣΗ (1 'Η 2) ΓΙΑ ΤΗΝ ΣΥΓΚΕΚΡΙΜΕΝΗ ΒΔΟΜΑΔΑ , ΚΑΘΩΣ ΚΑΙ ΤΟ ΠΡΙΜ ΠΟΥ ΘΑ ΠΑΡΕΙ Ο ΚΑΘΕ ΠΩΛΗΤΗΣ.

ΟΡΙΣΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ :
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΣ_762
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ΣΚ[5] , Σ , ΚΑΤ , ΠΩΛ[5,20] , ΚΑΛ_ΠΩΛ[5] , Ι , Κ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΜΑΧ , ΠΡ1[5] , ΠΡ2[5] , Σ1 , Σ2
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ',Ι,'ΟΥ ΚΑΤΑΣΤΗΜΑΤΟΣ'
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ',Κ,'ΟΥ ΠΩΛΗΤΗ'
      ΔΙΑΒΑΣΕ ΠΩΛ[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΣΚ[Ι] <-- 0
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
      ΣΚ[Ι] <-- ΣΚ[Ι] + ΠΩΛ[Ι,Κ]
      Σ <-- Σ + ΠΩΛ[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Ι = 1 ΤΟΤΕ
      ΜΑΧ <-- ΣΚ[1]
      ΚΑΤ <-- 1
    ΑΛΛΙΩΣ_ΑΝ ΜΑΧ < ΣΚ[Ι] ΤΟΤΕ
      ΜΑΧ <-- ΣΚ[Ι]
      ΚΑΤ <-- Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ'ΟΙ ΣΥΝΟΛΙΚΕΣ ΠΩΛΗΣΕΙΣ ΤΩΝ ΚΑΤΑΣΤΗΜΑΤΩΝ ΕΙΝΑΙ',Σ,'ΚΑΙ ΤΟ',ΚΑΤ,'Ο ΚΑΤΑΣΤΗΜΑ ΗΤΑΝ ΤΟ ΚΑΛΥΤΕΡΟ ΤΗΣ ΕΒΔΟΜΑΔΑΣ'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΚΑΛ_ΠΩΛ[Ι] <-- ΠΩΛ[Ι,1]
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
      ΑΝ ΚΑΛ_ΠΩΛ[Ι] < ΠΩΛ[Ι,Κ] ΤΟΤΕ
        ΚΑΛ_ΠΩΛ[Ι] <-- ΠΩΛ[Ι,Κ]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΠΡ1[Ι] <-- ΚΑΛ_ΠΩΛ[Ι]*1.5
    ΑΝ ΚΑΛ_ΠΩΛ[Ι] > 20 ΤΟΤΕ
      ΠΡ2[Ι] <-- 60
    ΑΛΛΙΩΣ
      ΠΡ2[Ι] <-- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ1 <-- 0
  Σ2 <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    Σ1 <-- Σ1 + ΠΡ1[Ι]
    Σ2 <-- Σ2 + ΠΡ2[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Σ1 > Σ2 ΤΟΤΕ
    ΓΡΑΨΕ'ΓΙΑ ΑΥΤΗΝ ΤΗΝ ΕΒΔΟΜΑΔΑ ΑΥΤΗ ΣΥΜΦΕΡΕΙ Ο 2ος ΤΡΟΠΟΣ' , Σ2,'ΕΥΡΩ'
  ΑΛΛΙΩΣ_ΑΝ Σ1 < Σ2 ΤΟΤΕ
    ΓΡΑΨΕ'ΓΙΑ ΑΥΤΗΝ ΤΗΝ ΕΒΔΟΜΑΔΑ ΑΥΤΗ ΣΥΜΦΕΡΕΙ Ο 1ος ΤΡΟΠΟΣ' , Σ1,'ΕΥΡΩ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ'ΤΟ ΙΔΙΟ ΘΑ ΠΛΗΡΩΣΕΙ ΚΑΙ ΜΕ ΤΟΥΣ 2 ΤΡΟΠΟΥΣ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΝΤΙΜΕΤΩΠΙΖΩ ΕΝΑ ΠΡΟΒΛΗΜΑ ΟΜΩΣ . ΤΟ ΠΡΟΓΡΑΜΜΑ ΛΕΙΤΟΥΡΓΕΙ ΟΡΘΟΤΑΤΑ ΣΤΗΝ ΓΛΩΣΣΟΜΑΘΕΙΑ 9.2 ΟΜΩΣ ΟΤΑΝ ΑΛΛΑΖΩ ΤΟ ΚΟΜΜΑΤΙ
Syntax: [ Download ] [ Hide ]
ΓΡΑΨΕ 'ΔΩΣΕ ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ',Κ,'ΟΥ ΠΩΛΗΤΗ'
         ΔΙΑΒΑΣΕ ΠΩΛ[Ι,Κ]

ΚΑΙ ΤΟ ΚΑΝΩ
Syntax: [ Download ] [ Hide ]
ΠΩΛ[Ι,Κ] <-- ΤΥΧΑΙΟΣ(50)

ΚΑΙ ΠΡΟΣΠΑΘΩ ΝΑ ΤΟ ΕΚΤΕΛΕΣΩ ΣΤΟΝ ΜΕΤΑΓΛΩΤΙΣΤΗ , ΔΗΛΑΔΗ ΤΗΝ ΕΚΔΟΣΗ 8.5 ΜΟΥ ΕΜΦΑΝΙΖΕΙ ΤΟ ΕΞΗΣ
Παράθεση:
Γραμμή 3 - Αναμενόταν αναγνωριστικό

ΠΑΡΑΚΑΛΩ ΑΝ ΚΑΠΟΙΟΣ ΒΡΕΙ ΠΟΥ ΕΧΩ ΚΑΝΕΙ ΤΟ ΛΑΘΟΣ ΝΑ ΤΟ ΔΗΜΟΣΙΕΥΣΕΙ . :? :?

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΤΑΙΡΙΑ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Μαρ 2009 01:33 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Άλλαξε το:
Syntax: [ Download ] [ Hide ]
ΑΚΕΡΑΙΕΣ:ΣΚ[5] , Σ , ΚΑΤ , ΠΩΛ[5,20] , ΚΑΛ_ΠΩΛ[5] , Ι , Κ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΜΑΧ , ΠΡ1[5] , ΠΡ2[5] , Σ1 , Σ2

σε:
Syntax: [ Download ] [ Hide ]
 ΑΚΕΡΑΙΕΣ:ΣΚ[5], Σ, ΚΑΤ, ΠΩΛ[5,20], ΚΑΛ_ΠΩΛ[5], Ι, Κ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΜΑΧ, ΠΡ1[5], ΠΡ2[5], Σ1, Σ2

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΤΑΙΡΙΑ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 22 Μαρ 2009 09:09 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΕΥΧΑΡΙΣΤΩ , ΑΛΛΑ ΔΕΝ ΚΑΤΑΛΑΒΑ ΤΙ ΕΚΑΝΑ ΛΑΘΟΣ ΤΕΛΙΚΑ. ΑΠΛΑ ΤΑ ΚΕΝΑ ΔΕΝ ΑΛΛΑΞΕΣ???

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΤΑΙΡΙΑ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 22 Μαρ 2009 09:12 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Το μόνο που άλλαξα ήταν τα κενά όπως σωστά κατάλαβες :) .

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΤΑΙΡΙΑ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 22 Μαρ 2009 09:15 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΤΕΛΟΣ ΠΑΝΤΩΝ , ΚΑΠΩΣ ΑΝΟΗΣΙΑ ΔΕΝ ΕΙΝΑΙ ΟΜΩΣ ?
ΠΟΙΟ ΕΙΝΑΙ ΤΟ ΛΑΘΟΣ ΔΗΛΑΔΗ ΣΤΑ ΚΕΝΑ ..... ???

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters