Τώρα είναι Παρ 05 Ιουν 2020 03:14 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 13 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: πρώτος αριθμός
ΔημοσίευσηΔημοσιεύτηκε: Τετ 08 Δεκ 2004 07:28 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 08 Δεκ 2004 07:17 pm
Δημοσιεύσεις: 1
Τοποθεσία: Ηλιούπολη, Αθήνα
Syntax: [ Download ] [ Hide ]
! Ζητάει έναν αριθμό και εμφανίζει αν είναι πρώτος ή όχι.
! Πρώτοι λέγονται οι αριθμοί που διαιρούνται μόνο από τη
! μονάδα και από τον εαυτό τους.

ΠΡΟΓΡΑΜΜΑ protos
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αλλο, χ, χ0, ι
ΑΡΧΗ
  Διαβασε χ
  Αν χ > 2 τότε
    χ0 <-- χ - 1
    ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ χ0
      ΑΝ χ MOD ι = 0 ΤΟΤΕ
        αλλο <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ αλλο <> 1 τότε
    ΓΡΑΨΕ 'ειναι πρωτος'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'δεν ειναι πρωτος'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ protos


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 20 Ιαν 2007 03:29 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Ο αλγόριθμος σου δέχεται και αρνητικούς αριθμούς και τους βγάζει όλους σαν πρώτους. Επίσης το 0 και 1 δεν είναι πρώτοι!

Μια καλύτερη λύση:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ πρωτος
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:αριθμος,ι
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Γραψε 'Δωσε εναν θετικο ακεραιο αριθμο'
    Διαβασε αριθμος
  ΜΕΧΡΙΣ_ΟΤΟΥ αριθμος>0

! 1 δεν ειναι πρωτος
! 2 ειναι ο μοναδικος αρτιος πρωτος αριθμος
  ΑΝ αριθμος=1 ΤΟΤΕ
    ι <-- αριθμος+1 !για τερματισμο τη επαναληψης
  ΑΛΛΙΩΣ_ΑΝ αριθμος=2 ΤΟΤΕ
    ι <-- αριθμος !για τερματισμο τη επαναληψης
  ΑΛΛΙΩΣ_ΑΝ αριθμος>2 ΤΟΤΕ
    ι <-- 2
  ΤΕΛΟΣ_ΑΝ

  ΟΣΟ ι<αριθμος ΕΠΑΝΑΛΑΒΕ
    Αν αριθμος MOD ι = 0 Τοτε
      ι <-- αριθμος+1 !για τερματισμο τη επαναληψης
    ΤΕΛΟΣ_ΑΝ
    ι <-- ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ ι=αριθμος ΤΟΤΕ !Αρα ειναι πρωτος αφου αριθμος MOD ι <> 0
    Γραψε 'Ο αριθμος', αριθμος,'ειναι πρωτος'
  ΑΛΛΙΩΣ  !Δηλαδη ι=αριθμος+1, αρα δεν ειναι πρωτος αφου αριθμος MOD ι = 0
    Γραψε 'Ο αριθμος', αριθμος,'δεν ειναι πρωτος'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πρωτος

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Για τη λύση του mailo
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 21 Ιαν 2007 12:50 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 14 Ιαν 2007 03:43 pm
Δημοσιεύσεις: 18
Τοποθεσία: Κομοτηνή
mailo τον παρακάτω κώδικα γιατί τον βάζεις;

Syntax: [ Download ] [ Hide ]
  ΑΝ αριθμος=1 ΤΟΤΕ
    ι <-- αριθμος+1 !για τερματισμο τη επαναληψης
  ΑΛΛΙΩΣ_ΑΝ αριθμος=2 ΤΟΤΕ
    ι <-- αριθμος !για τερματισμο τη επαναληψης
  ΑΛΛΙΩΣ_ΑΝ αριθμος>2 ΤΟΤΕ
    ι <-- 2
  ΤΕΛΟΣ_ΑΝ
 


Αυτό που κάνεις παραπάνω είναι: ι <- 2

Άρα, μπορείς να το γράψεις κατευθείαν.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 21 Ιαν 2007 01:05 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 14 Ιαν 2007 03:43 pm
Δημοσιεύσεις: 18
Τοποθεσία: Κομοτηνή
Ο κώδικας του Άκη πιστεύω πολύ πιο ευανάγνωστος.

Η μόνη αλλαγή που χρειάζεται για να δουλέψει και για αρνητικούς είναι η παρακάτω:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ protos
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αλλο, χ, χ0, ι
ΑΡΧΗ
  Διαβασε χ
  Αν χ > 2 τότε
    χ0 <-- χ - 1
    ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ χ0
      ΑΝ χ MOD ι = 0 ΤΟΤΕ
        αλλο <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ αλλο <> 1 τότε
      ΓΡΑΨΕ 'ειναι πρωτος'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'δεν ειναι πρωτος'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
     ΓΡΑΨΕ 'δεν είναι πρώτος'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ protos
 


Και μία πιο γρήγορη λύση:
Ο αριθμός που θα δοθεί από τον χρήστη θα είναι πρώτος αν δεν διαιρείται με κανένα αριθμό, πέρα του 1 και του εαυτού του. Για να δούμε, όμως, αν διαιρείται με κάποιον αριθμό, δε χρειάζεται να ψάξουμε όλους του αριθμούς, αλλά μόνο αυτούς που είναι μικρότεροι οι ίσοι της τετραγωνικής ρίζας του. Έτσι, γίνονται Ν - ΤΡ(Ν) λιγότερες επαναλήψεις. Για παράδειγμα, αν το νούμερο που θέλουμε να εξετάσουμε είναι το 10.000 τότε αντί για 9.998 επαναλήψεις που θα κάναμε, κάνουμε μόλις 100 επαναλήψεις!

Το πρόβλημά μου εδώ είναι ότι η τετραγωνική ρίζα της γλωσσομάθειας επιστρέφει δεκαδικό αριθμό (και φυσικά έτσι πρέπει). Δεν ξέρω αν υπάρχει κάποιος τρόπος να μεταρτέψεις έναν πραγματικό αριθμό σε ακέραιο στη γλωσσομάθεια (π.χ κάποιο cast, ή κάποιο τέχνασμα).


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 25 Ιαν 2007 09:37 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Ομως το 2 ειναι πρωτος αριθμος :!:
Επισης στο αλγοριθμο μου χρησιμοποιω μονο δυο μεταβλητες...


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Για τη λύση του mailo
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 25 Ιαν 2007 09:47 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
esogos έγραψε:
mailo τον παρακάτω κώδικα γιατί τον βάζεις;

Syntax: [ Download ] [ Hide ]
  ΑΝ αριθμος=1 ΤΟΤΕ
    ι <-- αριθμος+1 !για τερματισμο τη επαναληψης
  ΑΛΛΙΩΣ_ΑΝ αριθμος=2 ΤΟΤΕ
    ι <-- αριθμος !για τερματισμο τη επαναληψης
  ΑΛΛΙΩΣ_ΑΝ αριθμος>2 ΤΟΤΕ
    ι <-- 2
  ΤΕΛΟΣ_ΑΝ
 


Αυτό που κάνεις παραπάνω είναι: ι <- 2

Άρα, μπορείς να το γράψεις κατευθείαν.


καλα λες, δεν χρειαζοταν αυτο :oops:


Τωρα ειναι ενταξη:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ πρωτος
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:αριθμος,ι
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Γραψε 'Δωσε εναν θετικο ακεραιο αριθμο'
    Διαβασε αριθμος
  ΜΕΧΡΙΣ_ΟΤΟΥ αριθμος>0

  ι <-- 2

  ΟΣΟ ι<αριθμος ΕΠΑΝΑΛΑΒΕ
    Αν αριθμος MOD ι = 0 Τοτε
      ι <-- αριθμος+1 !για τερματισμο τη επαναληψης
    ΤΕΛΟΣ_ΑΝ
    ι <-- ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ ι=αριθμος ΤΟΤΕ
    Γραψε 'Ο αριθμος', αριθμος,'ειναι πρωτος'
  ΑΛΛΙΩΣ
    Γραψε 'Ο αριθμος', αριθμος,'δεν ειναι πρωτος'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πρωτος


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 26 Ιαν 2007 03:42 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 14 Ιαν 2007 03:43 pm
Δημοσιεύσεις: 18
Τοποθεσία: Κομοτηνή
Τώρα είναι μία χαρά!:)

_________________
"Imagination is more important than knowledge. For knowledge is limited to all we now know and understand, while imagination embraces the entire world, and all there ever will be to know and understand."

Albert Einstein


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: πρώτος αριθμός
ΔημοσίευσηΔημοσιεύτηκε: Τρί 14 Οκτ 2008 04:59 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 14 Οκτ 2008 04:34 pm
Δημοσιεύσεις: 2
Ορίστε μια ακόμη λύση.Ελπίζω να είναι κατανοητή
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ PROTOS
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΡΙΘΜΟΣ,Ι
  ΛΟΓΙΚΕΣ: ΠΡΩΤΟΣ
ΑΡΧΗ
  ΠΡΩΤΟΣ <-- ΑΛΗΘΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ'
    ΔΙΑΒΑΣΕ ΑΡΙΘΜΟΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ (ΑΡΙΘΜΟΣ>0)

  ΑΝ (ΑΡΙΘΜΟΣ>1) ΤΟΤΕ
    ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ ΑΡΙΘΜΟΣ-1
      ΑΝ ((ΑΡΙΘΜΟΣ MOD Ι)=0) ΤΟΤΕ
        ΠΡΩΤΟΣ <-- ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ (ΠΡΩΤΟΣ=ΑΛΗΘΗΣ) ΤΟΤΕ
      ΓΡΑΨΕ 'Ο',ΑΡΙΘΜΟΣ,'ΕΝΑΙ ΠΡΩΤΟΣ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο',ΑΡΙΘΜΟΣ,'ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΕΔΩΣΕΣ ΤΟ 1'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Re:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 14 Οκτ 2008 06:02 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
esogos έγραψε:
Το πρόβλημά μου εδώ είναι ότι η τετραγωνική ρίζα της γλωσσομάθειας επιστρέφει δεκαδικό αριθμό (και φυσικά έτσι πρέπει). Δεν ξέρω αν υπάρχει κάποιος τρόπος να μεταρτέψεις έναν πραγματικό αριθμό σε ακέραιο στη γλωσσομάθεια (π.χ κάποιο cast, ή κάποιο τέχνασμα).

Μπορείς να χρησιμοποιήσεις το Α_Μ( ) ή κάποιο από αυτάhttp://spinet.gr/glossomatheia/programs/viewtopic.php?f=6&t=690(Ακέραιο Μέρος χωρίς Α_Μ())
Υ.Γ. Καποιοί θεωρούν πρώτο αριθμό το 1

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: πρώτος αριθμός
ΔημοσίευσηΔημοσιεύτηκε: Παρ 05 Δεκ 2008 10:28 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 23 Ιούλ 2008 08:39 pm
Δημοσιεύσεις: 5
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ firstnumbers

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, ΑΡΙΘ, ΜΕΤΡ_1ΑΡΙΘ
  ΧΑΡΑΚΤΗΡΕΣ: ΧΑΡΑΚΤ_ΑΡ


ΑΡΧΗ

  ΜΕΤΡ_1ΑΡΙΘ <-- 0
  ΑΡΙΘ <-- 1

  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ 0
    ΧΑΡΑΚΤ_ΑΡ <-- 'ΠΡΩΤΟΣ'
    ΓΙΑ Β ΑΠΟ 2 ΜΕΧΡΙ (ΑΡΙΘ - 1)
      ΑΝ  ΑΡΙΘ MOD Β = 0 ΤΟΤΕ
        ΧΑΡΑΚΤ_ΑΡ <-- 'ΟΧΙ_ΠΡΩΤΟΣ'
        Β <-- ΑΡΙΘ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΧΑΡΑΚΤ_ΑΡ = 'ΠΡΩΤΟΣ' ΤΟΤΕ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ:', ΑΡΙΘ, 'ΕΙΝΑΙ ΠΡΩΤΟΣ'
      ΜΕΤΡ_1ΑΡΙΘ <-- ΜΕΤΡ_1ΑΡΙΘ + 1
    ΤΕΛΟΣ_ΑΝ
    ΑΡΙΘ <-- ΑΡΙΘ + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ firstnumbers



σε ενα λεπτο βρηκα μεχρι το 62000 σε Pc με CPU 500 MHz


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: πρώτος αριθμός
ΔημοσίευσηΔημοσιεύτηκε: Τετ 31 Δεκ 2008 05:26 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 23 Ιούλ 2008 08:39 pm
Δημοσιεύσεις: 5
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ firstnumbers

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, ΑΡΙΘ,
  ΧΑΡΑΚΤΗΡΕΣ: ΧΑΡΑΚΤ_ΑΡ


ΑΡΧΗ

  ΜΕΤΡ_1ΑΡΙΘ <-- 0
  ΑΡΙΘ <-- 1

  ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ 0
    ΧΑΡΑΚΤ_ΑΡ <-- 'ΠΡΩΤΟΣ'
    ΓΙΑ Β ΑΠΟ 2 ΜΕΧΡΙ (ΑΡΙΘ/2 + 1)
      ΑΝ  ΑΡΙΘ MOD Β = 0 ΤΟΤΕ
        ΧΑΡΑΚΤ_ΑΡ <-- 'ΟΧΙ_ΠΡΩΤΟΣ'
        Β <-- ΑΡΙΘ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΧΑΡΑΚΤ_ΑΡ = 'ΠΡΩΤΟΣ' ΤΟΤΕ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ:', ΑΡΙΘ, 'ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΡΙΘ <-- ΑΡΙΘ + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ firstnumbers


faster


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: πρώτος αριθμός
ΔημοσίευσηΔημοσιεύτηκε: Παρ 16 Ιαν 2009 05:59 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΠΡΩΤΟΣ_ΑΡΙΘΜΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Ι , ΔΙΑΙΡΕΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΘΕΤΙΚΟ ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΕΛΕΓΧΘΕΙ ΑΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
  ΔΙΑΒΑΣΕ Χ
  ΟΣΟ Χ <= 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ Χ = 0 ΤΟΤΕ
      ΓΡΑΨΕ'Ο ΑΡΙΘΜΟΣ ΜΗΔΕΝ ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
      ΔΙΑΒΑΣΕ Χ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ'ΔΩΣΑΤΕ ΑΡΝΗΤΙΚΟ ΑΡΙΘΜΟ , ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΤΕ'
      ΔΙΑΒΑΣΕ Χ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Χ = 1 ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΑΠΟΙΟΙ ΛΕΝΕ ΠΩΣ Ο 1 ΕΙΝΑΙ ΠΡΩΤΟΣ , ΑΛΛΟΙ ΛΕΝΕ ΠΩΣ ΟΧΙ'
  ΑΛΛΙΩΣ
    Ι <-- 2
    ΔΙΑΙΡΕΤΕΣ <-- 2!Η ΜΟΝΑΔΑ ΚΑΙ Ο ΕΑΥΤΟΣ ΤΟΥ
    ΟΣΟ Ι<=Τ_Ρ(Χ) ΚΑΙ ΔΙΑΙΡΕΤΕΣ=2 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Χ MOD Ι = 0 ΤΟΤΕ
        ΔΙΑΙΡΕΤΕΣ <-- ΔΙΑΙΡΕΤΕΣ + 1
      ΤΕΛΟΣ_ΑΝ
      Ι <-- Ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΔΙΑΙΡΕΤΕΣ = 2 ΤΟΤΕ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΟΥ ΔΩΣΑΤΕ , Ο' ,Χ, 'ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΟΥ ΔΩΣΑΤΕ , Ο' ,Χ, 'ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΤΩΡΑ ΕΙΝΑΙ ΟΚ!

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Τελευταία επεξεργασία από Sudavar{SP} και Κυρ 04 Οκτ 2009 03:48 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: πρώτος αριθμός
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Αύγ 2009 12:09 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Sudavar{SP} έγραψε:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΠΡΩΤΟΣ_ΑΡΙΘΜΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Ι , ΔΙΑΙΡΕΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΘΕΤΙΚΟ ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΕΛΕΓΧΘΕΙ ΑΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
  ΔΙΑΒΑΣΕ Χ
  ΟΣΟ Χ <= 0 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ'ΔΩΣΑΤΕ ΑΡΝΗΤΙΚΟ ΑΡΙΘΜΟ Ή ΜΗΔΕΝ , ΠΑΡΑΚΛΩ ΞΑΝΑΔΩΣΤΕ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Χ = 1 ΤΟΤΕ
    ΓΡΑΨΕ ' ΚΑΠΟΙΟΙ ΛΕΝΕ ΠΩΣ Ο 1 ΕΙΝΑΙ ΠΡΩΤΟΣ , ΑΛΛΟΙ ΛΕΝΕ ΠΩΣ ΟΧΙ'
  ΑΛΛΙΩΣ
    Ι <-- 2
    ΔΙΑΙΡΕΤΕΣ <-- 2!Η ΜΟΝΑΔΑ ΚΑΙ Ο ΕΑΥΤΟΣ ΤΟΥ
    ΟΣΟ Ι<=Τ_Ρ(Χ) ΚΑΙ ΔΙΑΙΡΕΤΕΣ=2 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Χ MOD Ι = 0 ΤΟΤΕ
        ΔΙΑΙΡΕΤΕΣ <-- ΔΙΑΙΡΕΤΕΣ + 1
      ΤΕΛΟΣ_ΑΝ
      Ι <-- Ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΔΙΑΙΡΕΤΕΣ = 2 ΤΟΤΕ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΟΥ ΔΩΣΑΤΕ , Ο',Χ,'ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΟΥ ΔΩΣΑΤΕ , Ο',Χ,'ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


πρέπει να προσθέσεις και την διάβασε μετά το ΓΡΑΨΕ 'ΔΩΣΑΤΕ ΑΡΝΗΤΙΚΟ ΑΡΙΘΜΟ Ή ΜΗΔΕΝ , ΠΑΡΑΚΛΩ ΞΑΝΑΔΩΣΤΕ' αλλιώς απλώς το γράφει μέχρι να βαρεθείς και να το κλείσεις :) αν δώσεις αρνητικό … ( επίσης έχεις ξεχάσει το Α στο παρακαλώ )

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 13 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters