Τώρα είναι Τρί 15 Οκτ 2019 10:10 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Φεβ 2011 02:18 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 28 Φεβ 2011 12:51 am
Δημοσιεύσεις: 2
! Πρόγραμμα επίλυσης γραμμικού συστήματος 2 x 2, της μορφής:
! Α1*X + Β1*Y = Γ1
! Α2*Χ + Β2*Υ = Γ2
! Εισάγουμε τους συντελεστές (Α1,Β1,Γ1,Α2,Β2,Γ2)
! και το πρόγραμμα μας δίνει τη λύση (Χ, Υ), αν φυσικά υπάρχει
! Η επίλυση γίνεται με ορίζουσες
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  ΣΥΣΤΗΜΑ_2Χ2
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Σ[2,3],Δ,ΔΧ,ΔΥ,Χ,Υ
  ΑΚΕΡΑΙΕΣ:Ι,Κ

ΑΡΧΗ
  ΓΡΑΨΕ '** Πρόγραμμα επίλυσης γραμμικού συστήματος 2 x 2, της μορφής:'
  ΓΡΑΨΕ '   Α1*X + Β1*Y = Γ1'
  ΓΡΑΨΕ '   Α2*Χ + Β2*Υ = Γ2'

  ΓΡΑΨΕ 'ΕΙΣΑΓΕΤΕ ΤΟΥΣ ΣΥΝΤΕΛΕΣΤΕΣ ΤΟΥ ΣΥΣΤΗΜΑΤΟΣ (Α1,Β1,Γ1,Α2,Β2,Γ2'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
      ΔΙΑΒΑΣΕ Σ[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Δ <-- Σ[1,1]*Σ[2,2]-Σ[1,2]*Σ[2,1]
  ΔΧ <-- Σ[1,3]*Σ[2,2]-Σ[1,2]*Σ[2,3]
  ΔΥ <-- Σ[1,1]*Σ[2,3]-Σ[1,3]*Σ[2,1]
  ΑΝ Δ=0 ΤΟΤΕ
    ΑΝ ΔΧ=0 ΚΑΙ ΔΥ=0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΟ ΣΥΣΤΗΜΑ ΕΙΝΑΙ ΑΟΡΙΣΤΟ! (ΥΠΑΡΧΟΥΝ ΑΠΕΙΡΕΣ ΛΥΣΕΙΣ)'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΤΟ ΣΥΣΤΗΜΑ ΕΙΝΑΙ ΑΔΥΝΑΤΟ! (ΔΕΝ ΥΠΑΡΧΕΙ ΛΥΣΗ)'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    Χ <-- ΔΧ/Δ
    Υ <-- ΔΥ/Δ
    ΓΡΑΨΕ 'ΤΟ ΣΥΣΤΗΜΑ ΕΧΕΙ ΜΟΝΑΔΙΚΗ ΛΥΣΗ:'
    ΓΡΑΨΕ 'Χ = ',Χ,'  και  Υ = '
  ΤΕΛΟΣ_ΑΝ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters