Τώρα είναι Σάβ 29 Φεβ 2020 03:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΔΙΟΡΘΩΤΗΣ ΣΕΛΙΔΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 15 Μάιος 2003 06:34 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Παλιά υπήρχαν διορθωτές σελίδων (screens) οπου δεν προχώραγε κάποιος δρομέας για να παρεμβάλουμε χαρακτήρες, παρά μας ζήταγε σελίδα και γραμμή και βάζαμε απ'ευθείας μια γραμμή.
Στο παράδειγμα βάζουμε και δυο λειτουργίες: Την διαγραφή γραμμής καθώς και την εισαγωγή γραμμής. Όταν διαγράφουμε, μαζεύουμε τις από **κάτω** γραμμές (και από τις άλλες σελίδες. Όταν παρεμβάλουμε μετακινούμε μια θέση όλες τις από κάτω γραμμές (και στις άλλες σελίδες).
Δοκιμάστε το!
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΔΙΟΡΘΩΤΗΣ_ΣΕΛΙΔΩΝ
ΣΤΑΘΕΡΕΣ
  ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ=12
  ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ=12
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΣΕΛΙΔΑ, ΓΡΑΜΜΗ, ΤΙ, Ι, ΝΕΑ_ΣΕΛΙΔΑ, ΝΕΑ_ΓΡΑΜΜΗ
  ΧΑΡΑΚΤΗΡΕΣ: ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ, ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ], ΑΛΛΗ
  ΛΟΓΙΚΕΣ: ΓΕΙΑ_ΧΑΡΑ
ΑΡΧΗ
  ΣΕΛΙΔΑ <-- 1
  ΓΡΑΜΜΗ <-- 1
  ΓΕΙΑ_ΧΑΡΑ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 24
      ΓΡΑΨΕ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '------------ΔΙΟΡΘΩΤΗΣ ΣΕΛΙΔΩΝ------------[ΓΡΑΜΜΗ: ',ΓΡΑΜΜΗ,', ΣΕΛΙΔΑ: ',ΣΕΛΙΔΑ,']'
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ
      ΑΝ Ι<10 ΤΟΤΕ
        ΓΡΑΨΕ ' ', Ι,'.',ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ, Ι]
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ  Ι,'.',ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ, Ι]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '-------------ΕΠΙΛΟΓΕΣ----------------------------------------------------------'
    ΓΡΑΨΕ ' 1 - ΕΜΦΑΝΙΣΗ ΣΕΛΙΔΑΣ'
    ΓΡΑΨΕ ' 2 - ΕΜΦΑΝΙΣΗ ΣΕΛΙΔΑΣ & ΔΙΟΡΘΩΣΗ ΓΡΑΜΜΗΣ'
    ΓΡΑΨΕ ' 3 - ΔΙΟΡΘΩΣΗ ΓΡΑΜΜΗΣ'
    ΓΡΑΨΕ ' 4 - ΔΙΑΓΡΑΦΗ ΓΡΑΜΜΗΣ'
    ΓΡΑΨΕ ' 5 - ΠΑΡΕΜΒΟΛΗ ΓΡΑΜΜΗΣ'
    ΓΡΑΨΕ ' 6 - ΕΞΟΔΟΣ'
    ΔΙΑΒΑΣΕ ΤΙ
    ΕΠΙΛΕΞΕ ΤΙ
      ΠΕΡΙΠΤΩΣΗ 1
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ  'ΔΩΣΕ ΣΕΛΙΔΑ:1 - ', ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ
          ΔΙΑΒΑΣΕ ΝΕΑ_ΣΕΛΙΔΑ
        ΜΕΧΡΙΣ_ΟΤΟΥ (ΝΕΑ_ΣΕΛΙΔΑ>0) ΚΑΙ (ΝΕΑ_ΣΕΛΙΔΑ<=ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ)
        ΣΕΛΙΔΑ <-- ΝΕΑ_ΣΕΛΙΔΑ
      ΠΕΡΙΠΤΩΣΗ 2
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ  'ΔΩΣΕ ΣΕΛΙΔΑ:1 - ', ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ
          ΔΙΑΒΑΣΕ ΝΕΑ_ΣΕΛΙΔΑ
        ΜΕΧΡΙΣ_ΟΤΟΥ (ΝΕΑ_ΣΕΛΙΔΑ>0) ΚΑΙ (ΝΕΑ_ΣΕΛΙΔΑ<=ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ)
        ΣΕΛΙΔΑ <-- ΝΕΑ_ΣΕΛΙΔΑ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ  'ΔΩΣΕ ΓΡΑΜΜΗ:1 - ', ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ
          ΔΙΑΒΑΣΕ ΝΕΑ_ΓΡΑΜΜΗ
        ΜΕΧΡΙΣ_ΟΤΟΥ (ΝΕΑ_ΓΡΑΜΜΗ>0) ΚΑΙ (ΝΕΑ_ΓΡΑΜΜΗ<=ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ)
        ΓΡΑΜΜΗ <-- ΝΕΑ_ΓΡΑΜΜΗ
        ΓΡΑΨΕ 'ΓΡΑΨΕ ΓΡΑΜΜΗ:'
        ΓΡΑΨΕ '<',ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ],'>'
        ΔΙΑΒΑΣΕ ΑΛΛΗ
        ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ] <-- ΑΛΛΗ
      ΠΕΡΙΠΤΩΣΗ 3
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ  'ΔΩΣΕ ΓΡΑΜΜΗ:1 - ', ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ
          ΔΙΑΒΑΣΕ ΝΕΑ_ΓΡΑΜΜΗ
        ΜΕΧΡΙΣ_ΟΤΟΥ (ΝΕΑ_ΓΡΑΜΜΗ>0) ΚΑΙ (ΝΕΑ_ΓΡΑΜΜΗ<=ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ)
        ΓΡΑΜΜΗ <-- ΝΕΑ_ΓΡΑΜΜΗ
        ΓΡΑΨΕ 'ΓΡΑΨΕ ΓΡΑΜΜΗ [',ΓΡΑΜΜΗ,']'
        ΔΙΑΒΑΣΕ ΑΛΛΗ
        ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ] <-- ΑΛΛΗ
      ΠΕΡΙΠΤΩΣΗ 4
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ  'ΔΩΣΕ ΓΡΑΜΜΗ ΓΙΑ ΔΙΑΓΡΑΦΗ:'
          ΔΙΑΒΑΣΕ ΝΕΑ_ΓΡΑΜΜΗ
        ΜΕΧΡΙΣ_ΟΤΟΥ (ΝΕΑ_ΓΡΑΜΜΗ>0) ΚΑΙ (ΝΕΑ_ΓΡΑΜΜΗ<=ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ)
        ΓΡΑΜΜΗ <-- ΝΕΑ_ΓΡΑΜΜΗ
        ΝΕΑ_ΣΕΛΙΔΑ <-- ΣΕΛΙΔΑ
        Ι <-- ΣΕΛΙΔΑ
        ΟΣΟ  (ΝΕΑ_ΣΕΛΙΔΑ<= ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ] <-- ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΝΕΑ_ΣΕΛΙΔΑ,ΝΕΑ_ΓΡΑΜΜΗ]
          ΣΕΛΙΔΑ <-- ΝΕΑ_ΣΕΛΙΔΑ
          ΓΡΑΜΜΗ <-- ΝΕΑ_ΓΡΑΜΜΗ
          ΝΕΑ_ΓΡΑΜΜΗ <-- ΓΡΑΜΜΗ+1
          ΑΝ ΝΕΑ_ΓΡΑΜΜΗ>ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ ΤΟΤΕ
            ΝΕΑ_ΓΡΑΜΜΗ <-- 1
            ΝΕΑ_ΣΕΛΙΔΑ <-- ΣΕΛΙΔΑ+1
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ] <-- ''
        ΣΕΛΙΔΑ <-- Ι
      ΠΕΡΙΠΤΩΣΗ 5
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ  'ΔΩΣΕ ΓΡΑΜΜΗ ΓΙΑ ΕΙΣΑΓΩΓΗ:'
          ΔΙΑΒΑΣΕ ΝΕΑ_ΓΡΑΜΜΗ
        ΜΕΧΡΙΣ_ΟΤΟΥ (ΝΕΑ_ΓΡΑΜΜΗ>0) ΚΑΙ  (ΝΕΑ_ΓΡΑΜΜΗ<=ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ)
        Ι <-- ΝΕΑ_ΓΡΑΜΜΗ+(ΣΕΛΙΔΑ-1)*ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ
        ΓΡΑΜΜΗ <-- ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ
        ΣΕΛΙΔΑ <-- ΜΕΓΙΣΤΕΣ_ΣΕΛΙΔΕΣ
        ΝΕΑ_ΣΕΛΙΔΑ <-- ΣΕΛΙΔΑ
        ΟΣΟ (ΓΡΑΜΜΗ+(ΣΕΛΙΔΑ-1)*ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ)>Ι ΕΠΑΝΑΛΑΒΕ
          ΝΕΑ_ΓΡΑΜΜΗ <-- ΓΡΑΜΜΗ-1
          ΑΝ ΝΕΑ_ΓΡΑΜΜΗ<1 ΤΟΤΕ
            ΝΕΑ_ΣΕΛΙΔΑ <-- ΣΕΛΙΔΑ-1
            ΝΕΑ_ΓΡΑΜΜΗ <-- ΜΕΓΙΣΤΕΣ_ΓΡΑΜΜΕΣ_ΑΝΑ_ΣΕΛΙΔΑ
          ΤΕΛΟΣ_ΑΝ
          ΑΝ ΣΕΛΙΔΑ>0 ΤΟΤΕ
            ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ] <-- ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΝΕΑ_ΣΕΛΙΔΑ,ΝΕΑ_ΓΡΑΜΜΗ]
          ΤΕΛΟΣ_ΑΝ
          ΓΡΑΜΜΗ <-- ΝΕΑ_ΓΡΑΜΜΗ
          ΣΕΛΙΔΑ <-- ΝΕΑ_ΣΕΛΙΔΑ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΜΜΗ_ΣΕΛΙΔΑΣ[ΣΕΛΙΔΑ,ΓΡΑΜΜΗ] <-- ''
      ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ
        ΓΕΙΑ_ΧΑΡΑ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΓΕΙΑ_ΧΑΡΑ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


******ΔΙΟΡΘΩΣΗ*******
ΣΤΗΝ ΠΕΡΙΠΤΩΣΗ 5 ΤΟ > ΕΓΙΝΕ <

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters