Τώρα είναι Δευτ 17 Φεβ 2020 04:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 24 Δεκ 2006 12:41 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 23 Δεκ 2006 07:51 am
Δημοσιεύσεις: 1
Να γίνει πρόγραμμα που να υπολογίζει το γινόμενο δύο ΝxΝ πινάκων.


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τετ 02 Ιαν 2008 11:45 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 02 Ιαν 2008 11:40 am
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
!========================================================================================
!Πολλαπλασιασμός πινάκων ( Κάθε φορά αλλάζουμε τις σταθερές ανάλογα με τους πίνακες)
!========================================================================================

ΠΡΟΓΡΑΜΜΑ Γινόμενο_Πινάκων

ΣΤΑΘΕΡΕΣ
  Μ=3
  Ν=4
  Τ=2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[Μ,Ν], Β[Ν,Τ], Γ[Μ,Τ], i ,j  ,k  ,Σ

ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    ΓΡΑΨΕ
    ΓΙΑ j ΑΠΟ 1  ΜΕΧΡΙ Ν
      ΓΡΑΨΕ 'Δώσε το στοιχείο της ',i,'ης γραμμής και ',j,'ης στήλης'
      ΔΙΑΒΑΣΕ Α[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    ΓΡΑΨΕ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΓΡΑΨΕ_ Α[i,j],' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ
    ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ Τ
      ΓΡΑΨΕ 'Δώσε το στοιχείο της ',j,'ης γραμμής και ',k,'ης στήλης'
      ΔΙΑΒΑΣΕ Β[j,k]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ
    ΓΙΑ  k ΑΠΟ 1 ΜΕΧΡΙ Τ
      ΓΡΑΨΕ_ Β[j,k],' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Το γινόμενο είναι:'

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    ΓΙΑ k ΑΠΟ 1  ΜΕΧΡΙ  Τ
      Σ <-- 0
      ΓΙΑ j ΑΠΟ 1  ΜΕΧΡΙ Ν
        Σ <-- Σ +  Α[i,j]*Β[j,k]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      Γ[i,k] <-- Σ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Μ
    ΓΡΑΨΕ
    ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ Τ
      ΓΡΑΨΕ_ Γ[i,k],' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Γινόμενο_Πινάκων


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters