Τώρα είναι Πέμ 28 Μάιος 2020 02:22 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αποκοπή γραμμής & στήλης
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 15 Μαρ 2003 03:37 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =================================================
! Να γίνει πρόγραμμα που να αποθηκεύει με χρήση
! μαθηματικού τύπου τις εξής τιμές σε έναν πίνακα
! 5x5 ακεραίων:
!               11  12  13  14  15
!               21  22  23  24  25
!               31  32  33  34  35
!               41  42  43  44  45
!               51  52  53  54  55
! Στη συνέχεια να ζητάει έναν αριθμό γραμμής και
! έναν αριθμό στήλης και να δημιουργεί ένα νέο
! πίνακα 4x4 ακεραίων, που θα είναι ίδιος με τον
! αρχικό αλλά χωρίς την επιλεγμένη γραμμή & στήλη.
! =================================================


ΠΡΟΓΡΑΜΜΑ Αποκοπή_γραμμής_και_στήλης

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[5,5], Β[4,4], i, j, x, y

ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
      Α[i,j] <-- 10*i+j
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Αρχικός πίνακας:'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ_ Α[i,j], '  '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ            ! Για αλλαγή γραμμής στην οθόνη
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε τη γραμμή & τη στήλη που θα αποκοπούν:'
    ΔΙΑΒΑΣΕ x,y
  ΜΕΧΡΙΣ_ΟΤΟΥ (x>0) ΚΑΙ (x<6) ΚΑΙ (y>0) ΚΑΙ (y<6)

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 4

      ΑΝ (i<x) ΚΑΙ (j<y) ΤΟΤΕ
        Β[i,j] <-- Α[i,j]
      ΑΛΛΙΩΣ_ΑΝ (i<x) ΚΑΙ (j>=y) ΤΟΤΕ
        Β[i,j] <-- Α[i,j+1]
      ΑΛΛΙΩΣ_ΑΝ (i>=x) ΚΑΙ (j<y) ΤΟΤΕ
        Β[i,j] <-- Α[i+1,j]
      ΑΛΛΙΩΣ_ΑΝ (i>=x) ΚΑΙ (j>=y) ΤΟΤΕ
        Β[i,j] <-- Α[i+1,j+1]
      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Αποκομμένος πίνακας:'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΡΑΨΕ_ Β[i,j], '  '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ            ! Για αλλαγή γραμμής στην οθόνη
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αποκοπή_γραμμής_και_στήλης

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 03 Φεβ 2007 10:30 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 07 Δεκ 2006 01:18 pm
Δημοσιεύσεις: 1
Τοποθεσία: Paros
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ αποκοπή_γραμμής_στήλης
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,k,l, G, S, A[5,5], B[4,4]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
      ΔΙΑΒΑΣΕ A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε γραμμή'
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΔΙΑΒΑΣΕ G
   ΜΕΧΡΙΣ_ΟΤΟΥ (G>=1) ΚΑΙ (G<=5)

  ΓΡΑΨΕ  'Δώσε στήλη'
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ  S
   ΜΕΧΡΙΣ_ΟΤΟΥ (S>=1) ΚΑΙ (S<=5)

  k <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ i<>G ΤΟΤΕ
      l <-- 1
      ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
        ΑΝ j<>S ΤΟΤΕ
          B[k,l] <-- A[i,j]
          l <-- l+1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      k <-- k+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο αρχικός πίνακας είναι ο παρακάτω....'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ  A[i,1], '-', A[i,2], '-',A[i,3], '-',A[i,4], '-',A[i,5]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο πίνακας χωρίς την ', G ,'η γραμμή και την ', S ,'η στήλη είναι ο παρακάτω....'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ  B[i,1], '-', B[i,2], '-',B[i,3], '-',B[i,4]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
Ok yes, ok yes...


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters