Τώρα είναι Πέμ 20 Φεβ 2020 02:17 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΡΩΤΗΣΗ: ΜΟ ΠΙΝΑΚΑ
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 12 Δεκ 2005 02:47 am 
Έχω γράψει τον παρακάτω αλγόριθμο για την εύρεση Μέσου όρου των τιμών ενός πίνακα:
Syntax: [ Download ] [ Hide ]
 
ΠΡΟΓΡΑΜΜΑ ΜΟ_ΠΙΝΑΚΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Κ,Σ, Π[2,3]
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
      ΓΡΑΨΕ 'Δώσε την Π[',Ι,',',Κ,'] τιμή του πίνακα:'
      ΔΙΑΒΑΣΕ Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
      Σ <-- Σ+Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΟ <-- Σ/6
  ΓΡΑΨΕ ΜΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΟ_ΠΙΝΑΚΑ
 

Μπορεί κάποιος να μου πει με τις θα αντικαταστήσω το 6, στη γραμμή ΜΟ <-- Σ/6, ώστε να διαιρεί με το πλήθος των στοιχείων του πίνακα;
Δοκίμασα το (Ι*Κ), αλλά δεν..

Ευχαριστώ εκ των προτέρων!


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 15 Δεκ 2005 01:23 pm 
ΜΟ <-- Σ/((Ι-1)*(Κ-1))
ΓΡΑΨΕ ΜΟ:2:2

ΚΑΙ ΕΙΣΑΙ ΕΤΟΙΜΟΣ...
ΑΥΤΟ ΔΟΥΛΕΥΕΙ ΓΙΑΤΙ ΟΥΣΙΑΣΤΙΚΑ ΕΣΥ ΘΕΛΕΙς ΝΑ ΠΟΛΛΑΠΛΑΣΙΑΖΕΙΣ ΤΩΝ ΑΡΙΘΜΟ ΓΡΑΜΜΩΝ ΜΕ ΤΟΝ ΑΡΙΘΜΟ ΣΤΗΛΩΝ ΤΟΥ ΠΙΝΑΚΑ.ΣΤΗ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ, ΟΙ ΜΕΤΡΗΤΕΣ "ΦΕΥΓΟΥΝ" ΑΠΟ ΤΙΣ ΔΟΜΕΣ ΜΕ ΤΙΜΗ, ΟΣΟ ΤΟ ΒΗΜΑ ΕΠΑΝΑΛΗΨΗΣ, ΠΑΡΑΠΑΝΩ!!(ΧΑ, ΘΑ ΛΕΣ, ΤΙ ΕΙΠΕ ΤΩΡΑ ΑΥΤΟΣ!). ΕΞΗΓΩ: ΑΝ ΣΕ ΜΙΑ ΔΟΜΗ ΓΙΑ ΕΧΩ

ΓΙΑ Α=1 ΕΩΣ 10
ΓΡΑΨΕ Α
ΤΕΛΟΣ_ΓΙΑ
ΓΡΑΨΕ Α

ΤΟΤΕ ΘΑ ΕΚΤΥΠΩΘΕΙ ΣΤΗΝ ΟΘΟΝΗ,ΓΙΑ ΤΟ Α ΠΟΥ ΕΙΝΑΙ ΜΕΤΑ ΤΗ ΔΟΜΗ Ο ΑΡΙΘΜΟΣ 11!.ΑΝ ΠΧ ΣΤΗΝ ΠΑΡΑΠΑΝΩ ΔΟΜΗ ΕΙΧΑ ΜΕ ΒΗΜΑ 2, ΤΟΤΕ ΤΟ Α ΠΟΥ ΘΑ ΕΜΦΑΝΙΖΟΤΑΝ ΣΤΗΝ ΟΘΟΝΗ ΜΕΤΑ ΤΗ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΘΑ ΗΤΑΝ 12!
ΑΡΑ ΣΤΟ ΠΑΡΑΔΕΙΓΜΑ ΣΟΥ, ΟΙ ΜΕΤΡΗΤΕΣ ΣΟΥ, "ΦΕΥΓΟΥΝ" ΑΠΟ ΤΙΣ ΔΟΜΕΣ ΕΧΩΝΤΑΣ ΩΣ ΤΙΜΗ 1 ΠΑΡΑΠΑΝΩ(ΓΙΑΤΙ ΤΟ ΒΗΜΑ ΣΟΥ ΕΙΝΑΙ 1)ΑΠΟ ΤΗΝ ΤΙΜΗ ΠΟΥ ΤΙΣ ΕΧΕΙ ΒΑΛΕΙ ΝΑ ΦΤΑΣΟΥΝ(ΑΡΑ ΤΟ Ι ΦΕΥΓΕΙ ΜΕ ΤΙΜΗ 3,ΕΝΩ ΤΟ Κ ΜΕ 4).ΓΙ' ΑΥΤΟ ΤΙΣ ΒΑΖΟΥΜΕ Ι-1 ΚΑΙ Κ-1...
ΕΛΠΙΖΩ ΝΑ ΒΟΗΘΗΣΑ. ΠΑΝΤΩΣ ΑΝ ΧΡΕΙΑΣΤΕΙΣ ΚΑΤΙ ΑΚΟΜΑ ΓΙΑ ΤΗΝ ΑΣΚΗΣΗ ΜΗ ΔΙΣΤΑΣΕΙΣ ΝΑ ΣΤΕΙΛΕΙΣ MAIL ΣΤΟ georgegir@gmail.com...


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Ιαν 2006 09:20 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Αύγ 2005 09:45 pm
Δημοσιεύσεις: 2
Δε καταλαβαίνω γιατί δε βάζεις απλά τον αριθμό 6 και θέλεις να το βγάλεις με μεταβλητές. Αφού έχεις δηλώσει τον πίνακα Π[2,3] και το μέγεθος του δε μεταβάλεται κατά την διάρκεια εκτέλεσης του προγράμματος ποιος ο λόγος να βάζεις τον Η/Υ να ψάχνει τις τιμές των μεταβλητών;
Αυτά...
Παρακάτω παραθέτω το πρόγραμμα όπως το θέλεις
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΟ_ΠΙΝΑΚΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Κ,Σ, Π[2,3]
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
      ΓΡΑΨΕ 'Δώσε την Π[',Ι,',',Κ,'] τιμή του πίνακα:'
      ΔΙΑΒΑΣΕ Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
      Σ <-- Σ+Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΟ <-- Σ/((Ι-1)*(Κ-1))
  ΓΡΑΨΕ ΜΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΟ_ΠΙΝΑΚΑ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 05 Δεκ 2007 10:42 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 05 Δεκ 2007 10:36 pm
Δημοσιεύσεις: 1
Τοποθεσία: Κύμη Ευβοίας
Έτσι δουλεύει, δηλ. με named constants
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΟ_ΠΙΝΑΚΑ
ΣΤΑΘΕΡΕΣ
  Γ=2
  Στ=3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Κ,Σ, Π[Γ,Στ]
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Γ
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Στ
      ΓΡΑΨΕ 'Δώσε την Π[',Ι,',',Κ,'] τιμή του πίνακα:'
      ΔΙΑΒΑΣΕ Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Γ
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Στ
      Σ <-- Σ+Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΟ <-- Σ/(Γ*Στ)
  ΓΡΑΨΕ ΜΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΟ_ΠΙΝΑΚΑ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters