Τώρα είναι Παρ 05 Ιουν 2020 12:28 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 27 Νοέμ 2005 02:52 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 27 Νοέμ 2005 02:40 pm
Δημοσιεύσεις: 1
Να γραφεί πρόγραμμα που θα διαβάζει ένα πίνακα Α[9,9] στον οποίο κάθε στοιχείο του θα πρέπει να είναι απο το 1 εως το 20 και δεν θα είναι ίδιο με κανένα άλλο στοιχείο της γραμμής που βρίσκεται και της στήλης που βρίσκεται.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 30 Νοέμ 2005 02:38 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Matrix_2D
ΣΤΑΘΕΡΕΣ
  N=9
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  i,j,k,m,Α[N,N]
  ΛΟΓΙΚΕΣ:   ομοιο
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N

      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Δώσε στοιχείο ',i,'ης γραμμής και ',j,'ης στηλης'
          ΔΙΑΒΑΣΕ Α[i,j]
        ΜΕΧΡΙΣ_ΟΤΟΥ  Α[i,j] >=1 ΚΑΙ  Α[i,j] <=20

        k <-- i
        m <-- 1
        ομοιο <-- ΨΕΥΔΗΣ
        ΟΣΟ  ομοιο=ΨΕΥΔΗΣ ΚΑΙ m<j ΕΠΑΝΑΛΑΒΕ
          ΑΝ   Α[i,j] = Α[k,m] ΤΟΤΕ
            ομοιο <-- ΑΛΗΘΗΣ
            ΓΡΑΨΕ 'Βρέθηκε όμοιο στοιχείο στην ',m,'η στηλη'
          ΤΕΛΟΣ_ΑΝ
          m <-- m+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

        k <-- 1
        m <-- j
        ΟΣΟ  ομοιο=ΨΕΥΔΗΣ ΚΑΙ k<i ΕΠΑΝΑΛΑΒΕ
          ΑΝ   Α[i,j] = Α[k,m] ΤΟΤΕ
            ομοιο <-- ΑΛΗΘΗΣ
            ΓΡΑΨΕ 'Βρέθηκε όμοιο στοιχείο στην ',k,'η γραμμη'
          ΤΕΛΟΣ_ΑΝ
          k <-- k+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΜΕΧΡΙΣ_ΟΤΟΥ  ομοιο=ΨΕΥΔΗΣ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters