Τώρα είναι Τετ 08 Ιούλ 2020 11:17 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 22 Φεβ 2005 02:11 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Τα επόμενα προγράμματα απαρτίζουν μια σειρά προβλήματων κατασκευής διδιάστατων τετραγωνικών πινάκων (διαφορετικής δυσκολίας) των οποίων η λύση συνίσταται κυρίως στην παρατηρητικότητα αλλά και στην εξοικίωση μας με τους δείκτες i,j.
Πριν λοιπόν ασχοληθείτε με τα επόμενα προβλήματα, θα ήθελα να βοήθησω λίγο με την αποτύπωση των δεικτών i,j ενός τετραγωνικού πίνακα Α[Ν,Ν] με Ν=5.

------------------------------------------------------------------------------------
Παρακολουθήστε την 1η χρωματική διαβαθμίση του πίνακα Α.

1,1 1,2 1,3 1,4 1,5

2,1 2,2 2,3 2,4 2,5

3,1 3,2 3,3 3,4 3,5

4,1 4,2 4,3 4,4 4,5

5,1 5,2 5,3 5,4 5,5

και παρατηρείστε πως:

για τα ΜΠΛΕ στοιχεία του πίνακα ισχύει i<j

για τα KOKKINA στοιχεία του πίνακα ισχύει i=j

για τα ΜΑΥΡΑ στοιχεία του πίνακα ισχύει i>j


------------------------------------------------------------------------------------
Παρακολουθήστε την 2η χρωματική διαβαθμίση του πίνακα Α.

1,1 1,2 1,3 1,4 1,5

2,1 2,2 2,3 2,4 2,5

3,1 3,2 3,3 3,4 3,5

4,1 4,2 4,3 4,4 4,5

5,1 5,2 5,3 5,4 5,5


και παρατηρείστε πως:

για τα ΜΠΛΕ στοιχεία του πίνακα ισχύει i=j-2

για τα KOKKINA στοιχεία του πίνακα ισχύει i=j+2


------------------------------------------------------------------------------------
Παρακολουθήστε την 3η χρωματική διαβαθμίση του πίνακα Α.

1,1 1,2 1,3 1,4 1,5

2,1 2,2 2,3 2,4 2,5

3,1 3,2 3,3 3,4 3,5

4,1 4,2 4,3 4,4 4,5

5,1 5,2 5,3 5,4 5,5


και παρατηρείστε πως:

για τα ΜΠΛΕ στοιχεία του πίνακα ισχύει i+j=4 (ή γενικότερα i+j=N-1)

για τα KOKKINA στοιχεία του πίνακα ισχύει i+j=6 (ή γενικότερα i+j=N+1)


------------------------------------------------------------------------------------
Παρακολουθήστε την 4η χρωματική διαβαθμίση του πίνακα Α.

1,1 1,2 1,3 1,4 1,5

2,1 2,2 2,3 2,4 2,5

3,1 3,2 3,3 3,4 3,5

4,1 4,2 4,3 4,4 4,5

5,1 5,2 5,3 5,4 5,5

και παρατηρείστε πως:

για τα KOKKINA στοιχεία του πίνακα ισχύει i Mod 2 = 1


------------------------------------------------------------------------------------
Παρακολουθήστε την 5η χρωματική διαβαθμίση του πίνακα Α.

1,1 1,2 1,3 1,4 1,5

2,1 2,2 2,3 2,4 2,5

3,1 3,2 3,3 3,4 3,5

4,1 4,2 4,3 4,4 4,5

5,1 5,2 5,3 5,4 5,5

και παρατηρείστε πως:

για τα ΜΠΛΕ στοιχεία του πίνακα ισχύει i<3 KAI j<3

για τα KOKKINA στοιχεία του πίνακα ισχύει i>3 KAI j>3

------------------------------------------------------------------------------------
Ελπίζοντας ότι δεν σας κουρασα παραθετώ τα επόμενα προβλήματα-παιχνίδια, περιμένοντας τα σχόλια σας :D και ανάλογα προβλήματα ή και διαφορετικές λύσεις στα ήδη προτεινόμενα.



Syntax: [ Download ] [ Hide ]


! ===================     1    ===============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[5,5].
!
!      1   2   3    4   5
!      2   4   6    8  10
!      3   6   9   12  15
!      4   8  12   16  20
!      5  10  15   20  25
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_01
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      A[i,j] <-- i*j
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 




Syntax: [ Download ] [ Hide ]

! ======================   2   ===============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!
!      2   0   0    0   0
!      2   4   0    0   0
!      2   2   6    0   0
!      2   2   2    8   0
!      2   2   2    2  10
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_02
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ i<j ΤΟΤΕ
        A[i,j] <-- 0
      ΑΛΛΙΩΣ_ΑΝ i=j ΤΟΤΕ
        A[i,j] <-- i+j
      ΑΛΛΙΩΣ_ΑΝ i>j ΤΟΤΕ
        A[i,j] <-- 2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 



Syntax: [ Download ] [ Hide ]


! ======================    3    ============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!                  
!      0  2  0  0  0
!      2  0  3  0  0
!      0  3  0  4  0
!      0  0  4  0  5
!      0  0  0  5  0
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_03
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ i=j+1 ΤΟΤΕ
        A[i,j] <-- i
      ΑΛΛΙΩΣ_ΑΝ i=j-1 ΤΟΤΕ
        A[i,j] <-- j
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 




Syntax: [ Download ] [ Hide ]

! ====================   4    ================================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!
!   -1   -4   -9  -16  -25
!
!    2    8   18   32   50
!
!   -3  -12  -27  -48  -75
!
!    4   16   36   64  100
!
!   -5  -20  -45  -80 -125
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_04
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      A[i,j] <-- Α_Μ((-1)^i)*i*j*j
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Syntax: [ Download ] [ Hide ]

! =====================    5    ==============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!
!    0  0  0  0  4
!    0  0  0  2  0
!    0  0  0  0  0
!    0 -2  0  0  0
!   -4  0  0  0  0
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_05
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ i+j=N+1 ΤΟΤΕ
        A[i,j] <-- j-i
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 




Syntax: [ Download ] [ Hide ]

! =======================    6    ============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=9.
!
!   0   0   4   0   0   7   0   0  10
!
!   0   0   5   0   0   8   0   0  11
!
!   0   0   6   0   0   9   0   0  12
!
!   0   0   7   0   0  10   0   0  13
!
!   0   0   8   0   0  11   0   0  14
!
!   0   0   9   0   0  12   0   0  15
!
!   0   0  10   0   0  13   0   0  16
!
!   0   0  11   0   0  14   0   0  17
!
!   0   0  12   0   0  15   0   0  18
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_06
ΣΤΑΘΕΡΕΣ
  N=9
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ (j MOD 3)=0 ΤΟΤΕ
        A[i,j] <-- j+i
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 



Syntax: [ Download ] [ Hide ]

! =====================    7    ==============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!
! 2 0 4 0 6
! 0 3 0 5 0
! 2 0 4 0 6
! 0 3 0 5 0
! 2 0 4 0 6
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_07
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j, A[N,N]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ (i+j) MOD 2=0 ΤΟΤΕ
        A[i,j] <-- j+1
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Syntax: [ Download ] [ Hide ]

! ======================    8    =============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!
!  0  1  2  3  4
!  0  0  5  6  7
!  0  0  0  8  9
!  0  0  0  0 10
!  0  0  0  0  0
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_08
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,K, A[N,N]
ΑΡΧΗ
  k <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ i<j ΤΟΤΕ
        A[i,j] <-- K
        K <-- K+1
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Syntax: [ Download ] [ Hide ]

! =======================    9     ===========================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=6.
!
!  0  0  3  0  0  6
!  0  2  0  0  5  0
!  1  0  0  4  0  0
!  0  0  3  0  0  6
!  0  2  0  0  5  0
!  1  0  0  4  0  0
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_09
ΣΤΑΘΕΡΕΣ
  N=6
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,A[N,N]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ (i+j) MOD 3 =1 ΤΟΤΕ
        A[i,j] <-- j
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Syntax: [ Download ] [ Hide ]

! ====================    10    ==============================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=6.
!
!  0  0  0  9  0  0
!  0  0  8  0  0  0
!  0  7  0  0  0  6
!  5  0  0  0  4  0
!  0  0  0  3  0  0
!  0  0  2  0  0  0
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_10
ΣΤΑΘΕΡΕΣ
  N=6
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,K,A[N,N]
ΑΡΧΗ
  K <-- 9
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ (i+j) MOD 4 =1 ΤΟΤΕ
        A[i,j] <-- K
        K <-- K-1
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 



Syntax: [ Download ] [ Hide ]

! ========================    11     =========================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=4.
!
!  1  1  1  1
!  1  0  0  1
!  1  0  0  1
!  1  1  1  1
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_11
ΣΤΑΘΕΡΕΣ
  N=4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,A[N,N]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ (i MOD 3=1) Ή (j MOD 3=1) ΤΟΤΕ
        A[i,j] <-- 1
      ΑΛΛΙΩΣ
        A[i,j] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Syntax: [ Download ] [ Hide ]


! ========================    12     =========================
! Να αναπτύξετε πρόγραμμα το οποίο κατασκευάζει και εμφανίζει
! τον επόμενο διδιαστατο τετραγωνικό πίνακα Α[N,N] με Ν=5.
!
!   1   2   3   4   5
!
!   1   3   5   7   9
!
!   1   4   8  12  16
!
!   1   5  12  20  28
!
!   1   6  17  32  48
!
! ===========================================================

ΠΡΟΓΡΑΜΜΑ Sguare_Table_12
ΣΤΑΘΕΡΕΣ
  N=5
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,A[N,N]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΑΝ (i=1)Ή (j=1)  ΤΟΤΕ
        A[i,j] <-- j
      ΑΛΛΙΩΣ
        A[i,j] <-- A[i-1,j]+A[i-1,j-1]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ N
      ΓΡΑΨΕ_  A[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters