Τώρα είναι Σάβ 04 Ιούλ 2020 08:37 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Al Capone... *
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 23 Απρ 2005 06:31 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
! =======================================================================
! Σικάγο 1918... Ο Al Capone διευθύνει μια σπείρα από 8 συμμορίες παρανόμων...
! Στο πέρας κάθε μήνα οι συμμορίες συγκεντρώνουν τα αρχικά "κέρδη"
! τους και τα θέτουν προς αναδιανομή. Η αναδιανομή γίνεται ως εξής:
! Κάθε συμμορία δικαιούται κέρδη εφόσον έχει συνεισφέρει
! ποσό μεγαλύτερο από το 1/3 του ποσού που έχει συνεισφέρει κάθε φορά
! η συμμορία με τα περισσότερα αρχικά κέρδη ("καλύτερη συμμορία").
! Στη συνέχεια κάθε συμμορία που δικαιούται κέρδη, έκτος της "καλύτερης",
! λαμβάνει ποσό ανάλογο με το πλήθος των παρανόμων της,
! από το 50% των συνολικών κερδών του μήνα. Το υπόλοιπο 50% των κερδών
! το μοιράζεται σε ίσα μέρη η καλύτερη κάθε φορά συμμορία και ο Al Capone !!!
! Να υλοποιήσετε πρόγραμμα το οποίο:
! α. Διαβάζει το όνομα και το πλήθος των παρανόμων κάθε συμμορίας.
! β. Για ένα εξάμηνο (6 μήνες) διαβάζει τα αρχικά κέρδη ($) που συνεισφέρει
! η κάθε συμμορία στο τέλος κάθε μήνα. Υπολογίζει και εμφανίζει αντίστοιχα
! το τελικό πόσο που δικαιούται να λάβει η κάθε συμμορία (εφόσον δικαιούται),
! όπως και το ποσό που λαμβάνει ο  Al Capone κάθε μήνα.
! γ. Εμφανίζει τα ονόματα των 3 "καλύτερων" συμμοριών στο τέλος του εξαμήνου,
! δηλαδή τα ονόματα των συμμοριών με τα 3 μεγαλύτερα συνολικά ποσά.
! δ. Εμφανίζει το μήνυμα "MAFIA ... keep walking"  εφόσον τα συνολικά κέρδη
! του Al Capone είναι  περισσότερα από το άθροισμα των συνολικών ποσών
! που έχουν λάβει οι 2 "χειρότερες" συμμορίες.
! ε. Υπολογίζει το πλήθος των παρανόμων που έχουν απομείνει στη σπείρα στο
! τέλος του εξαμήνου, αφού ο Al Capone σκοτώνει όλα τα μέλη της "χειρότερης" συμμορίας.
! =======================================================================

ΠΡΟΓΡΑΜΜΑ  Al_Capone
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,Παρ[8],Σπ,Κέρδη[8,6],Σ,ΣυνΚ[6],max,Συμ,k,temp
  ΑΚΕΡΑΙΕΣ:maxK[6],Best[6],Capone[6],Ποσο[8,6],ΣΠοσο[8]
  ΧΑΡΑΚΤΗΡΕΣ: Ονμ[8],temp2
ΑΡΧΗ

!-------- α ερωτημα ---------
  Σπ <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ 'Δωσε ονομα ',i,'ης συμμορίας'
    ΔΙΑΒΑΣΕ Ονμ[i]
    ΓΡΑΨΕ 'Δωσε πλήθοςπαρανομών ',i,'ης συμμορίας'
    ΔΙΑΒΑΣΕ Παρ[i]
    Σπ <-- Σπ+Παρ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!-------- β ερωτημα ---------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ 'Δωσε αρχικά κέρδη της συμμορίας ',Ονμ[i],' για το μηνα ',j
      ΔΙΑΒΑΣΕ Κέρδη[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    Σ <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
      Σ <-- Σ+Κέρδη[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΣυνΚ[j] <-- Σ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    max <-- Κέρδη[1,j]
    Συμ <-- 1
    ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 8
      ΑΝ Κέρδη[i,j]>max ΤΟΤΕ
        max <-- Κέρδη[i,j]
        Συμ <-- i
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    maxK[j] <-- max
    Best[j] <-- Συμ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
      ΑΝ i<>Best[j] ΤΟΤΕ
        ΑΝ Κέρδη[i,j]>(1/3*maxK[j]) ΤΟΤΕ
          Ποσο[i,j] <-- Α_Μ ((Παρ[i]/Σπ)*(50/100)*ΣυνΚ[j])
        ΑΛΛΙΩΣ
          Ποσο[i,j] <-- 0
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        Ποσο[i,j] <-- Α_Μ (25/100*ΣυνΚ[j])
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Capone[j] <-- Α_Μ (25/100*ΣυνΚ[j])
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ_ Ονμ[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ_ Ποσο[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ_ ' <<Al Capone>>'
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ_ Capone[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
!-------- γ ερωτημα ---------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    Σ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      Σ <-- Σ+ Ποσο[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΣΠοσο[i] <-- Σ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 8
    ΓΙΑ j ΑΠΟ 8 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ  ΣΠοσο[j-1]<ΣΠοσο[j] ΤΟΤΕ
        temp <-- ΣΠοσο[j-1]
        ΣΠοσο[j-1] <-- ΣΠοσο[j]
        ΣΠοσο[j] <-- temp

        temp <-- Παρ[j-1]
        Παρ[j-1] <-- Παρ[j]
        Παρ[j]  <-- temp

        temp2 <-- Ονμ[j-1]
        Ονμ[j-1] <-- Ονμ[j]
        Ονμ[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Οι καλύτερες συμμορίες είναι οι:'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΡΑΨΕ Ονμ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!-------- δ ερωτημα ---------

  Σ <-- 0
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    Σ <-- Σ+Capone[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ
  ΑΝ Σ>(ΣΠοσο[7]+ΣΠοσο[8]) ΤΟΤΕ
    ΓΡΑΨΕ  'MAFIA... keep walking'
  ΤΕΛΟΣ_ΑΝ

!-------- ε ερωτημα ---------

  ΓΡΑΨΕ
  Σπ <-- Σπ-Παρ[8]
  ΓΡΑΨΕ 'Στο τελος του εξαμήνου εχουν μείνει ',Σπ, ' παρανομοι'
!----------------------------

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Αρχείο Εισόδου για την "Αντληση Δεδομένων" στη Γλωσσομάθεια
Παράθεση:
Manhatan Boys
8
Blues Brothers
7
Cuba Libre
6
Quervo
9
Cicily
10
Fast Pistols
6
Carbine
5
Hard to Die
7

55 70 90 110 45 65
75 80 65 100 85 45
105 75 40 50 90 80
45 95 65 90 35 70
55 85 95 80 100 90
100 55 45 90 80 35
40 70 90 115 45 65
90 60 100 80 80 40

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters