Τώρα είναι Δευτ 17 Φεβ 2020 04:39 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΣΤΟΧΑΣΤΙΚΟΣ ΠΙΝΑΚΑΣ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 21 Μαρ 2004 05:27 pm 
Πρόγραμμα το οποίο να εξετάζει αν ένας πίνακας είναι στοχαστικός.

:oops:
Syntax: [ Download ] [ Hide ]
!===================================================
! Ενας πίνακας ονομάζεται στοχαστικός, όταν το άθροισμα
! των στοιχείων της κάθε γραμμής του ισούται με μονάδα.
! Να γραφεί πρόγραμμα το οποίο να εξετάζει αν ο πίνακας
! που δίνει ο χρήστης είναι στοχαστικός.
!===================================================
ΠΡΟΓΡΑΜΜΑ Έλεγχος_Στοχαστικού

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:     Ν, Μ, i, j
  ΠΡΑΓΜΑΤΙΚΕΣ: Π[10,10], Άθροισμα[10]
  ΛΟΓΙΚΕΣ:     Στοχαστικός

ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε τον αριθμό των γραμμών'
    ΔΙΑΒΑΣΕ Ν
  ΜΕΧΡΙΣ_ΟΤΟΥ (Ν > 0) ΚΑΙ (Ν <= 10)

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε τον αριθμό των στηλών'
    ΔΙΑΒΑΣΕ Μ
  ΜΕΧΡΙΣ_ΟΤΟΥ ( Μ > 0) ΚΑΙ (Μ <= 10)


  Στοχαστικός <-- Αληθής
  i <-- 1
  ΟΣΟ (i <= Ν) ΚΑΙ (Στοχαστικός = Αληθής) ΕΠΑΝΑΛΑΒΕ
    Άθροισμα[i] <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Μ
      ΓΡΑΨΕ 'Δώσε το ', i, ',', j, ' στοιχείο του πίνακα'
      ΔΙΑΒΑΣΕ Π[i,j]
      Άθροισμα[i] <-- Άθροισμα[i] + Π[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Άθροισμα[i] <> 1 ΤΟΤΕ
      Στοχαστικός <-- Ψευδής
    ΤΕΛΟΣ_ΑΝ
    i <-- i + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ΑΝ Στοχαστικός = Αληθής ΤΟΤΕ
    ΓΡΑΨΕ 'Ο πίνακας είναι στοχαστικός'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο πίνακας δεν είναι στοχαστικός'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Έλεγχος_Στοχαστικού
 


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters