Τώρα είναι Πέμ 20 Φεβ 2020 02:34 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αποθήκες & προϊόντα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 12 Μαρ 2004 04:12 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Φεβ 2004 06:59 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
!---------------------------------------------------------------------
!Μια εταιρεία αποθηκεύει 30 προϊόντα σε 12 αποθήκες.Ο αλγόριθμος ζητά
!τις ποσότητες κάθε είδους σε κάθε αποθήκη και να εμφανίζει:
!α)Το σύνολο ποσότητας κάθε είδους
!β)Το σύνολο ποσότητας κάθε αποθήκης
!---------------------------------------------------------------------

ΠΡΟΓΡΑΜΜΑ ΑΠΟΘΗΚΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Κ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΑΠ[12],ΣΕΙΔ[30][30,12]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
    ΣΕΙΔ[Ι] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 12
    ΣΑΠ[Ι] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
      ΓΡΑΨΕ 'ΔΩΣΕ ΠΟΣΟΤΗΤΑ'
      ΔΙΑΒΑΣΕ Π[Ι,Κ]
      ΣΕΙΔ[Ι] <-- ΣΕΙΔ[Ι]+Π[Ι,Κ]
      ΣΑΠ[Κ] <-- ΣΑΠ[Κ]+Π[Ι,Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
    ΓΡΑΨΕ 'ΣΥΝΟΛΟ ΕΙΔΟΥΣ',ΣΕΙΔ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 12
    ΓΡΑΨΕ 'ΣΥΝΟΛΟ ΑΠΟΘΗΚΗΣ',ΣΑΠ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΠΟΘΗΚΕΣ


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters