Τώρα είναι Πέμ 20 Φεβ 2020 02:15 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Φεβ 2004 05:51 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 14 Φεβ 2004 09:23 pm
Δημοσιεύσεις: 1
Τοποθεσία: Γέρακας
Syntax: [ Download ] [ Hide ]

!====================================================================
!====================================================================
!Να γραφεί πρόγραμμα το οποίο διαβάζει τα στοιχεία ενός πολυδιάστατου
!πίνακα, με ίσο αριθμό στηλών και γραμμών, και εκτυπώνει έναν άλλο
!ανεστραμμένο, με άξονα συμμετρίας την δευτερεύουσα διαγώνιο.
!====================================================================
!====================================================================


ΠΡΟΓΡΑΜΜΑ ΑΝΤΙΣΤΡΟΦΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,Ν
  ΧΑΡΑΚΤΗΡΕΣ: Α[100,100], Β[100,100]
  ΛΟΓΙΚΕΣ: ΔΕΚΤΟΣ
ΑΡΧΗ
  ΔΕΚΤΟΣ <-- ΨΕΥΔΗΣ
  ΟΣΟ ΔΕΚΤΟΣ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Δώσε διάσταση πίνακα (μέχρι 100)'
    ΔΙΑΒΑΣΕ Ν
    ΑΝ (Ν > 100) Η (Ν<=0) ΤΟΤΕ
      ΓΡΑΨΕ 'Αριθμός μεγαλύτερος του 100 ή μικρότερος του 0'
      ΓΡΑΨΕ
    ΑΛΛΙΩΣ
      ΔΕΚΤΟΣ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΓΡΑΨΕ 'Δώσε το στοιχείο της ',i,'ης γραμμής και ',j,'ης στήλης'
      ΔΙΑΒΑΣΕ Α[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΓΡΑΨΕ_ Α[i,j],' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΑΝ (i+j-1) = Ν ΤΟΤΕ
        Β[i,j] <-- Α[i,j]
      ΑΛΛΙΩΣ
        Β[i,j] <-- Α[Ν-j+1,Ν-i+1]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΓΡΑΨΕ_ Β[i,j],' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΝΤΙΣΤΡΟΦΗ
 

_________________
Dimi


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters