Τώρα είναι Πέμ 27 Ιουν 2019 03:52 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΠΙΛΥΣΗ ΣΥΣΤΗΜΑΤΟΣ 3*3
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 05 Φεβ 2015 10:27 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 05 Φεβ 2015 09:48 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  οριζουσα_3
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, ζ, τ, κ, λ, μ, ν, ξ, ρ, D, Dx, Dy, Dz, x, y, z
ΑΡΧΗ  
  ΓΡΑΨΕ 'Δώσε συντελεστές της πρώτης εξίσωσης(με σειρά x,y,z)'  
  ΔΙΑΒΑΣΕ α, β, γ
  ΓΡΑΨΕ 'Δώσε συντελεστές της δεύτερης εξίσωσης(με σειρά x,y,z)'  
  ΔΙΑΒΑΣΕ ζ, τ, κ
  ΓΡΑΨΕ 'Δώσε συντελεστές της τρίτης εξίσωσης(με σειρά x,y,z)'                            
  ΔΙΑΒΑΣΕ μ, ν, ξ
  ΓΡΑΨΕ 'Δώσε τον σταθερό όρο της πρώτης εξίσωσης'
  ΔΙΑΒΑΣΕ δ                                                                    
  ΓΡΑΨΕ 'Δώσε τον σταθερό όρο της δεύτερης εξίσωσης'
  ΔΙΑΒΑΣΕ λ
  ΓΡΑΨΕ 'Δώσε τον σταθερό όρο της τρίτης εξίσωσης'
  ΔΙΑΒΑΣΕ ρ
  ΑΝ α=0 και β=0 και γ=0 και δ<>0 ή ζ=0 και τ=0 και κ=0 και λ<>0 ή μ=0 και ν=0 και ξ=0 και ρ<>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Το σύστημα είναι αδύνατο'
  ΑΛΛΙΩΣ
    D <-- α*(τ*ξ-κ*ν)- β*(ζ*ξ-κ*μ)+ γ*(ζ*ν-τ*μ)
    Dx <-- δ*(τ*ξ-κ*ν)-β*(λ*ξ-κ*ρ)+γ*(λ*ν-τ*ρ)
    Dy <-- α*(λ*ξ-κ*ρ)-δ*(ζ*ξ-κ*μ)+γ*(ζ*ρ-λ*μ)
    Dz <-- α*(τ*ρ-λ*ν)-β*(ζ*ρ-λ*μ)+δ*(ζ*ν-τ*μ)
    ΑΝ D=0 και Dx=0 και Dy=0 και Dz=0  ΤΟΤΕ
      ΓΡΑΨΕ 'Το σύστημα έχει άπειρες λύσεις'
    ΑΛΛΙΩΣ_ΑΝ D=0 και (Dx<>0 ή Dy<>0 ή Dz<>0)  ΤΟΤΕ
      ΓΡΑΨΕ 'Το σύστημα είναι αδύνατο'
    ΑΛΛΙΩΣ
      x <-- Dx/D
      y <-- Dy/D
      z <-- Dz/D
      ΓΡΑΨΕ 'Το σύστημα έχει λύσεις:', 'x=', x, 'y=', y, 'z=', z
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters