Τώρα είναι Τρί 02 Ιουν 2020 11:53 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΟΜΑΔΑ ΜΠΑΣΚΕΤ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 12 Οκτ 2003 02:57 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! _______________________________________________________________________________
!      
! Σε ένα σχολείο οι μαθητές που θα διαγωνιστούν για μια θέση στην ομάδα μπάσκετ του σχολείου
! είναι εκείνοι που το ύψος τους είναι μεγαλύτερο από το μέσο όρο του ύψους των μαθητών της
! συγκεκριμένης τάξης.
! Να γραφεί πρόγραμμα που να δέχεται το ύψος των 100 μαθητών της τάξης και να εμφανίζει :
!     - Το μέσο όρο του ύψους των μαθητών της τάξης.      
!     - Το ύψος του ψηλότερου μαθητή της τάξης.
!     - Το πλήθος των μαθητών που θα διαγωνιστούν για την ομάδα.
!     - Το μέσο όρο των υψών των μαθητών που θα διαγωνιστούν για την ομάδα.
! ______________________________________________________________________________

ΠΡΟΓΡΑΜΜΑ ΟΜΑΔΑ_ΜΠΑΣΚΕΤ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΥΨΟΣ[100] , ΑΘΡΟΙΣΜΑ , ΜΕΣΟΣ1 , ΜΑΧ , ΜΕΣΟΣ2
  ΑΚΕΡΑΙΕΣ: x , n
ΑΡΧΗ
  ΑΘΡΟΙΣΜΑ <-- 0
  ΓΙΑ x ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΥΨΟΣ ΤΟΥ ΜΑΘΗΤΗ Νο : ' , x
    ΔΙΑΒΑΣΕ ΥΨΟΣ[x]
    ΑΘΡΟΙΣΜΑ <-- ΑΘΡΟΙΣΜΑ + ΥΨΟΣ[x]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΣΟΣ1 <-- ΑΘΡΟΙΣΜΑ / 100
  ΜΑΧ <-- ΥΨΟΣ[1]
  ΓΙΑ x ΑΠΟ 2 ΜΕΧΡΙ 100
    ΑΝ ΥΨΟΣ[x] > ΜΑΧ ΤΟΤΕ
      ΜΑΧ <-- ΥΨΟΣ[x]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  n <-- 0
  ΑΘΡΟΙΣΜΑ <-- 0
  ΓΙΑ x ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ ΥΨΟΣ[x] > ΜΕΣΟΣ1 ΤΟΤΕ
      n <-- n + 1
      ΑΘΡΟΙΣΜΑ <-- ΑΘΡΟΙΣΜΑ + ΥΨΟΣ[x]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΣΟΣ2 <-- ΑΘΡΟΙΣΜΑ / n
  ΓΡΑΨΕ 'Ο μέσος όρος των υψών όλων των μαθητών της τάξης είναι : ', ΜΕΣΟΣ1
  ΓΡΑΨΕ 'Ο ψηλότερος μαθητής της τάξης έχει ύψος : ', ΜΑΧ
  ΓΡΑΨΕ 'Το πλήθος των μαθητών που θα διαγωνιστούν για την ομάδα είναι : ', n
  ΓΡΑΨΕ 'Ο μέσος όρος των υψών των μαθητών που θα διαγωνιστούν είναι : ' , ΜΕΣΟΣ2
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΟΜΑΔΑ_ΜΠΑΣΚΕΤ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters