Τώρα είναι Δευτ 01 Ιουν 2020 08:04 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μοναδικά στοιχεία σε Πίνακα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 10 Μάιος 2008 02:37 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Φεβ 2007 12:46 pm
Δημοσιεύσεις: 3
Να γίνει πρόγραμμα το οποίο θα δέχεται στοιχεία σε έναν πίνακα 100 θέσεων έτσι ώστε αυτά τα στοιχεία να είναι μοναδικά.


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τετ 30 Ιούλ 2008 10:58 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 02:55 pm
Δημοσιεύσεις: 12
Ελπιζω να ειναι σωστο :?:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΟΝΑΔΙΚΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Χ,Ι,Κ,Θ,ΜΟΝ[100]
  ΛΟΓΙΚΕΣ:ΥΠΑΡΧΕΙ
ΑΡΧΗ
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι+1
    ΔΙΑΒΑΣΕ Χ
    ΑΝ Ι=1 ΤΟΤΕ                                
      ΜΟΝ[1] <-- Χ
      Θ <-- 1
    ΑΛΛΙΩΣ
      Κ <-- 0
      ΥΠΑΡΧΕΙ <-- ΨΕΥΔΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        Κ <-- Κ+1
        ΑΝ ΜΟΝ[Κ]=Χ ΤΟΤΕ                    
          ΥΠΑΡΧΕΙ <-- ΑΛΗΘΗΣ
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ Κ=Θ Η ΥΠΑΡΧΕΙ=ΑΛΗΘΗΣ
      ΑΝ ΥΠΑΡΧΕΙ=ΨΕΥΔΗΣ ΤΟΤΕ
        Θ <-- Θ+1
        ΜΟΝ[Θ] <-- Χ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Θ=100
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters