Τώρα είναι Παρ 29 Μάιος 2020 03:01 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 15 Φεβ 2008 04:58 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 26 Δεκ 2004 01:29 pm
Δημοσιεύσεις: 2
Τοποθεσία: Αλεξανδρούπολη
Syntax: [ Download ] [ Hide ]
!ΕΚΠΑΙΔΕΥΤΙΚΗ ΑΣΚΗΣΗ

!ΑΝΑΖΗΤΗΣΗ τιμής ΣΕ ΠΙΝΑΚΑ 1ας Διάστασης και αποθήκευση θέσεων
! σέ άλλον πίνακα 1ας Διάστασης

!--------------------------------------------------------
!Να γραφεί πρόγραμμα σε ΓΛΩΣΣΑ που να αναζητά μια
!τιμή σε ΜΟΝΟΔΙΑΣΤΑΤΟ πίνακα και να αναφέρει αν υπάρχει,
!τις θέσεις ή θέση στις οποιες βρέθηκε τιμή αυτή.
!--------------------------------------------------------

ΠΡΟΓΡΑΜΜΑ ΑΝΑΖΗΤΗΣΗ_ΕΥΡΕΣΗ_ΑΠΟΘΗΚΕΥΣΗ_ΘΕΣΕΩΝ_Σε_πίνακα_1D

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  α,κ,χ,ρ,λ
  ΠΡΑΓΜΑΤΙΚΕΣ: τιμή_αναζήτησης ,θέση[10][10]
  χαρακτήρες: μ1,μ2

ΑΡΧΗ
  θέση[1] <-- 0
  κ <-- 1
  χ <-- 0
  Γράψε'Πληκτρολόγισε μια τιμή που ψάχεις'
  Διάβασε τιμή_αναζήτησης

  Για ρ από 1 μέχρι 10
      γράψε 'Δώσε το περιεχόμενο της',ρ,'ης θέσης το πίνακα'
      διάβασε Π[ρ]
  τέλος_επανάληψης

  μ1 <-- ' Η τιμή αναζήτησης βρέθηκε σε μία μόνο θέση '
  μ2  <-- 'Η τιμή αναζήτησης βρέθηκε στις παρακάτω θέσεις '
 
  Για α από 1 μέχρι 10
    αν Π[α]=τιμή_αναζήτησης  τότε
        θέση[κ] <-- α
        κ <-- κ+1
        χ <-- χ+1
    τέλος_αν
  τέλος_επανάληψης

  αν χ=1 τότε

     γράψε μ1,'και είναι η'
     για λ από 1 μέχρι χ
         γράψε θέση[λ],'η θέση'
     τέλος_επανάληψης

  Αλλιώς_αν χ>=2  τότε

     γράψε μ2,'και είναι με τη σειρά οι:'
     για λ από 1 μέχρι χ
         γράψε θέση[λ],'η θέση'
     τέλος_επανάληψης

  αλλιώς
      γράψε 'η τιμή που ψάχνεις δεν υπάρχει στον πίνακα'
  Τέλος_αν

 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters