Τώρα είναι Παρ 29 Μάιος 2020 04:06 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 19 Μάιος 2007 09:27 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 12 Μάιος 2007 10:21 pm
Δημοσιεύσεις: 2
Τοποθεσία: Πάτρα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΗΤΣΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Ζ,Π
  ΠΡΑΓΜΑΤΙΚΕΣ:Α[100]
ΑΡΧΗ
  Ζ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ 'ΔΟΣΕ ΤΑ ΣΤΟΙΧΕΙΑ ΣΤΑ ΟΠΟΙΑ ΘΕΣ ΝΑ ΨΑΞΕΙΣ'
    ΔΙΑΒΑΣΕ Α[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΔΟΣΕ ΤΟ ΣΤΟΙΧΕΙΟ ΠΟΥ ΘΕΣ ΝΑ ΑΝΑΖΗΤΗΣΕΙΣ'
  ΔΙΑΒΑΣΕ Β
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ Α[Ι]=Β ΤΟΤΕ
      Π <-- Ι
      Ι <-- 250
      Ζ <-- 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Ζ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΤΟ ΖΗΤΟΥΜΕΝΟ ΔΕΝ ΒΡΕΘΗΚΕ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΤΟ ΖΗΤΟΥΜΕΝΟ ΒΡΕΘΗΚΕ ΣΤΗ ΘΕΣΗ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΗΤΣΟΣ
 

_________________
Snoop:The Tire Smoker


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 20 Μάιος 2007 01:42 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Και μια μικρή παραλλαγή που γλιτώνουμε μια μεταβλητή.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΗΤΣΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Ι , Π
  ΠΡΑΓΜΑΤΙΚΕΣ : Α[100] , Β
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ 'ΔΟΣΕ ΤΑ ΣΤΟΙΧΕΙΑ ΣΤΑ ΟΠΟΙΑ ΘΕΣ ΝΑ ΨΑΞΕΙΣ'
    ΔΙΑΒΑΣΕ Α[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΣΤΟΙΧΕΙΟ ΠΟΥ ΘΕΣ ΝΑ ΑΝΑΖΗΤΗΣΕΙΣ'
  ΔΙΑΒΑΣΕ Β
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ Α[Ι] = Β ΤΟΤΕ
      Π <-- Ι
      Ι <-- 250
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ I = 250 ΤΟΤΕ                             ! Αν δεν το έβρισκε θα ήταν I = 101
    ΓΡΑΨΕ 'ΤΟ ΖΗΤΟΥΜΕΝΟ ΔΕ ΒΡΕΘΗΚΕ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΤΟ ΖΗΤΟΥΜΕΝΟ ΒΡΕΘΗΚΕ ΣΤΗ ΘΕΣΗ' , Π
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΗΤΣΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters