Τώρα είναι Πέμ 16 Ιούλ 2020 07:56 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αναζήτηση_Μέγιστης_Οφειλής
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 16 Φεβ 2004 01:34 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
! ===================================================================================
! Να γραφεί πρόγραμμα το οποίο να ζητά από το χρήστη τη λίστα
! με τα ονόματα πελατών και τα χρήματα σε Ευρώ τα οποία χρωστάει
! ο κάθε πελάτης μιας επιχείρησης. Κατόπιν να αναζητά και να
! εμφανίζει το όνομα του πελάτη που χρωστά τα περισσότερα χρήματα.
! Ο αριθμός των πελατών που θα δώσει ο χρήστης να καθορίζεται από
! τον ίδιο και να είναι μεταξύ 1 και 100.
! ===================================================================================
! panos giannakopoulos
! ===================================================================================
ΠΡΟΓΡΑΜΜΑ Αναζήτηση_Μέγιστης_Οφειλής

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:    n, i, Χρήματα[100], max, θέση_Max
  ΧΑΡΑΚΤΗΡΕΣ:  Όνομα[100]

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε το πλήθος των πελατών (1-100)'
    ΔΙΑΒΑΣΕ n
  ΜΕΧΡΙΣ_ΟΤΟΥ (n>=1) ΚΑΙ (n<=100)

  ΓΙΑ i ΑΠΟ 1 μέχρι n
    ΓΡΑΨΕ  'Δώσε το όνομα του πελάτη ' , i
    ΔΙΑΒΑΣΕ Όνομα[i]
    ΓΡΑΨΕ  'Δώσε τα χρήματα που χρωστά'
    ΔΙΑΒΑΣΕ Χρήματα[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  max <-- Χρήματα[1]        
  θέση_Max <-- 1

  ΓΙΑ i ΑΠΟ 2 μέχρι n
    ΑΝ Χρήματα[i] > max ΤΟΤΕ
      max <-- Χρήματα[i]
      θέση_Max <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο πελάτης που χρωστά τα περισσότερα χρήματα είναι: ', Όνομα[θέση_Max]

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αναζήτηση_Μέγιστης_Οφειλής
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters