Τώρα είναι Δευτ 01 Ιουν 2020 07:18 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εύρεση τιμής σε πίνακα (2)
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 13 Απρ 2003 04:32 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Το παρακάτω πρόγραμμα προτάθηκε από το συνάδελφο κ. Αθανάσιο Βρακόπουλο σαν εναλλακτική μέθοδος αναζήτησης.

Syntax: [ Download ] [ Hide ]
! -------------------------------------------
! ΤΟ ΠΡΟΓΡΑΜΜΑ ΖΗΤΑΕΙ ΤΙΜΕΣ ΓΙΑ ΕΝΑΝ ΠΙΝΑΚΑ Π
! ΚΑΙ ΜΙΑ ΤΙΜΗ ΠΡΟΣ ΑΝΑΖΗΤΗΣΗ. ΣΤΗ ΣΥΝΕΧΕΙΑ
! ΕΜΦΑΝΙΖΕΙ ΣΕ ΠΟΙΑ ΘΕΣΗ ΥΠΑΡΧΕΙ Η ΖΗΤΟΥΜΕΝΗ
! ΤΙΜΗ (ΑΝ ΥΠΑΡΧΕΙ).
! -------------------------------------------

ΠΡΟΓΡΑΜΜΑ ΕΥΡΕΣΗ_ΤΙΜΗΣ_ΣΕ_ΠΙΝΑΚΑ
ΣΤΑΘΕΡΕΣ
  Ν=10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΖΗΤ_ΤΙΜΗ, ΘΕΣΗ, Π[Ν], Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε την ', Ι, 'η τιμή του πίνακα:'
    ΔΙΑΒΑΣΕ Π[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Δώσε την τιμή που αναζητάς:'
  ΔΙΑΒΑΣΕ ΖΗΤ_ΤΙΜΗ

!Σας προτείνω την παρακάτω λύση

  Ι <-- 1
  ΟΣΟ (Π[Ι]<>ΖΗΤ_ΤΙΜΗ) ΚΑΙ (Ι<Ν) ΕΠΑΝΑΛΑΒΕ
    Ι <-- Ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Π[Ι]=ΖΗΤ_ΤΙΜΗ  ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή ', ΖΗΤ_ΤΙΜΗ, ' βρέθηκε στην ', Ι, 'η θέση'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η τιμή ', ΖΗΤ_ΤΙΜΗ, ' δε βρέθηκε στον πίνακα'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΕΥΡΕΣΗ_ΤΙΜΗΣ_ΣΕ_ΠΙΝΑΚΑ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters