Τώρα είναι Δευτ 01 Ιουν 2020 07:25 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 13 Απρ 2003 11:27 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 25 Μαρ 2003 03:33 pm
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
!===========================================
! Να φτιαχτεί πρόγραμμα το οποίο να δέχεται τις μετρήσεις της
! μόλυνσης 10 ημερών και να τις καταχωρεί σε ένα πίνακα και
! επιστρέφει τις ημέρες που έχουμε κορυφή, δηλ. αυτές που
! παρουσιάζουν μόλυνση μεγαλύτερη από την επόμενη και προηγούμενη
! μέρα. Η μόλυνση παίρνει τιμές από 1 έως 100.
!==============================================

ΠΡΟΓΡΑΜΜΑ ΑΣΚ_ΜΟΛΥΝΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Α[10]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΙΜΕΣ ΜΟΛΥΝΣΗΣ ΓΙΑ ΤΗΝ ',Ι,' ΗΜΕΡΑ'
    ΔΙΑΒΑΣΕ Α[Ι]
    ΑΝ (Α[Ι]<0) Η (Α[Ι]>100) ΤΟΤΕ
      ΓΡΑΨΕ 'ΞΑΝΑΔΩΣΕ ΤΙΜΗ'
      Ι <-- Ι-1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 9
    ΑΝ (Α[Ι]>Α[Ι-1]) ΚΑΙ (Α[Ι]>Α[Ι+1]) ΤΟΤΕ
      ΓΡΑΨΕ 'Η ',Ι,' ΗΜΕΡΑ ΠΑΡΟΥΣΙΑΖΕΙ ΚΟΡΥΦΗ ΜΕ ΜΟΛΥΝΣΗ '[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

_________________
Elizatsi


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters