Τώρα είναι Παρ 29 Μάιος 2020 03:51 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 12:38 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! =============================================================================
! Η τρίτη τάξη ενός λυκείου αποτελείται από 100 μαθητές και μαθήτριες.
! Να γραφεί πρόγραμμα το οποίο :
!  α) δέχεται το φύλο κάθε μαθητή ( Α αν είναι αγόρι ή Κ αν είναι κορίτσι ).
!  β) δέχεται το ύψος και το βάρος κάθε μαθητή ή μαθήτριας.
!  γ) υπολογίζει και εμφανίζει πόσα κορίτσια έχουν ύψος μεγαλύτερο
!     από το μέσο όρο του ύψους των αγοριών.
!  δ) υπολογίζει και εμφανίζει πόσα αγόρια έχουν βάρος μικρότερο
!     από το μέσο όρο του βάρους των κοριτσιών.
!  ε) υπολογίζει και εμφανίζει το μέσο όρο του ύψους των αγοριών
!     με βάρος πάνω από 90 kg.
! στ) υπολογίζει και εμφανίζει το μέσο όρο του βάρους των κοριτσιών
!     με ύψος κάτω από 1,6 m.
!
!  ΠΑΡΑΤΗΡΗΣΗ : Στην είσοδο κάθε δεδομένου να γίνεται έλεγχος εγκυρότητας.
!               Δεν είναι δεκτά :
!               - χαρακτηρισμός φύλου διαφορετικός απο Α ή Κ
!               - βάρη μικρότερα από 40 ή μεγαλύτερα από 150 kg και
!               - ύψη μικρότερα από 1 ή μεγαλύτερα από 2,20 m.
! =============================================================================
ΠΡΟΓΡΑΜΜΑ PIN05
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , n
  ΠΡΑΓΜΑΤΙΚΕΣ: h[100] , w[100] , s , mo
  ΧΑΡΑΚΤΗΡΕΣ: f[100]                          
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
!  α) =======                          
    ΓΡΑΨΕ 'Δώσε το φύλο του μαθητή ή της μαθήτριας Νο:',i,' (Α για αγόρι ή Κ για κορίτσι)'
    ΔΙΑΒΑΣΕ f[i]
    ΟΣΟ f[i] <> 'Α' ΚΑΙ f[i] <> 'Κ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος.Α για αγόρι ή Κ για κορίτσι. Ξαναδώσε'
      ΔΙΑΒΑΣΕ f[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  β) =======
    ΓΡΑΨΕ 'Δώσε το ύψος'
    ΔΙΑΒΑΣΕ h[i]
    ΟΣΟ h[i] < 1 ή h[i] > 2.2 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ h[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'και το βάρος'
    ΔΙΑΒΑΣΕ w[i]
    ΟΣΟ w[i] < 40 ή w[i] > 150 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ w[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  γ) =======                                                                        
  s <-- 0
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ f[i] = 'A' ΤΟΤΕ
      n <-- n + 1         ! Πλήθος αγοριών.
      s <-- s + h[i]      ! ’θροισμα υψών αγοριών.
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mo <-- s/n              ! Μέσος όρος ύψους αγοριών.
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ f[i] = 'Κ' ΚΑΙ h[i] > mo ΤΟΤΕ
      n <-- n + 1         ! Πλήθος κοριτσιών με ύψος μεγαλύτερο από το μέσο ύψος των αγοριών.
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ n,'κορίτσια έχουν ύψος μεγαλύτερο από το μέσο όρο του ύψους των αγοριών'
!  δ) =======
  s <-- 0
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ f[i] = 'Κ' ΤΟΤΕ
      n <-- n + 1         ! Πλήθος κοριτσιών.
      s <-- s + w[i]      ! ’θροισμα βαρών κοριτσιών.
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mo <-- s/n              ! Μέσος όρος βάρους κοριτσιών.
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ f[i] = 'A' ΚΑΙ w[i] < mo ΤΟΤΕ
      n <-- n + 1         ! Πλήθος αγοριών με βάρος μικρότερο από το μέσο βάρος των κοριτσιών.
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ n,'αγόρια έχουν βάρος μικρότερο από το μέσο όρο του βάρους των κοριτσιών'
!  ε) =======
  s <-- 0
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ f[i] = 'Α' ΚΑΙ w[i] > 90 ΤΟΤΕ
      n <-- n + 1         ! Πλήθος αγοριών με βάρος πάνω από 90 kg.
      s <-- s + h[i]      ! ’θροισμα των υψών τους.
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mo <-- s/n              ! Μέσος όρος ύψους αγοριών με βάρος πάνω από 90 kg.
  ΓΡΑΨΕ 'O μέσος όρος ύψους των αγοριών με βάρος πάνω από 90 kg είναι :',mo
! στ) =======
  s <-- 0
  n <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΑΝ f[i] = 'Κ' ΚΑΙ h[i] < 1.6 ΤΟΤΕ
      n <-- n + 1         ! Πλήθος κοριτσιών με ύψος κάτω από 1,6 m.
      s <-- s + w[i]      ! ’θροισμα των βαρών τους.
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  mo <-- s/n              ! Μέσος όρος βάρους κοριτσιών με ύψος κάτω από 1,6 m.
  ΓΡΑΨΕ 'O μέσος όρος βάρους των κοριτσιών με ύψος κάτω από 1,6 m είναι :',mo
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ΠΑΡΑΤΗΡΗΣΗ :
! Οι μεταβλητές s , n και mo χρησιμοποιούνται σε κάθε ερώτημα για διαφορετικό σκοπό αφού
! έχει βγεί το αντίστοιχο μήνυμα, οπότε το περιεχόμενό τους δε χρειάζεται πλέον και μπορεί
! να αλλάξει. Αν θέλαμε να βγούν τα μηνύματα όλα μαζί στο τέλος θα έπρεπε να δώσουμε διαφο-
! ρετικά ονόματα στις μεταβλητές. Έτσι και αλλιώς η εμφάνιση στην οθόνη θα είναι ακριβώς η
! ίδια.
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters