Τώρα είναι Παρ 28 Φεβ 2020 09:04 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εύρεση τιμής σε πίνακα (1)
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:55 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ======================================================================
! Να γίνει πρόγραμμα που να ζητάει τιμές για έναν πίνακα ακεραίων
! αριθμών 10 θέσεων και μια τιμή προς αναζήτηση. Στη συνέχεια να
! εμφανίζει σε ποια θέση υπάρχει η ζητούμενη τιμή. Αν δεν τη βρει, να
! εμφανίζει ενημερωτικό μήνυμα.
! ======================================================================


ΠΡΟΓΡΑΜΜΑ Εύρεση_τιμής_σε_πίνακα

ΣΤΑΘΕΡΕΣ
  Ν=10

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ζητ_τιμή, θέση, Π[Ν], i
  ΛΟΓΙΚΕΣ: βρέθηκε

ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε την ', i, 'η τιμή του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε την τιμή που αναζητάς:'
  ΔΙΑΒΑΣΕ ζητ_τιμή
  βρέθηκε <-- ΨΕΥΔHΣ

  i <-- 1
  ΟΣΟ (βρέθηκε=ΨΕΥΔHΣ) ΚΑΙ (i<=Ν) ΕΠΑΝΑΛΑΒΕ
    ΑΝ Π[i]=ζητ_τιμή ΤΟΤΕ
      βρέθηκε <-- ΑΛΗΘΗΣ
      θέση <-- i
    ΑΛΛΙΩΣ
      i <-- i+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ βρέθηκε=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή ', ζητ_τιμή, ' βρέθηκε στη θέση ', θέση, ' του πίνακα'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η τιμή ', ζητ_τιμή, ' δε βρέθηκε στον πίνακα'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_τιμής_σε_πίνακα

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters