Τώρα είναι Παρ 29 Μάιος 2020 04:09 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Έυρεση διαφορετικών αριθμών
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 05 Φεβ 2005 01:17 am 
Να φτιαχτεί πράγραμμα που θα δεχεται Ν αριθμούς και θα φτιάχνει πίνακα με τους διαφορετικούς απ'αυτούς τους αριθμούς και θα τους εμφανίζει (χωρίς να τους έχει ταξινομήσει) καθώς και τον σύνολό τους.


Κορυφή
  
 
 Θέμα δημοσίευσης: Διαφορετικοί Αριθμοί *
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 05 Φεβ 2005 11:23 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Φιλε Giozis καλώς ήρθες στην παρέα μας,
Το ζήτημα που θέτεις, αποτελεί ένα όμορφο πρόβλημα :wink: , και ιδού μια από τις αρκετές λύσεις του.

Syntax: [ Download ] [ Hide ]
! ===================================================================
! Να αναπτυχθεί πρόγραμμα που θα δέχεται 100 ακέραιους αριθμούς
! και θα επιστρέφει το πλήθος των διαφορετικών αριθμών που εισήχθησαν
! καθώς και τους αριθμούς αυτούς.
! Για παράδειγμα εάν διαβάστηκαν οι αριθμοί
! 1, 23 ,1, 2, 2, 6, 34, 1, 23, 7      
! το πλήθος των διαφορετικών αριθμών είναι 6
! και οι αριθμοί αυτοί είναι οι:  1, 23, 2,  6, 34, 7
! ===================================================================

ΠΡΟΓΡΑΜΜΑ Διαφορετικοί_Αριθμοί
ΣΤΑΘΕΡΕΣ
  N=100
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,Δ,Α,Β[N]
  ΛΟΓΙΚΕΣ: όμοιο
ΑΡΧΗ

  ΓΡΑΨΕ 'Δωσε 1ο αριθμό'
  ΔΙΑΒΑΣΕ Β[1]           ! Ο πρώτος αριθμός διαβάζεται και καταχωρείται σε πίνακα Β
  Δ <-- 1                ! Η μεταβλητή Δ μετράει το πλήθος των διαφορετικών αριθμών
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ N
    ΓΡΑΨΕ 'Δωσε ',i, 'ο αριθμό'
    ΔΙΑΒΑΣΕ Α
    όμοιο <-- ψευδής
    j <-- 1
    ΟΣΟ (j<=Δ) ΚΑΙ (όμοιο=ψευδής) ΕΠΑΝΑΛΑΒΕ    ! Ελέγχεται κάθε φορά ο αριθμός Α
      ΑΝ  Β[j]=Α ΤΟΤΕ                          ! έαν υπάρχει ήδη στον πίνακα Β
        όμοιο <-- αληθής
      ΤΕΛΟΣ_ΑΝ
      j <-- j+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ όμοιο=ψευδής ΤΟΤΕ    ! Στον πίνακα Β καταχωρούνται ΜΟΝΟΝ οι διαφορετικοί αριθμοί
      Δ <-- Δ+1
      Β[Δ] <-- Α
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'βρέθηκαν ',Δ, ' διαφορετικοί αριθμοί οι οποίοι είναι οι παρακάτω'
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Δ
    ΓΡΑΨΕ Β[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters