Τώρα είναι Παρ 29 Μάιος 2020 03:21 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εισπράξεις εταιριών
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 11 Μαρ 2004 07:00 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Φεβ 2004 06:59 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
! ----------------------------------------------------
! Το πρόγραμμα ζητά τα ονόματα 10 εταιρειών και 40 ημερήσιες εισπράξεις κάθε μιας.
! Υστερα εμφανίζει το σύνολο κάθε εταιρείας,κάθε μέρας,την χειρότερη εταιρεία και
! την χειρότερη μέρα.
! ----------------------------------------------------

ΠΡΟΓΡΑΜΜΑ BICTOR
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Κ,ΘΕΣ,ΘΕΣ2
  ΠΡΑΓΜΑΤΙΚΕΣ: Σ[10],ΕΙ[40],Σ2[40],ΜΙΝ,ΜΙΝ2
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜ[3]

ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΕΤΑΙΡΕΙΑΣ'
    ΔΙΑΒΑΣΕ ΟΝΟΜ[Ι]
    Σ[Ι] <-- 0
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 40
      ΓΡΑΨΕ 'ΔΩΣΕ ΕΙΣΠΡΑΞΗ'
      ΔΙΑΒΑΣΕ ΕΙ[Κ]
      Σ[Ι] <-- Σ[Ι]+ΕΙ[Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΣΥΝΟΛΟ ΕΤΑΙΡΕΙΑΣ',ΟΝΟΜ[Ι],'ΕΙΝΑΙ'[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 40
    Σ2[Κ] <-- 0
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
      Σ2[Κ] <-- Σ2[Κ]+ΕΙ[Κ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΣΥΝΟΛΟ',Κ,'ΜΕΡΑΣ ΕΙΝΑΙ',Σ2[Κ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΙΝ <-- Σ[1]
  ΘΕΣ <-- 1
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 10
    ΑΝ ΜΙΝ<Σ[Ι] ΤΟΤΕ
      ΜΙΝ <-- Σ[Ι]
      ΘΕΣ <-- Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΙΝ2 <-- Σ2[Ι]
  ΘΕΣ2 <-- 1
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 40
    ΑΝ ΜΙΝ2<Σ2[Ι] ΤΟΤΕ
      ΜΙΝ2 <-- Σ2[Ι]
      ΘΕΣ2 <-- Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Η ΧΕΙΡΟΤΕΡΗ ΕΤΑΙΡΕΙΑ ΕΙΝΑΙ Η',ΟΝΟΜ[ΘΕΣ]
  ΓΡΑΨΕ 'Η ΜΕΡΑ ΜΕ ΤΙΣ ΛΙΓΟΤΕΡΕΣ ΕΙΣΠΡΑΞΕΙΣ ΕΙΝΑΙ Η',ΘΕΣ2

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ BICTOR

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters