Τώρα είναι Παρ 29 Μάιος 2020 04:32 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Φεβ 2004 05:33 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Σε αυτήν την παραλλαγή της αναζήτησης εμφανίζεται όσες φορές θέλει ο χρήστης η ζητούμενη τιμή. Η μεταβλητή Φορές είναι εκείνη που δείχνει πόσες φορές θα εμφανιστεί. Παραμετροποώντας την άσκηση μπορούμε να την κάνουμε να ψάχνει μόνο για την πρώτη τιμή, ή και για όλες !!!!
Syntax: [ Download ] [ Hide ]
!=============================================================
! Να γραφεί πρόγραμμα το οποίο vα διαβάζει τα στοιχεία ενός
! πίνακα Π, ο οποίος έχει n θέσεις (όπου n από 5 μέχρι 100)
! και μία τιμή προς αναζήτηση.
! Στη συνέχεια να ζητάει από το χρήστη πόσες φορές θέλει να
! αναζητήσει τη ζητούμενη τιμή, από 3 μέχρι 5 φορές και να
! εμφανίζει τις θέσεις στις οποίες βρέθηκε η ζητούμενη τιμή,
! αν υπάρχει, διαφορετικά να εμφανίζει σχετικό μήνυμα που να
! ενημερώνει ότι δε βρέθηκε η ζητούμενη τιμή.
!=============================================================
! (panos giannakopoulos)
!=============================================================

ΠΡΟΓΡΑΜΜΑ Εύρεση_n_πρώτων_τιμών_σε_πίνακα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Τιμή_Αναζήτησης, Θέση, Π[10], i, n, Φορές, Μετρητής
  ΛΟΓΙΚΕΣ: Βρέθηκε

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε το πλήθος των στοιχείων του πίνακα: (5-100)'
    ΔΙΑΒΑΣΕ n
  ΜΕΧΡΙΣ_ΟΤΟΥ (n >= 5) ΚΑΙ (n <= 100)

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n
    ΓΡΑΨΕ 'Δώσε την ', i, 'η τιμή του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε την τιμή που ψάχνεις:'
  ΔΙΑΒΑΣΕ Τιμή_Αναζήτησης

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Πόσες φορές να αναζητήσω την τιμή; (3-5)'
    ΔΙΑΒΑΣΕ Φορές
  ΜΕΧΡΙΣ_ΟΤΟΥ (Φορές >= 3) ΚΑΙ (Φορές <= 5)

  Βρέθηκε <-- ΨΕΥΔΗΣ
  Μετρητής <-- 0
  i <-- 1
  ΟΣΟ (i<=10) ΚΑΙ (Βρέθηκε=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
    ΑΝ Π[i]= Τιμή_Αναζήτησης ΤΟΤΕ
      Θέση <-- i
      Μετρητής <-- Μετρητής + 1
      ΓΡΑΨΕ 'Η τιμή ', Τιμή_Αναζήτησης, ' βρέθηκε για ', Μετρητής, 'η φορά'
      ΓΡΑΨΕ 'στην ', Θέση, 'η θέση του πίνακα.'
      ΑΝ Μετρητής = Φορές ΤΟΤΕ
        Βρέθηκε <-- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ Βρέθηκε=ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή: ', Τιμή_Αναζήτησης, ' δε βρέθηκε στον πίνακα.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_n_πρώτων_τιμών_σε_πίνακα
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters