Τώρα είναι Παρ 29 Μάιος 2020 03:09 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Φεβ 2004 05:29 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Σε αυτήν την παραλλαγή της αναζήτησης, εμφανίζονται όλες οι θέσεις στις οποίες βρέθηκε η ζητούμενη τιμή.
Syntax: [ Download ] [ Hide ]
!=============================================================
! Να γραφεί πρόγραμμα το οποίο να διαβάζει τα στοιχεία ενός
! πίνακα Π 10 θέσεων και μία τιμή προς αναζήτηση.
! Στη συνέχεια να εμφανίζει όλες τις θέσεις στις οποίες
! βρέθηκε η ζητούμενη τιμή, αν υπάρχει, διαφορετικά να
! εμφανίζει σχετικό μήνυμα που να ενημερώνει ότι δε βρέθηκε
! η ζητούμενη τιμή.
!=============================================================
! (panos giannakopoulos)
!=============================================================

ΠΡΟΓΡΑΜΜΑ Εύρεση_όλων_των_τιμών_σε_πίνακα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Τιμή_Αναζήτησης, Θέση, Π[10], i
  ΛΟΓΙΚΕΣ: Βρέθηκε

ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε την ', i, 'η τιμή του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε την τιμή που ψάχνεις:'
  ΔΙΑΒΑΣΕ Τιμή_Αναζήτησης
  Βρέθηκε <-- ΨΕΥΔΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΝ Π[i]= Τιμή_Αναζήτησης ΤΟΤΕ
      Βρέθηκε <-- ΑΛΗΘΗΣ
      Θέση <-- i
      ΓΡΑΨΕ 'Η τιμή ', Τιμή_Αναζήτησης, ' βρέθηκε στην ', Θέση, 'η θέση του πίνακα.'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ Βρέθηκε=ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή: ', Τιμή_Αναζήτησης, ' δε βρέθηκε στον πίνακα.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_όλων_των_τιμών_σε_πίνακα
 


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 23 Δεκ 2004 02:43 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 15 Δεκ 2004 04:26 am
Δημοσιεύσεις: 10
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!------------------------------------------------------------------------
! netnick
!------------------------------------------------------------------------
! Μια άλλη προσέγγιση είναι να καταχωρηθούν οι θέσεις των στοιχειων σε πίνακα
! ΝΓΠ (= Να Γραψετε Προγραμμα) που βρισκει σε μη ταξινομημενο πίνακα,
! όλες τις εμφανίσεις ενός αριθμού ΚΕΥ και τους τοποθετεί σε πίνακα (ΘΕΣΗ)
! Στο τέλος να εμφανίζει το πλήθος και τις θέσεις εμφάνισης του ζητούμενου αριθμού.
! Και εδώ το flag είναι περιττό.
! done (ή ΒΡΕΘΗΚΕ) =  true <=> ΘΕΣΗ > 0 <=> ΒΡΕΘΗΚΕ
! done (ή ΒΡΕΘΗΚΕ) = false <=> ΘΕΣΗ = 0 <=> ΔΕΝ ΒΡΕΘΗΚΕ
!------------------------------------------------------------------------
ΠΡΟΓΡΑΜΜΑ ANAZHTHSH
ΣΤΑΘΕΡΕΣ
  Ν = 100
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[Ν],Ι,ΚΕΥ,ΠΛΗΘΟΣ,ΘΕΣΗ[Ν]
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΑ ΣΤΟΙΧΕΙΑ ΤΟΥ ΠΙΝΑΚΑ'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΔΙΑΒΑΣΕ Π[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Ο ΠΙΝΑΚΑΣ ΠΕΡΙΕΧΕΙ 100 ΑΚΕΡΑΙΟΥΣ ΑΠΟ 1 ΕΩΣ 30.'
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΌ ΠΟΥ ΘΑ ΑΝΑΖΗΤΗΣΩ ΣΤΟΝ ΠΙΝΑΚΑ: '
  ΔΙΑΒΑΣΕ ΚΕΥ

! Η ΑΝΑΖΗΤΗΣΗ
  ΠΛΗΘΟΣ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ ΚΕΥ = Π[Ι] ΤΟΤΕ
      ΠΛΗΘΟΣ <-- ΠΛΗΘΟΣ + 1
      ΘΕΣΗ[ΠΛΗΘΟΣ] <-- Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΕΜΦΑΝΙΣΗ ΑΠΟΤΕΛΕΣΜΑΤΩΝ - ΜΗΝΥΜΑΤΩΝ
  ΑΝ ΠΛΗΘΟΣ > 0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΒΡΕΘΗΚΕ ',ΠΛΗΘΟΣ,' ΦΟΡΕΣ, ΣΤΙΣ ΠΑΡΑΚΑΤΩ ΘΕΣΕΙΣ ΤΟΥ ΠΙΝΑΚΑ Π'
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΠΛΗΘΟΣ-1
      ΓΡΑΨΕ ΘΕΣΗ[Ι],','
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ΘΕΣΗ[ΠΛΗΘΟΣ]
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΔΕΝ ΥΠΑΡΧΕΙ ΣΤΟΝ ΠΙΝΑΚΑ.'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Βερύκιος Νίκος


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters