Τώρα είναι Παρ 29 Μάιος 2020 02:56 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Φεβ 2004 05:25 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Σε αυτήν την παραλλαγή της αναζήτησης ψάχνει την τελευταία θέση στην οποία βρέθηκε η ζητούμενη τιμή.
Syntax: [ Download ] [ Hide ]
!=============================================================
! Να γραφεί πρόγραμμα το οποίο να διαβάζει τα στοιχεία ενός
! πίνακα Π 10 θέσεων και μία τιμή προς αναζήτηση.
! Στη συνέχεια να εμφανίζει την τελευταία θέση στην οποία
! βρέθηκε η ζητούμενη τιμή, αν υπάρχει, διαφορετικά να
! εμφανίζει σχετικό μήνυμα που να ενημερώνει ότι δε βρέθηκε
! η ζητούμενη τιμή.
!=============================================================
! (panos giannakopoulos)
!=============================================================

ΠΡΟΓΡΑΜΜΑ Εύρεση_τελευταίας_τιμής_σε_πίνακα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Τιμή_Αναζήτησης, Θέση, Π[10], i
  ΛΟΓΙΚΕΣ: Βρέθηκε

ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε την ', i, 'η τιμή του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε την τιμή που ψάχνεις:'
  ΔΙΑΒΑΣΕ Τιμή_Αναζήτησης
  Βρέθηκε <-- ΨΕΥΔΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΑΝ Π[i]= Τιμή_Αναζήτησης ΤΟΤΕ
      Βρέθηκε <-- ΑΛΗΘΗΣ
      Θέση <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ Βρέθηκε=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή ', Τιμή_Αναζήτησης, ' βρέθηκε για τελευταία φορά'
    ΓΡΑΨΕ 'στην ', Θέση, 'η θέση του πίνακα.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η τιμή: ', Τιμή_Αναζήτησης, ' δε βρέθηκε στον πίνακα.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_τελευταίας_τιμής_σε_πίνακα
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters