Τώρα είναι Παρ 29 Μάιος 2020 03:05 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Φεβ 2004 05:22 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Ξεκινώντας μία σειρά ασκήσεων πάνω στην αναζήτηση σε μονοδιάστατο πίνακα, αρχίζω με αυτήν η οποία αναζητεί μία τιμή και εμφανίζει την πρώτη θέση στην οποία βρέθηκε.
Syntax: [ Download ] [ Hide ]
!=============================================================
! Να γραφεί πρόγραμμα το οποίο vα διαβάζει τα στοιχεία ενός
! πίνακα Π 10 θέσεων και μία τιμή προς αναζήτηση.
! Στη συνέχεια να εμφανίζει την πρώτη θέση στην οποία βρέθηκε
! η ζητούμενη τιμή, αν υπάρχει, διαφορετικά να εμφανίζει              
! σχετικό μήνυμα που να ενημερώνει ότι δε βρέθηκε η ζητούμενη
! τιμή.
!=============================================================
! (panos giannakopoulos)
!=============================================================

ΠΡΟΓΡΑΜΜΑ Εύρεση_πρώτης_τιμής_σε_πίνακα                                                        

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Τιμή_Αναζήτησης, Θέση, Π[10], i
  ΛΟΓΙΚΕΣ: Βρέθηκε

ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε την ', i, 'η τιμή από τις 10 του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε την τιμή που ψάχνεις:'
  ΔΙΑΒΑΣΕ Τιμή_Αναζήτησης
  Βρέθηκε <-- ΨΕΥΔΗΣ

  i <-- 1
  ΟΣΟ (i<=10) ΚΑΙ (Βρέθηκε=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
    ΑΝ Π[i]= Τιμή_Αναζήτησης ΤΟΤΕ
      Βρέθηκε <-- ΑΛΗΘΗΣ
      Θέση <-- i
    ΤΕΛΟΣ_ΑΝ
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ Βρέθηκε=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή ', Τιμή_Αναζήτησης, ' βρέθηκε για πρώτη φορά'
    ΓΡΑΨΕ 'στην ', Θέση, 'η θέση του πίνακα.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η τιμή: ', Τιμή_Αναζήτησης, ' δε βρέθηκε στον πίνακα.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_πρώτης_τιμής_σε_πίνακα
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters