Τώρα είναι Δευτ 16 Σεπ 2019 11:34 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ρέστα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 03 Μαρ 2010 01:31 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Παράθεση:
βρίσκει το ελάχιστο ποσό σε νομίσματα


Κώδικας:
ΠΡΟΓΡΑΜΜΑ  λιγότερα_ρέστα

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: λεφτά[15],ρέστα,υπολ
  ΑΚΕΡΑΙΕΣ:μετρ,χ,ποσο
  ΛΟΓΙΚΕΣ: αλλα

ΑΡΧΗ

  λεφτά[1] <-- 500
  λεφτά[2] <-- 200
  λεφτά[3] <-- 100
  λεφτά[4] <-- 50
  λεφτά[5] <-- 20
  λεφτά[6] <-- 10
  λεφτά[7] <-- 5
  λεφτά[8] <-- 2
  λεφτά[9] <-- 1
  λεφτά[10] <-- 0.50
  λεφτά[11] <-- 0.20
  λεφτά[12] <-- 0.10
  λεφτά[13] <-- 0.05
  λεφτά[14] <-- 0.02
  λεφτά[15] <-- 0.01


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε τα ρέστα που σου οφείλονται:'
    ΔΙΑΒΑΣΕ ρέστα
  ΜΕΧΡΙΣ_ΟΤΟΥ ρέστα>0

  υπολ <-- ρέστα
  μετρ <-- 1
  χ <-- 1
  αλλα <-- ΨΕΥΔΗΣ

  γράψε'Το ποσό της οφηλής είναι.'
  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    αν λεφτά[μετρ]<=υπολ τοτε
      υπολ <-- υπολ-λεφτά[μετρ]
      αλλα <-- ΨΕΥΔΗΣ
         !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      αν αλλα=ΨΕΥΔΗΣ και χ>=1  τότε
        ποσο <-- χ
        αν υπολ-λεφτά[μετρ]<0  τοτε
          γράψε_ 'χ',ποσο, λεφτά[μετρ],''
          χ <-- 0
        ΤΕΛΟΣ_ΑΝ
      τέλος_αν
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      χ <-- χ+1
    ΑΛΛΙΩΣ
      αλλα <-- ΑΛΗΘΗΣ
      μετρ <-- μετρ+1

    ΤΕΛΟΣ_ΑΝ

  ΜΕΧΡΙΣ_ΟΤΟΥ υπολ=0
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters