Τώρα είναι Τρί 18 Φεβ 2020 05:05 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Μαρ 2009 12:21 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΟΡΙΣΤΕ ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΠΟΥ ΜΕΤΑΤΡΕΠΕΙ ΕΝΑΝ ΑΡΙΘΜΟ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΥΣΤΗΜΑ ΣΕ ΔΥΑΔΙΚΟ (ΚΑΙΡΟ ΤΟ ΠΑΛΕΥΑ , ΚΑΙ ΕΠΙΤΕΛΟΥΣ ΤΑ ΚΑΤΑΦΕΡΑ)
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΕΤΑΤΡΟΠΗ_ΑΠΟ_ΔΕΚΑΔΙΚΟ_ΣΕ_ΔΥΑΔΙΚΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι , Κ , Ξ , Τ , Ρ , ΜΑΧ , Δ[100] , Ψ[100]  , Μ
  ΠΡΑΓΜΑΤΙΚΕΣ: Π , Χ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΜΕΤΑΤΡΑΠΕΙ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΥΣΤΗΜΑ ΣΤΟ ΔΥΑΔΙΚΟ'
  ΔΙΑΒΑΣΕ Τ
  Χ <-- Τ
  Π <-- 0
  Ι <-- 0
  ΜΑΧ <-- 0
  ΟΣΟ Χ-Π<>0 ΚΑΙ Χ>0 ΕΠΑΝΑΛΑΒΕ
    Ι <-- Ι + 1
    Μ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Μ <-- Μ + 1
      Π <-- 2^Μ
    ΜΕΧΡΙΣ_ΟΤΟΥ Π>=Χ
    ΑΝ ΜΑΧ<Μ ΤΟΤΕ
      ΜΑΧ <-- Μ - 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Π>Χ ΤΟΤΕ
      Ψ[Ι] <-- Μ - 1
      Χ <-- Χ - 2^(Μ-1)
    ΑΛΛΙΩΣ_ΑΝ Χ=Π ΤΟΤΕ
      Ψ[Ι] <-- Μ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΜΑΧ MOD 7 = 0 ΤΟΤΕ
    Κ <-- ΜΑΧ DIV 8
  ΑΛΛΙΩΣ
    Κ <-- (ΜΑΧ DIV 7)+1
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Κ*8
    Δ[Ξ] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ Ι
    Ρ <-- Ψ[Ξ]
    Δ[Ρ+1] <-- 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ',Τ,'ΣΤΟ ΔΥΑΔΙΚΟ ΣΥΣΤΗΜΑ ΓΡΑΦΕΤΑΙ:'
  ΓΙΑ Ξ ΑΠΟ Κ*8 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΑΝ Ξ MOD 8 = 0 ΤΟΤΕ
      ΓΡΑΨΕ_ ''
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ_ Δ[Ξ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΕΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΟΠΩΣ ΠΑΝΤΑ ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΟΙ ΔΙΟΡΘΩΣΕΙΣ :mrgreen: :D

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Τελευταία επεξεργασία από Sudavar{SP} και Τετ 10 Ιουν 2009 01:44 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Μαρ 2009 02:49 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Μήπως θα μπορούσες να εξηγήσεις με ποιον τρόπο βρίσκεις τον αριθμό στο δυαδικό γιατί δεν τον κατάλαβα :oops: ?
Το παρακάτω είναι ένας (κατά την γνώμη μου, ίσως επειδή δεν κατάλαβα τον παραπάνω) πιο απλώς τρόπος. Ο τρόπος που αναπαριστά είναι το :
Διαιρούμε τον αριθμό με το 2 και βρίσκουμε το ακέραιο πηλίκο, το οποίο στην συνέχεια το διαιρούμε με το 2. Αυτό επαναλαμβάνετε μέχρι να βρούμε πηλίκο 1. Ο αριθμός στο δυαδικό είναι τα υπόλοιπα γραμμένα με το τελευταίο πηλίκο και από την τελευταία διαίρεση προς την 1η π.χ. ο αριθμός στο δεκαδικό είναι το 10,
10/2= 5 ,υπόλοιπο 0
5/2=2 ,υπόλοιπο 1
2/2=1, υπόλοιπο 0
Ο αριθμός στο δυαδικό είναι το 1010 (1 πηλίκο τελευταίας, 0 υπόλοιπο τελευταίας, 1 υπόλοιπο 2ης , 0 υπόλοιπο 1ης )

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΔΕΚ_ΣΕ_ΔΥΑΔ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ, ΑΡ, Ι, ΔΥΑΔ, Ψ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΜΕΤΑΤΡΑΠΕΙ ΑΠΟ ΤΟ ΔΕΚΑΔΙΚΟ ΣΥΣΤΗΜΑ ΣΤΟ ΔΥΑΔΙΚΟ'
  ΔΙΑΒΑΣΕ ΑΡ
  Ι <-- 0
  ΔΥΑΔ <-- 0
  Ψ <-- ΑΡ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι + 1
    Χ <-- Ψ MOD 2
    Ψ <-- Ψ DIV 2
    ΔΥΑΔ <-- ΔΥΑΔ + ( Χ*(10^(Ι-1)))
  ΜΕΧΡΙΣ_ΟΤΟΥ Ψ <=0
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ',ΑΡ,'ΣΤΟ ΔΥΑΔΙΚΟ ΣΥΣΤΗΜΑ ΓΡΑΦΕΤΑΙ:'
  ΓΙΑ Χ ΑΠΟ (((Ι-1) DIV 8)+1)*8 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΑΝ Χ MOD 8=0 ΤΟΤΕ
      ΓΡΑΨΕ_ ' '
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ_ (ΔΥΑΔ MOD (10^(Χ)))DIV (10^(Χ-1))
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters