Τώρα είναι Τρί 29 Σεπ 2020 01:41 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: max kai min 100 akeraiwn...
ΔημοσίευσηΔημοσιεύτηκε: Τρί 25 Νοέμ 2008 05:42 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 15 Νοέμ 2008 07:40 pm
Δημοσιεύσεις: 2
Exw mia askhsh kai exw mperdeyti apisteyta. Elpizw na me Boithisete.

Na grapsete programma pou tha briskei to megisto kai to elaxisto stoixeio enos monodiastatou pinaka 100 akeraiwn kathws kai tis theseis aytwn twn stoixeiwn ston pinaka.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: max kai min 100 akeraiwn...
ΔημοσίευσηΔημοσιεύτηκε: Τετ 26 Νοέμ 2008 04:50 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Αν κατάλαβα καλά ζητάει κάτι τέτοιο. Το 1ο από το δεύτερο διαφέρουν στο ότι το 2ο επιστρέφει όλες τις θέσεις των τιμών στον πίνακα ενώ το 1ο μόνο την πρώτη θέση στην οποία βρήκε την κάθε μια.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ max_min_8esi
ΣΤΑΘΕΡΕΣ
  Ν=100
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΙΝ[Ν], ΘΑ, ΘΒ, Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΤΟ, ', Ι, 'ΣΤΟΙΧΕΙΟ ΤΟΥ ΠΙΝΑΚΑ.'
    ΔΙΑΒΑΣΕ ΠΙΝ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΘΑ <-- 1   !ΜΑΧ
  ΘΒ <-- 1   !ΜΙΝ
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΑΝ ΠΙΝ[Ι] > ΠΙΝ[ΘΑ] ΤΟΤΕ
      ΘΑ <-- Ι
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΠΙΝ[Ι] < ΠΙΝ[ΘΒ] ΤΟΤΕ
      ΘΒ <-- Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Το μέγιστο στοιχείο του πίνακα είναι το', ΠΙΝ[ΘΑ], 'και βρίσκετε στην θέση', ΘΑ
  ΓΡΑΨΕ 'Το ελάχιστο στοιχείο του πίνακα είναι το', ΠΙΝ[ΘΒ], 'και βρίσκετε στην θέση', ΘΒ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ max_min_8esi
ΣΤΑΘΕΡΕΣ
  Ν=100
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΙΝ[Ν], ΘΑ, ΘΒ, Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΤΟ, ', Ι, 'ΣΤΟΙΧΕΙΟ ΤΟΥ ΠΙΝΑΚΑ.'
    ΔΙΑΒΑΣΕ ΠΙΝ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΘΑ <-- ΠΙΝ[1]   !ΜΑΧ
  ΘΒ <-- ΠΙΝ[1]   !ΜΙΝ
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΑΝ ΠΙΝ[Ι] > ΘΑ ΤΟΤΕ
      ΘΑ <-- ΠΙΝ[Ι]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΠΙΝ[Ι] < ΘΒ ΤΟΤΕ
      ΘΒ <-- ΠΙΝ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ_ 'Το μέγιστο στοιχείο του πίνακα είναι το', ΘΑ, 'και βρίσκετε στις/ην θέσεις/η'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ ΠΙΝ[Ι] = ΘΑ ΤΟΤΕ
      ΓΡΑΨΕ_ Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
  ΓΡΑΨΕ_ 'Το ελάχιστο στοιχείο του πίνακα είναι το', ΘΒ, 'και βρίσκετε στις/ην θέσεις/η'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΑΝ ΠΙΝ[Ι] = ΘΒ ΤΟΤΕ
      ΓΡΑΨΕ_ Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters